1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

ASUS aiMesh dropping WiFi Calling during switch

Discussion in 'ASUS Wireless' started by ShinyRobot, Feb 9, 2018.

  1. thiggins

    thiggins Mr. Easy Staff Member

    Joined:
    May 18, 2008
    Messages:
    13,631
    Why did you replace the Extremes?

    We track 11kvr and other roaming assistance and many other attributes in the Wi-Fi System and AP Finders. kv support is most common in Wi-Fi/Mesh systems and enterprise-grade APs. Support in lower end APs is not so much.
     
  2. OzarkEdge

    OzarkEdge Very Senior Member

    Joined:
    Feb 14, 2018
    Messages:
    775
    Location:
    USA

    Thanks.

    I'll leave your question for the OP.

    OE
     
  3. thiggins

    thiggins Mr. Easy Staff Member

    Joined:
    May 18, 2008
    Messages:
    13,631
    Sorry, I wasn't paying attention to who I was talking to. :)
     
  4. sfx2000

    sfx2000 Part of the Furniture

    Joined:
    Aug 11, 2011
    Messages:
    13,585
    Location:
    San Diego, CA
    Airports are one of the more vendor agnostic players out there in consumer space - they generally work with everything. They do a lot of things that other vendors don't do - one good case is how they handle guest networking - they do it as a VLAN, so it works to extend the guest network, and it also works well with managed switches - no other vendor does this.

    Only item I've found with them is the FCC power level on 5GHz, and that's fair...
     
    OzarkEdge likes this.
  5. Madders

    Madders New Around Here

    Joined:
    Mar 20, 2018
    Messages:
    3
    I lost quite a few hours on this exact same ios wifi calling issue after I enabled Aimesh, but finally got it working and it’s now roaming flawlessly between my three nodes.

    This post by Richard on getting wifi calling working on google's mesh is what worked for me on aimesh: https://productforums.google.com/forum/#!msg/googlewifi/3SmTK0Vk1P4/YTJLGg5TCAAJ

    Note that I set static IP both on the iphone and on the router to avoid DHCP delays when roaming (I saw something in logs, but this may not be needed).

    In hope of saving others some pain, here’s my setup and other settings I tweaked to get wifi calling working on aimesh:
    --Aimesh with AC5300 base with 2 AC68U nodes (1 node ethernet backbone to base, 2nd is wireless)
    --2 SSIDS, for 2.4ghz and 5ghz, with my iphone on 5ghz (2.4ghz is noisy where I live)
    --Smartconnect: off
    --Roaming assistant: on, -65 dBm
    --Airtime Fairness: off
    --Universal Beamforming: off
    --Port 500 & 4500 UDP forwarded to same ports on my now-static iPhone IP
     
    ROBERT CARLSON MD and OzarkEdge like this.
  6. alixvincent

    alixvincent Occasional Visitor

    Joined:
    Dec 12, 2017
    Messages:
    17

    Would you be kind enough to send me snapshots of your port forwarding settings for 500 and 4500. Port forwarding is always a challenge for me. Thanks in advance.
     
    ROBERT CARLSON MD likes this.
  7. Madders

    Madders New Around Here

    Joined:
    Mar 20, 2018
    Messages:
    3
    Here you go, good luck!
    https://imgur.com/a/LsWLa
    [​IMG]

    Also, I forgot to mention I did previously reset my network settings on my iphone as per OzarksEdge post above - if above config still not working that would be the final step to try. I noticed my iphone wifi calling was improved after resetting my network settings, but it didn't work fully nor last more than a few hours until I did the above static IP and port forwarding changes.
     
    Adimord and ROBERT CARLSON MD like this.
  8. ROBERT CARLSON MD

    ROBERT CARLSON MD New Around Here

    Joined:
    Feb 18, 2018
    Messages:
    8
    Thanks for working on this. I've complained to the ASUS support people about this issue and after several back and forths they are still working on it.

    Here's something else that worked for me: In the LAN settings, I disabled "auto" NAT acceleration so that the router is forced to use the CPU for NAT acceleration rather than hardware. Apparently enabling any kind of port forwarding has the same effect of forcing NAT acceleration to the CPU.

    This has improved ATT WIFI Calling greatly here and it may give a clue as to what the real problem: the WIFI Calling IPSEC packets may not be transiting the router correctly with hardware NAT acceleration enabled.

    I'm using 2 AC1900p and 1 AC68U with latest firmware, and Airtime Fairness is off.

    -- R Carlson MD
     
  9. OzarkEdge

    OzarkEdge Very Senior Member

    Joined:
    Feb 14, 2018
    Messages:
    775
    Location:
    USA
    I wonder if Android Google Fi WiFi Calling is not experiencing this issue because it runs over its VPN...

    OE
     
  10. ROBERT CARLSON MD

    ROBERT CARLSON MD New Around Here

    Joined:
    Feb 18, 2018
    Messages:
    8
    Here's the latest update from ASUS:


    Re:Re: Re: WiFi calling do not work;ASUS Service No=N1803132303

    [email protected]
    6:15 AM (9 hours ago)
    [​IMG]
    [​IMG]
    [​IMG]
    to me
    [​IMG]


    (*Please do not change the subject line when you reply to this email)

    Hello ROBERT CARLSON M.D.

    Thank you for your response to ASUS product support, my name is John S.

    I appreciate your patience and for giving us time to come up with a resolution for your case. After collaborating with our support staff, we have verified that the next firmware update that we will release will fix this issue.

    Do let us know if further assistance is needed. Thank you for choosing ASUS. Your case number is:N1803132303.

    Regards,
    John S
    ASUS Product Support
     
  11. Madders

    Madders New Around Here

    Joined:
    Mar 20, 2018
    Messages:
    3
    I ended up having to revisit this issue as my wifi calling stopped working again after a week or so. I tried updating to the firmware release that just came out, but it seems that doesn't yet fix this issue as ASUS' support email to Robert indicated. Have others seen this working now with the new firmware?
    Fortunately, after a bunch of troubleshooting and resets, I followed your suggestion above to just disable auto NAT acceleration and BOOM - fixed! My wifi calling turned on instantly after I applied the setting. Not sure why I didn't start there... Now I'm roaming between all my nodes with wifi calling. Also, it didn't seem to have any negative impact on my network speeds when I disabled NAT acceleration based on some basic testing I did. Thanks Robert and hopefully I'm not back here again in another week...
     
  12. Kemper Martin

    Kemper Martin New Around Here

    Joined:
    Oct 8, 2018
    Messages:
    5
    I switched DD-WRT and I have hardware version A6.
    I no longer have problems on 2.4ghz or 5ghz.
    Use the trx files not the bin extensions.
    If you use .bin you may not be able to go back to Merlin or ASUS stock firmware.
    I had another AC88U and I used the .bin I was not able to get back.
    asus_rt-ac88u-firmware 36527.trx