Asus AIMesh Guest network issues

HKcow

Regular Contributor
Tried to using the same switch, but disabled link aggregation in the switch and my main router. The same AiMesh Guest Network issue still occur. I also tried to tag all the ports in the QNAP swtich into a new VLAN ID (before that all the prots are untagged), this also not solving the guest network issue. Anyhow I still can't get an IP if the device is connecting to Guest Network through the AiMesh Node.
I found an articale for TP-Link, though not ASUS, but I guess the GN implementation is somehow the same?


Do we know what's the VLAN ID being used by AiMesh GN such that I can try to setup in my managed switch?

On the other hand I have tried to mitigate the switch and using direct connection between 2 RT-AX92U, confirmed that Guest Network working for 2.4G, but not working for 5G1 or 5G2 (strange...).
 
Last edited:

Just_Karma

Occasional Visitor
Tried to using the same switch, but disabled link aggregation in the switch and my main router. The same AiMesh Guest Network issue still occur. I also tried to tag all the ports in the QNAP swtich into a new VLAN ID (before that all the prots are untagged), this also not solving the guest network issue. Anyhow I still can't get an IP if the device is connecting to Guest Network through the AiMesh Node.

@HKcow I would make sure you are running current Asus official firmware. Then I would try connecting the Aimesh Node to the Aimesh Primary Router directly without using your QNAP switch at all. So that should be the WAN port of your Aimesh Node to a LAN port on your Aimesh Primary Router. Then setup the guest network, ensure Access Intranet as Disable on your guest network setup. Ensure this is for the Guest network 1 and not 2 or 3.

If it works when a client connects to the Aimesh node guest network you should see it's IP address as x.x.101.x if it's on the 2.4GHz guest network and x.x.102.x for 5G-1 and x.x.103.x for 5G-2.

Once you've got a working configuration without the QNAP switch in the setup then introduce it. The Aimesh node and Aimesh Primary router will be sending ethernet frames on VLAN 501, 502 and 503. Make sure your QNAP switch is not removing these VLAN ids on the frames between Aimesh devices.

My problem was my managed Tp-link switch was behaving very unpredictably and was removing VLAN tags so now I don't network my Aimesh devices using managed Tp-link switch. I am using a POE unmanaged Tp-link switch and it is working correctly.
 
Last edited:

pinkgrae

Regular Contributor
Update: asuswrt-merlin 386.5_alpha2 seems to have resolved the issue with guest 1 not propagating properly to wired aimesh nodes.

I have been successfully running this firmware on both router and node for a couple of hours now. Guest 1 is behaving as expected with intranet access disabled.
 

Just_Karma

Occasional Visitor
It does all work for me running latest offical Asus firmware on my setup with guest network 1, access to intranet set to disabled. That's also good to hear it works with Merlin firmware as well. I can't test Merlin firmware as it's not supported on Asus XT8.

I am running all hard cabled ethernet backhaul to my primary router. It initially failed to work for me due to a faulty TP-link switch which was connecting the Aimesh nodes to the Primary Asus Router.

My set up is:
  • Asus XT8, running 3.0.0.4.386.46061 - Primary Router
  • Asus XD4, running 3.0.0.4.386.46061 - Aimesh Node 1 and 2
  • Asus RT-AC86U, running 3.0.0.4.386.45956 - Aimesh Node 3
 
Last edited:

HKcow

Regular Contributor
@HKcow I would make sure you are running current Asus official firmware. Then I would try connecting the Aimesh Node to the Aimesh Primary Router directly without using your QNAP switch at all. So that should be the WAN port of your Aimesh Node to a LAN port on your Aimesh Primary Router. Then setup the guest network, ensure Access Intranet as Disable on your guest network setup. Ensure this is for the Guest network 1 and not 2 or 3.

If it works when a client connects to the Aimesh node guest network you should see it's IP address as x.x.101.x if it's on the 2.4GHz guest network and x.x.102.x for 5G-1 and x.x.103.x for 5G-2.

Once you've got a working configuration without the QNAP switch in the setup then introduce it. The Aimesh node and Aimesh Primary router will be sending ethernet frames on VLAN 501, 502 and 503. Make sure your QNAP switch is not removing these VLAN ids on the frames between Aimesh devices.

My problem was my managed Tp-link switch was behaving very unpredictably and was removing VLAN tags so now I don't network my Aimesh devices using managed Tp-link switch. I am using a POE unmanaged Tp-link switch and it is working correctly.

Thanks for your suggestion. After adding the 501 VLAN ID into the related ports as tagged into the QNAP switch, I can now have the Guest Network 2.4G setup with Intranet Access = disable and Sync to Node = All. Devices can connect to the Guest Network through the main router or through the node. One point to note is if I enable link aggregation this setup will not work. In the QNAP switch I can also tag the VLAN ID into the LAG group, however this cannot help with the Guest Network. The error is a bit wired, unlike origianl error that said cannot get an IP address, this time the error is wrong Wifi Password.

However, as I mentioned before, seems in the latest official firmware the RT-AX92U has issues with the Guest Network 5.0G - 1 and 5.0G - 2. I can't connect any devices if enabled these 2 Guest Networks. even without using any switch and connect to the main Router only.
 

Smallnetbuilderguy

New Around Here
Both my router AC5300 (386.46065) and ZenWifi AC XT8 nodes (v.3.0.0.4.386.46122) are on latest firmware. All stock firmwares.


Is there a reason that devices are not able to connect "Guest Network 1" through these nodes, even though these nodes are physical closer/in between the main router and some far away devices?

I even tried binding some devices to nodes but they just keep connecting to main router. See screenshot:
Screen Shot 2022-03-03 at 6.14.03 PM.png


Are nodes still not allowing devices to connect via Guest Network 1 (2.4 GHz) SSID? I already tried toggling "Enabled/Disabled" for "Access Intranet" -- no difference.

I don't have any switches between main router and nodes. One node is using 5GHz-2 link and one is using Ethernet cable uplink -- both nodes don't have any 2.4 GHz devices connect to them.

I also tried Roaming - Enabled in WiFi > Professional to -60, -65, -70 etc, no difference.

What's a good troubleshooting next step?
 
Last edited:

Eon83

New Around Here
Both my router AC5300 (386.46065) and ZenWifi AC XT8 nodes (v.3.0.0.4.386.46122) are on latest firmware. All stock firmwares.


Is there a reason that devices are not able to connect "Guest Network 1" through these nodes, even though these nodes are physical closer/in between the main router and some far away devices?

I even tried binding some devices to nodes but they just keep connecting to main router. See screenshot:
View attachment 39971

Are nodes still not allowing devices to connect via Guest Network 1 (2.4 GHz) SSID? I already tried toggling "Enabled/Disabled" for "Access Intranet" -- no difference.

I don't have any switches between main router and nodes. One node is using 5GHz-2 link and one is using Ethernet cable uplink -- both nodes don't have any 2.4 GHz devices connect to them.

I also tried Roaming - Enabled in WiFi > Professional to -60, -65, -70 etc, no difference.

What's a good troubleshooting next step?
I am having similar issue as well. I had AX86U (Merlin 386.5) as the main router and AX82U (Official firmware) as AiMesh node.

I had change the guest network setting for Sync to AiMesh Node to All. But all my device cannot connect to guest network 1 (both 2.4 & 5 GHz) via the AiMesh node but working fine if it is connecting via main router.

Update:
Tried downgrade AX86U back to Merlin 386.4 and AiMesh work as intended. It seems like Merlin 386.5 is not compatible with the latest AX82U firmware.
 
Last edited:

tsanga

Regular Contributor
Update:
Tried downgrade AX86U back to Merlin 386.4 and AiMesh work as intended. It seems like Merlin 386.5 is not compatible with the latest AX82U firmware.
That’s too bad - I was about to go from Merlin 386.4 to 386.5 on my main AiMesh with a node running stock FW. However I’m still on AC models and not AX.

Is anyone else losing guest network functionality with 386.5?
 

pinkgrae

Regular Contributor
That’s too bad - I was about to go from Merlin 386.4 to 386.5 on my main AiMesh with a node running stock FW. However I’m still on AC models and not AX.

Is anyone else losing guest network functionality with 386.5?
I've been on 386.5 on both AC86U router and AC68U Aimesh node for over 18 days now. Guest network (and everything else) behaving as expected, and solid as a rock. Very different experience from the issues with 386.4 that I previously reported in this thread.
 

tsanga

Regular Contributor
I've been on 386.5 on both AC86U router and AC68U Aimesh node for over 18 days now. Guest network (and everything else) behaving as expected, and solid as a rock. Very different experience from the issues with 386.4 that I previously reported in this thread.
Great to hear that Merlin is working on both main and node.
 

Eon83

New Around Here
Yep - see post #74 above - the issue seems to arise from the following combination: (1) wired backhaul to node, (2) asuswrt-merlin firmware on node, and (3) intranet access disabled on guest 1. Which means you can (only) achieve working guest 1 via nodes, with intranet access disabled, in one of two ways:
  • Wired backhaul: must run stock firmware on node; OR
  • Wireless backhaul: can run either asuswrt-merlin or stock firmware on node.
Just tried updating my AiMesh router (AX86U)) from 386.4 to 386.5_2 and it broke the guest network on Aimesh node. All my devices can't connect to my guest network thru the Aimesh node. But the issue was resolved after I switch my Aimesh network from Wired backhaul to Wireless Backhaul. Seems like my setup has the same issue mentioned by pinkgrae in one of the earlier post. This issue wasn't there when my Aimesh router (AX86U) was in Merlin 386.4 firmware.

My current setup:
Asus RT-AX86U on Merlin 386.5_2 (AiMesh Router)
Asus RT-AX82U on Stock 386_46061 (AiMesh Node)
 

pinkgrae

Regular Contributor
Just tried updating my AiMesh router (AX86U)) from 386.4 to 386.5_2 and it broke the guest network on Aimesh node. All my devices can't connect to my guest network thru the Aimesh node. But the issue was resolved after I switch my Aimesh network from Wired backhaul to Wireless Backhaul. Seems like my setup has the same issue mentioned by pinkgrae in one of the earlier post. This issue wasn't there when my Aimesh router (AX86U) was in Merlin 386.4 firmware.

My current setup:
Asus RT-AX86U on Merlin 386.5_2 (AiMesh Router)
Asus RT-AX82U on Stock 386_46061 (AiMesh Node)
No, my issue with guest 1 on merlin 386.4 was different as it only occurred with the node on merlin, whereas yours is on stock. It would disappear when I did any of the following: (a) used wireless rather than wired backhaul, (b) put node on stock rather than merlin firmware, or (c) enable intranet access.

Anyway, currently not experiencing any issues with guest 1 with both router and node on merlin 386.5_2, wired backhaul, and intranet access disabled.
 
Last edited:

tsanga

Regular Contributor
No, my issue with guest 1 on merlin 386.4 was different as it only occurred with the node on merlin, whereas yours is on stock. It would disappear when I did any of the following: (a) used wireless rather than wired backhaul, (b) put node on stock rather than merlin firmware, or (c) enable intranet access.

Anyway, currently not experiencing any issues with guest 1 with both router and node on merlin 386.5_2, wired backhaul, and intranet access disabled.
My current configuration is also not experiencing any issues.

Asus RT-AC1750 B1 on Merlin 386.5_2 AC68U (AiMesh router)
Asus RT-AC66U B1 on Stock 386_48262 (AiMesh node)
Guest 1, wired backhaul, intranet access disabled
 

gorstj

Occasional Visitor
This issue seems very similar to my issue at the following thread.

Can you confirm the same absence of adding eth0 to the bridge on the node when intranet access disabled?

 

Daan1976

New Around Here
One point to note is if I enable link aggregation this setup will not work. In the QNAP switch I can also tag the VLAN ID into the LAG group, however this cannot help with the Guest Network. The error is a bit wired, unlike origianl error that said cannot get an IP address, this time the error is wrong Wifi Password.

Have you, or anybody else, already got link aggregation in combination with aimesh working ?
Because i have the same issue.
 

GSpock

Senior Member
Same issue here: unable to get IP address from Nodes when on GN 1 (intranet access disabled, of course), connection to main is OK.
Set-up is AX86U as main router, 2 AX56U as nodes, all running Merlin 386.5_2
 
Last edited:

gorstj

Occasional Visitor
Same issue here: unable to get IP address from Nodes when on GN 1 (intranet access disabled, of course), connection to main is OK.
Set-up is AX86U as main router, 2 AX56U as nodes, all running Merlin 386.5_2

What happens if nodes are on stock firmware?
What happens if main is on stock firmware too?

(i.e. can we isolate if it is a stock firmware issue or is it a Merlin issue)
 

gorstj

Occasional Visitor
I only use Merlin ..

If you move your nodes (and then main if needed) back to stock it will be a way if isolating the issue. I appreciate it is not a 'fix' and is just a trial. (although not sure what benefit of running Merlin on nodes is)
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top