What's new

Asus RT-66BU-B1 (one primary, one AP) - Quest Airlink works through the Primary, but constantly disconnects through AP

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
So, I wanted a dedicated AP for my Quest 2, for Airlink. And, this isn't necessarily an Airlink specific puzzle, so I thought I'd see what you folks think.

My original topology was all hard-wired (ethernet), one primary router Asus RT-66BU-B1 hooked directly (via switches) to the gaming PC, and primary router's WiFi linked to the Quest. Router is on the 3rd floor, use the Quest on the 2nd floor. PC is also on the 2nd floor, not that it matters. Everything works fine. There are plenty of other WiFi devices that also use the primary router, but they don't cause Airlink disruptions when the Quest is on the primary router.

I added a dedicated AP, also a Asus RT-66BU-B1 (not a mesh AP, just a regular AP), near my 2nd floor Quest area. If I connect the Quest through it, Airlink constantly drops - sometimes immediately, sometimes 5 minutes into a game - but it ALWAYS drops. Again, the only device connected to it's WiFi is the Quest. The only LAN connections to it are to the upstairs router (via switches), and to my gaming PC right next to the AP. There are very minor tweaks (from factory defaults) to the AP's settings - different WiFi channel (no DFS channels), 5 Ghz radio only, different SSID. I've tested the network speed (to external sources) with my laptop hooked to the AP, and it's plenty fast - ping rates are 1ms from AP to gaming PC. I've made sure all routers have up-to-date firmware. I've tried an Asus factory reset on the AP, and it still drops Airlink. I have a 3rd Asus RT-66BU-B1 which I've factory reset and set up identical to the AP, to rule out any hardware issues, and it has the same exact problem. To remove all the switches and cables out of the loop, I went upstairs and hooked my AP directly to the router. And, Airlink still drops.

I know this isn't an Oculus support forum, and I don't expect anyone to be experts on that. Since the connection works flawlessly through my primary router's WiFi, but not through a dedicated AP's WiFi, hard-wired to the router, I really think this has something to do with the AP or primary router settings and some sort of sudden latency, or burst bandwidth disruption, based on those settings. Either that, or maybe my gaming PC is seeing the Quest connection differently since it's coming via the AP to the primary router, and not simply from a direct WiFi connection to the primary router. I've tried to enable Game Mode on my Asus primary router, and put my Quest and Desktop on the list of priority gaming devices. That didn't help. For clarification, when I say Airlink drops, it means the connection between the Oculus Desktop App on my gaming PC and the Quest has failed - the data rate likely can't be sustained. The Quest still says it's connected to the WiFi, even when it drops Airlink.

I've tried pretty much every combination of 5 Ghz WiFi channels and channel widths. It doesn't help. I've scanned the neighbor WiFi's, and although there are WiFis on pretty much every channel, I don't think they are sufficiently close/strong to cause a massive disruption. If you want to further scratch your head: as yet another test, I set up my Gaming PC as a dedicated hotspot, with the same frequency 5Ghz channel, and width, as the AP, and connected my Quest directly to that. Worked flawlessly. I'm almost out of hair to pull out, so I figured I'd see if you guys have any guesses. This AP setup should work - it doesn't. I've tried a ton of other things, but I don't want to write an entire book.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!