Release ASUS RT-AC68U Firmware version 3.0.0.4.386.45934

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Tech9

Part of the Furniture
A question before I potentially kill an Asus router:
Flashing the large firmware in GUI is perhaps okay, the router will use what applies according to hardware version. What happens if I want to revert back to stock one of my AC68U Tomato routers using Mini CFE Web? I guess, the safer way it to flash 41994 first, then update in GUI.
 

SCInterest

New Around Here
Problem with AIMesh...

AC1900U (master) -> AC66U B1 (node, cable backhaul) both updated to this version.

Wifi guest 1 (5g) isolated from intranet don't resolve IP to clients (clients can connect to wifi but don't get an IP). Works if connected to master but not in nodes.

It Works in previous version :(

Edit: AC66U B1 firmware downgraded to version 3.0.0.4.386.43129 ... works again
I have the same issue with the guest network. I apologize in advance if this has already been answered many times but I'm new to this forum. Where can I download prior firmware versions for RT-AC68U? Thanks for any help.

Problem with AIMesh...

AC1900U (master) -> AC66U B1 (node, cable backhaul) both updated to this version.

Wifi guest 1 (5g) isolated from intranet don't resolve IP to clients (clients can connect to wifi but don't get an IP). Works if connected to master but not in nodes.

It Works in previous version :(

Edit: AC66U B1 firmware downgraded to version 3.0.0.4.386.43129 ... works again
 

SCInterest

New Around Here
The latest and previous firmware versions are here:
Click "Show all" to list the previous versions.
Thanks Wouterv. I did check there but missed the "show all". I downloaded the prior version and installed it on the router and the guest networks are now working well back. I guess it's a matter to wait for the next firmware release and see if this issue has been fixed.
 

wouterv

Very Senior Member
For me the Bios & Firmware page looks like this:
1637816651933.png
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top