What's new

asus RT-AC88U "netstat -nl" CPU usage ?

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here

I turn to you because I encounter something weird with my router asus rtac88u. I noticed that my CPU usage was rather high that is higher than 50% permanently while I do nothing special.
I disabled a maximum of things but nothing helps!

Does someone have an idea ?

thanks in advance
Have hit this same condition. Logged into my switch and noted CPU2 was 100%. SSH in, top, CPU2 100%. PS and discovered a "sh -c netstat -nl" call / spawn taking CPU. Manually running "netstat -nl" (no name resolution; list listening ports) just loops and loops the listening port output over and over never ending....

... busbox netstat bug?
I think it is something to do with aiprotect. I have a RT-AC5300 and when I turn it off the CPU goes back to normal. I’ve tried resetting everything and setup manually but comes back after 1/2 a day with aiprotect on. It started happening after the most resent Merlin firmware.
Strangely, this issue just 'went away' and I haven't seen it re-occur since I first reported it 07/15. If I run 'netstat -nl' now it terminates correctly and doesn't constant loop.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!