ASUS RT-AX86U 2.4GHz Auto forces 40MHz BW

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

ComputerAbuser

Occasional Visitor
I recently installed an ASUS RT-AX86U to replace my old Netgear Nighthawk R7000. I wanted to add AX and my R7000 was running really old firmware (Netgear removed the media server from newer versions of the firmware, so I was stuck on firmware that was several years old).

So far everything is great, except when using 2.4GHz. I want to limit the router to a 20MHz channel bandwidth. If I choose Auto Wireless Mode (to gain 802.11N support) it switches to 40MHz even if I have the channel bandwidth set to 20Mhz. I verified this with LinSSID in Linux.

I have to use Wireless Mode Legacy in order for it to correctly use only 20MHz.

Is this just a bug in the firmware? I can live with only B/G on 2.4GHz, but I shouldn't have to. My old R7000 had no problem doing B/G/N on 2.4GHz with a 20MHz channel.
 

joe scian

Very Senior Member
I recently installed an ASUS RT-AX86U to replace my old Netgear Nighthawk R7000. I wanted to add AX and my R7000 was running really old firmware (Netgear removed the media server from newer versions of the firmware, so I was stuck on firmware that was several years old).

So far everything is great, except when using 2.4GHz. I want to limit the router to a 20MHz channel bandwidth. If I choose Auto Wireless Mode (to gain 802.11N support) it switches to 40MHz even if I have the channel bandwidth set to 20Mhz. I verified this with LinSSID in Linux.

I have to use Wireless Mode Legacy in order for it to correctly use only 20MHz.

Is this just a bug in the firmware? I can live with only B/G on 2.4GHz, but I shouldn't have to. My old R7000 had no problem doing B/G/N on 2.4GHz with a 20MHz channel.

Do we just guess the firmware you are using ? No such issue on Merlin 386.2_2
 

bbunge

Part of the Furniture
I recently installed an ASUS RT-AX86U to replace my old Netgear Nighthawk R7000. I wanted to add AX and my R7000 was running really old firmware (Netgear removed the media server from newer versions of the firmware, so I was stuck on firmware that was several years old).

So far everything is great, except when using 2.4GHz. I want to limit the router to a 20MHz channel bandwidth. If I choose Auto Wireless Mode (to gain 802.11N support) it switches to 40MHz even if I have the channel bandwidth set to 20Mhz. I verified this with LinSSID in Linux.

I have to use Wireless Mode Legacy in order for it to correctly use only 20MHz.

Is this just a bug in the firmware? I can live with only B/G on 2.4GHz, but I shouldn't have to. My old R7000 had no problem doing B/G/N on 2.4GHz with a 20MHz channel.
No, leave the Wireless modem to auto. Set the 2.4 GHZ to 20 MHZ and a fixed channel. Disable Airtime Fairness and Universal Beamforming. My G and N clients work just fine!
 

ComputerAbuser

Occasional Visitor
No, leave the Wireless modem to auto. Set the 2.4 GHZ to 20 MHZ and a fixed channel. Disable Airtime Fairness and Universal Beamforming. My G and N clients work just fine!
I will try again with Universal Beamforming disabled. It appears to be enabled by default.
 

ComputerAbuser

Occasional Visitor
I tried with Beamforming disabled and that didn't make a difference.

But, I tried the "N Only" option and that correctly keeps the BW to 20MHz when set to 20MHz. Also, LinSSID shows the protocol as "bgn" so I'm not sure what's "N Only" about it. I don't think I have any 802.11b or 802.11g only devices, so I should be good.

So for some reason switching to "Auto" flips it to 40Mhz, regardless of the BW setting. Perhaps 802.11AC requires 40Mhz at 2.4GHz?

I suspect many people just trust that it's operating at 20MHz when it's set to 20MHz without actually doing a WiFi channel scan.
 

joe scian

Very Senior Member
I tried with Beamforming disabled and that didn't make a difference.

But, I tried the "N Only" option and that correctly keeps the BW to 20MHz when set to 20MHz. Also, LinSSID shows the protocol as "bgn" so I'm not sure what's "N Only" about it. I don't think I have any 802.11b or 802.11g only devices, so I should be good.

So for some reason switching to "Auto" flips it to 40Mhz, regardless of the BW setting. Perhaps 802.11AC requires 40Mhz at 2.4GHz?

I suspect many people just trust that it's operating at 20MHz when it's set to 20MHz without actually doing a WiFi channel scan.
I have the AX86U and use Auto and my channel BW set to 20Mhz and its definitely at 20MHz with inSSIDer.
 

ComputerAbuser

Occasional Visitor
Perhaps it's an issue with stock vs Merlin? It definitely shouldn't be doing this. The channel BW is clearly set to 20 MHz, but scans show differently.
 

ComputerAbuser

Occasional Visitor
Good idea. I switched from "N Only" to "Auto". Channel BW still shows 20MHz in the config. I grabbed a chunk of the log, but I don't see anything about bandwidth.

I checked LinSSID and indeed my BW switched to 40MHz.

1618616699192.png
 

joe scian

Very Senior Member
Its in the Streams column which shows channel bandwith and Whether its an N stream or G stream or AC and number of streams

OR click on OPEN - Display low level details on Wireless Log Tab
 

ComputerAbuser

Occasional Visitor
Doh, I'm still getting used to the UI, sorry.

Ya, I was looking at the General Log and looking at the logs was a good tip. The logs showed that it was running at 20MHz BW with Auto and N Only.

So I pulled out my gaming laptop running Windows and checked inSSIDer. It shows 20MHz too, so the issue appears to be LinSSID in Ubuntu. Something about the WiFi details makes it think the channel bandwidth is 40MHz.

Since inSSIDer and the router both report 20MHz, I will trust that and blame LinSSID. I'm running version 3.6 in case this comes up for anyone else. Feel free to close this thread. Thank you for the help everyone. :D
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top