ASUS RT-N12E C1: Prevent router from power saving?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

happyman

New Around Here
Background:
I have purchased an ASUS RT-N12E C1 so I could connect my geothermal heat pump to the internet and access the heat pump via the resellers web interface (Thermia online).

My issue:
The router enters power save mode as only the heat pump is connected to the router, and the heat pump rarely connects by itself to the internet. My issue is that when the router enters power save mode I can't access the heat pump remotely any more. :-(

Asking for help:
Is there a way to disable the power save mode? Is there any other way to prevent the router from entering power save mode?

Thank you in advance
 

eibgrad

Very Senior Member
Are you sure its the *router* that's entering powering saving mode? I've never heard of a router doing such a thing, esp. since it can never be sure when it will be needed. OTOH, I've heard of some *other* devices that have a power saving mode, including printers and maybe even your heat pump. And when it does (at least in the case of my network print), it no longer responds to ARP requests, making it effectively unreachable. IOW, the client can't resolve its IP address into its MAC address, which is required for it to be addressable at the ethernet level.

One way to solve it is to create a *static* ARP entry in the client, so it no longer has to rely on ARP requests to resolve the device's IP into its MAC address. But depending on the client platform, that might not always be possible.
 
Last edited:

Wallace_n_Gromit

Senior Member
I went to the website thermia.com/online. So, trying to picture this setup and thinking about how I would "hack" a temporary/workable solution (until a better/typical/officially supported solution was evident).

If it is the Thermia router that goes to "power save mode" and it's behind the primary home router, could you setup a cron job on the primary router to ping the Thermia router every 1, 2, or 3 hours (whatever time interval the "router" appears to "power save") to keep it from going into "power save mode"? I had never heard of such a feature on any router either. I reviewed the users manual online for the ASUS RT-N12E C1 and it didn't mention such a feature.

Or could you set up a cron job on the Thermia dedicated router to periodically ping the Thermia heat pump from going into Power Save mode?

NOTE: The online manual for the N12 did mention that telnet was able to be enabled, though it didn't mention anything about ssh.

LAST RESORT: You could call Thermia customer service/support. This is probably the type of issue they have had to address in the past. With such an expensive product can't imagine that customer support wouldn't be able to help you. BUT it's always fun to try and figure things out on your own FIRST! ;)
 
Last edited:

happyman

New Around Here
I did try to find a parameter in the nvram that would let me turn off the stand by mode, but was hard put to figure it out :).

PS. I would be delighted if someone could point me to the correct nvram parameter in the attached file :)
 

Attachments

  • nvram.txt
    16.2 KB · Views: 55
Last edited:

ColinTaylor

Part of the Furniture
@eibgrad: I'm as baffled as you are. :) But it's a "feature": ASUS writes: "Power saving: consumes less power during stand by mode (see https://www.asus.com/Networking-IoT-Servers/WiFi-Routers/ASUS-WiFi-Routers/RTN12E/).
I think the "standby mode" is in reference to the WiFi only (WMM APSD?).
ASUS RT-N12E supports 802.11 b/g/n and has 300 Mbps high speed. With CD free easy installation and stable data transmission, RT-N12E is the basic solution for wireless internet setup. It also contents Green WLAN technology so it consumes less power during stand by mode.

EDIT: It looks like the "Power saving" feature was only promoted for the original RT-N12E. They've removed that phrase for the RT-N12E C1 model.
 
Last edited:

eibgrad

Very Senior Member
Is the RT-N12E C1 your primary router, or just daisy-chained behind your primary router? And how, LAN to LAN, or WAN to LAN? I'm just trying to get a better understanding of why this RT-N12E C1 is even part of your network, and why the heat pump isn't available over the primary network like any other device. Is it perhaps configured as a wireless client, because the heat-pump only accepts a wired connection?? Please clarify.
 

Wallace_n_Gromit

Senior Member
PS. I would be delighted if someone could point me to the correct nvram parameter in the attached file :)
I tried keyword(s) "pwr" , "save", and then (thanks to @ColinTaylor) "green"

ASUS RT-N12E supports 802.11 b/g/n and has 300 Mbps high speed. With CD free easy installation and stable data transmission, RT-N12E is the basic solution for wireless internet setup. It also contents Green WLAN technology so it consumes less power during stand by mode.

Examining your nvram.txt file I did see two interesting lines:

664 wl_GreenAP=0
748 wl0_GreenAP=0

Dunno what all that means, and AM NOT SUGGESTING you do anything with this information, and I don't wanna be blamed for any damage, bricking your router etc, etc.

I have never generated an nvram.txt like you have.

I just wonder if those 2 lines are related to the "power save mode" and are they SAFELY changed and how and what to?
 
Last edited:

KsWoodsMan

Regular Contributor
As mentioned, Knowing how the RT-N12 is being used makes a difference.
If your RT-N12 is in Router Mode getting it's internet connectivity from another router/gateway and it's not in AP mode you face a "double NAT" problem that some client devices don't like. This asumes the heatpump is connecting wirelessly to the RT-N12 and not as a wired device.

If you have your RT-N12 wired to another router or gateway for connectivity, setting the RT-N12 to AP mode may fix this.
Be sure to enable WPA-2 encryption so you aren't offereing free pron dl's for the neighborhood.

If you have the RT-N12 set up as a wireless bridge, using it at the heatpump to connect wirelessly to a WiFi router/gateway, you might be able to change the lease time on your router/gateway to shorter intervals to keep things "alive".
I don't like short lease times for a variety of reasons but setting the lease time to 300 seconds might be the trick in your case.

I hope you find your solution.

Sidenote: Piping the output of nvram show through sort , like this, makes it easier to visually search the output.
Code:
 nvram show | sort
 
Last edited:

happyman

New Around Here
Is the RT-N12E C1 your primary router, or just daisy-chained behind your primary router? And how, LAN to LAN, or WAN to LAN? I'm just trying to get a better understanding of why this RT-N12E C1 is even part of your network, and why the heat pump isn't available over the primary network like any other device. Is it perhaps configured as a wireless client, because the heat-pump only accepts a wired connection?? Please clarify.
The heat pump is in a house (let's call it house B) with three tenants. As I still lack my own internet access I have been allowed to access the tenants WiFi. I have set my router to repeat mode and connected it to the tenants WiFi. The heat pump is connected to my router via standard network cable. I have tried two different WiFis (Janes and Emilias) and have the same issue.

At another house (house A), with four tenants, I have used the same setup. Router ASUS RT-N12 (with Tomato - cant remember wich version - installed). The router is in repeat mode on one of the tenants WiFi and then cable from the modem to the heat pump. It works like a charm :).

The setup in house B is the same as in house A. The only difference is;
house A: RT-N12 with tomato firmware
house B: RT-N12E C1 with Asus firmware.

PS. I have been trying to find another firmware for the router, but no luck.

PS 2: @KsWoodsMan: Thank you for the sort tip. :)
 
Last edited:

KsWoodsMan

Regular Contributor
The heat pump is in a house (let's call it house B) with three tenants. As I still lack my own internet access I have been allowed to access the tenants WiFi. I have set my router to repeat mode and connected it to the tenants WiFi. The heat pump is connected to my router via standard network cable. I have tried two different WiFis (Janes and Emilias) and have the same issue.

At another house (house A), with four tenants, I have used the same setup. Router ASUS RT-N12 (with Tomato - cant remember wich version - installed). The router is in repeat mode on one of the tenants WiFi and then cable from the modem to the heat pump. It works like a charm :).

The setup in house B is the same as in house A. The only difference is;
house A: RT-N12 with tomato firmware
house B: RT-N12E C1 with Asus firmware.

PS. I have been trying to find another firmware for the router, but no luck.

PS 2: @KsWoodsMan: Thank you for the sort tip. :)
There are differences between Tomato on a RT-N12D and factory firmware on a RT-N12E.
"Repeater Mode" is not the same between Tomato and the factory firmware.

To get this to work , use "Wireless Bridge Mode" on the RT-N12E .
 

eibgrad

Very Senior Member
Given everything I've read in this thread to date, it has to be asked, why would anyone use a router w/ power saving mode?! Sorry folks, but this is ridiculous. As it is, that low-budget router w/o powering saving mode is probably barely registering any wattage at all during periods of idle. So what's the point of power saving mode? It just creates an unnecessary headache. Sounds to me like an OEM just wanting to place a "green" sticker on their product for public relations purposes.

My advice? DUMP IT and get a normal router!
 

happyman

New Around Here
My advice? DUMP IT and get a normal router!

I am inclinde to agree with you. But as I have purchased three of them. I would love to try all I can to get them to work before dumping them for three new ones. :)

PS. At home I have a RT-AC68U router with Merlin. I was trying to find a bit cheaper router for these three locations as I don't need anything fancy just to connect to the three heat pumps.

PS. I have never before looked in to nvram variables or tried a cron script (yet to try that one out live). So even if it's frustrating that the router doesn't work out-of-the box, I'm enjyoing learning new things :)
 
Last edited:

happyman

New Around Here
There are differences between Tomato on a RT-N12D and factory firmware on a RT-N12E.
"Repeater Mode" is not the same between Tomato and the factory firmware.

To get this to work , use "Wireless Bridge Mode" on the RT-N12E .

There is three modes. As far as I can understand, Repeater mode seems like my only option (see below, text taken from the admin interface).

Wireless router:
"In wireless router/ IP sharing mode, RT-N12E connects to the Internet via PPPoE, DHCP, PPTP, L2TP, or Static IP and shares the wireless network to LAN clients or devices. In this mode, NAT, firewall, and DHCP server are enabled by default. UPnP and Dynamic DNS are supported for SOHO and home users. Select this mode if you are a first-time user or you are not currently using any wired/wireless routers."

Repeater
"In Repeater mode, RT-N12E wirelessly connects to an existing wireless network to extend the wireless coverage. In this mode, the firewall, IP sharing, and NAT functions are disabled.
In Repeater mode, the DHCP-assigned IP address changes. Install and use the Device Discovery Utility to get the wireless router's new IP address.

AP
"In Access Point (AP) mode, RT-N12E connects to a wireless router through an Ethernet cable to extend the wireless signal coverage to other network clients. In this mode, the firewall, IP sharing, and NAT functions are disabled by default.
In Access Point (AP) mode, the DHCP-assigned IP address changes. Install and use the Device Discovery Utility in order to detect the wireless router's IP address."
 

KsWoodsMan

Regular Contributor
Are you connecting to the WAN Port or one of the 4 LAN Ports ?

If you were connecting to one of the the lan ports and it's not working, I'd replace the RT-N12E's with the RT-N12D version which has wireless bridge mode available as well as the 3 modes you have listed.

My 12D's have been very resilient having offered no problems to date.
The firmware may be a little dated (ok , very dated) but since they aren't serving as a wireless router or AP this shouldn't be a huge concern for a wireless bridge.
 
Last edited:

Wallace_n_Gromit

Senior Member
` the heat pump rarely connects by itself to the internet. `

A novel thought that has less to do with your networking configuration troubleshooting.

I would think that the supplier of the Heat Pump would allow you to configure the monitoring of the heat pump on their website interface with your personal settings. If you wanted feedback on a regular basis from the heat pump--let's say every 30 minutes, couldn't you do that and have the setting pushed to the Heat Pump?

Does the Heat Pump only respond to "Pull" requests or can it regularly "Push" data to another device?

NOTE: I haven't tried to see if I can
Code:
crontab -e
into my own RT-N12D1 (have 2) which is stored away/collecting dust in a closet right now, or to see/experiment with "Pinging" commands in a crontab. I'm willing to give it a shot if you haven't resolved this issue to your satisfaction. (From what I understand about the Crontab intervals, I think the shortest interval is every hour but you can set up multiple one hour interval periods-- i.e. 12 periods to have pings every 5 minutes)
 
Last edited:

KsWoodsMan

Regular Contributor
NOTE: I haven't tried to see if I can
Code:
crontab -e
into my own RT-N12D1 (have 2) which is stored away/collecting dust in a closet right now, or to see/experiment with "Pinging" commands in a crontab. I'm willing to give it a shot if you haven't resolved this issue to your satisfaction. (From what I understand about the Crontab intervals, I think the shortest interval is every hour but you can set up multiple one hour interval periods-- i.e. 12 periods to have pings every 5 minutes)
Instead of
Code:
crontab -e
to edit a crontab,
they use the smaller
Code:
cru -a
to add to the cron settings.

With no USB available and no jffs partition on them, I haven't found a good place on an RT-N12D to store this that will persist after a reboot.
There is some space for a jffs filesystem , though small, but the modules for this are not in the firmware.
Because of smaller write block sizes used on the device, the jffs modules are also different from the modules used in my other routers, using the same kernel version.
 

Wallace_n_Gromit

Senior Member
Instead of
Code:
crontab -e
to edit a crontab,
they use the smaller
Code:
cru -a
to add to the cron settings.

With no USB available and no jffs partition on them, I haven't found a good place on an RT-N12D to store this that will persist after a reboot.
There is some space for a jffs filesystem , though small, but the modules for this are not in the firmware.
Because of smaller write block sizes used on the device, the jffs modules are also different from the modules used in my other routers, using the same kernel version.
That's right, when I tried the
Code:
crontab -e
command (weeks ago) on my RT-AC68U the file was not editable/closable only viewable, so I realized that this would not work that way (and by implication maybe not work in a N12). Thank you for that other code
Code:
cru -a
Though the command works in my 86U as [cru a] without the "-". I do seem to recall a prior posting about that command in our routers.

I think I was in a bit over my head in offering that suggestion about the possibility of using a crontab/cru method to periodically ping another device to keep it from "power saving". I relied on what I thought was logical/plausible without really having done/experimented with it before in Asus firmware. I do seem to recall that either OpenWRT or dd-WRT for the N12D1 has a [Crontab] field in the GUI that can be populated, though have never used that feature either.
 
Last edited:

KsWoodsMan

Regular Contributor
@ Wallace_n_Gromit ,
You are right. A hyphen isn't needed when using cru with the factory firmware. Good catch.
I've tried Open WRT but don't recall much from that short exposure, except the jffs part was used as an overlay.
And it's been a while since I'ved used Tomato on one. I'd forgotten he'd said he was using tomato on the RT-N12D.

I thought adding a cronjob a was a valid idea. I wasn't sure how to go about implementing that and getting it to "stick" after reboots.
I guess , I was sort of thinking out loud as I typed, looking for ways to make that work for him.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top