AX-11000 system date wrong after upgrade to 3.0.0.4.386_45898

tastle

Occasional Visitor
So this is the first time I've ever encountered this. I just updated my router and then I noticed that my Nord VPN was failing to connect with an OpenSSL error.

May 5 09:32:27 vpnclient5[10809]: VERIFY ERROR: depth=1, error=certificate is not yet valid: C=PA, O=NordVPN, CN=NordVPN CA6, serial=4764208788777194848
May 5 09:32:27 vpnclient5[10809]: OpenSSL: error:1416F086:lib(20):func(367):reason(134)


I noticed that the system date was wrong. I tried:
* Changing TZs
* Toying with the DST values
* Soft reboot
* Hard reboot

Nothing worked. I finally just sshed into the router and set the date myself (not ideal... it should be syncing to pool.ntp.org).

After I set the date, the message that I was seeing under the NTP Server field ("Reminder: The system time has not yet been synchronized with an NTP Server. FAQ") finally went away, and my VPN is now working.

Has anyone ever seen this before?
 

dave14305

Part of the Furniture
It usually means the router cannot resolve the DNS name of the NTP server at boot time. What are your WAN DNS settings?
 

tastle

Occasional Visitor
My WAN DNS points to my local DNS (which has my local domains), which routes through to Cloudflare. And that bit is working A-okay.
 

bbunge

Part of the Furniture
My WAN DNS points to my local DNS (which has my local domains), which routes through to Cloudflare. And that bit is working A-okay.
Your WAN DNS needs to point to an upstream DNS resolver. Not a local (LAN) one!
 

v-jian

New Around Here
I am having the exact same problem and unable to change system time. My internet and smart devices are randomly going offline…internet status says disconnected but its not. There is also a lot of traffic going 10.0.0.1 address which is neither mine nor my ISPs network class.

Last months update did the same. I finally rolled back after sending logs to asus but I never checked the system time. I was hoping they fixed something after seeing how soon this was released
 

tastle

Occasional Visitor
I just finished talking to support. They believe it is a bug in the firmware. They said it _may_ be in a future firmware fix. There is another workaround.

If you:
  1. ping www.google.com
  2. note the return IP and
  3. enter both under the Administration System tab for Resolved Hostname and Resolved IP Address
The system will sync its time.
 

tastle

Occasional Visitor
Apparently it's also related to a bug where the Dashboard shows as "disconnected" from the Internet, despite being connected.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top