What's new

AX 86u PPPOE gives no Internet

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

dankehoe1

New Around Here
I've got T-Mobile 5G Home internet Gateway (Arcadyan) and have run a script to toggle off the radio on both bands (2 and 5 ghz)
I got an RT Ax86U today and ran it off the Ethernet port in the back of the Gateway, into the WAN port of the AX.
Setup went without a hitch and all devices connected up to the router with zero issues.
My issue is, I want to change the packet size to reduce ping and buffer bloat and the only way I can do this is through the WAN PPPOE mode. I plugged in my login credentials (I tried both my ISP account login credentials and the gateway admin login credentials because honestly, I was unsure which I needed to provide), selected PPPOE, and applied.
Internet map show that I am connected to the gateway but there is NO INTERNET.
I have attached a screenshot of a bufferbloat test showing why I want to tweak my MTU settings. Based on ping tests that i have run, 1480 is the ideal packet size (including the 29 byte header info)
 

Attachments

  • Bufferbloat.png
    Bufferbloat.png
    278.8 KB · Views: 29
Everyone seems to want to change the WAN packet size. Gamers! When in fact you are shooting yourself in the foot as the packets get fragmented upstream anyway. Many feel bufferbloat is something to not worry about as well as idle ICMP Echo results (ping to you).
A system with good QOS may help. FIOS is way better than 5G (just can't understand why you would go to a network that pauses traffic to avoid collisions...WIFI is bad enough).

Bottom line? Don't mess with WAN packet size (and you can't use PPPoE anyway on a 5G network).
 
Tells me all I need to know. I'm no network pro for sure. Thank you for the insight.

Everyone seems to want to change the WAN packet size. Gamers! When in fact you are shooting yourself in the foot as the packets get fragmented upstream anyway. Many feel bufferbloat is something to not worry about as well as idle ICMP Echo results (ping to you).
A system with good QOS may help. FIOS is way better than 5G (just can't understand why you would go to a network that pauses traffic to avoid collisions...WIFI is bad enough).

Bottom line? Don't mess with WAN packet size (and you can't use PPPoE anyway on a 5G network).
Incidentally, I went to 5G because for the last 19 years, I was a captive of Comcast, there being no other broadband alternative in my (and a lot of other people's) area. Fios hasn't been and still isn't available in my area. So, I went from paying ~240/month ($54,000.00 over the 19 years I was a Comcast slave) for broadband to 30/month. Kind of a no brainer
 
This 5G Internet will have fluctuating speed and latency depending on the tower load. You may never have good online gaming experience with mobile ISP. Don't waste your time with online bufferbloat testing. QoS on your end is unlikely to fix much. Just use what you have and don't stress yourself.
 
I've got T-Mobile 5G Home internet Gateway (Arcadyan) and have run a script to toggle off the radio on both bands (2 and 5 ghz)
I got an RT Ax86U today and ran it off the Ethernet port in the back of the Gateway, into the WAN port of the AX.
Setup went without a hitch and all devices connected up to the router with zero issues.
My issue is, I want to change the packet size to reduce ping and buffer bloat and the only way I can do this is through the WAN PPPOE mode. I plugged in my login credentials (I tried both my ISP account login credentials and the gateway admin login credentials because honestly, I was unsure which I needed to provide), selected PPPOE, and applied.
Internet map show that I am connected to the gateway but there is NO INTERNET.
I have attached a screenshot of a bufferbloat test showing why I want to tweak my MTU settings. Based on ping tests that i have run, 1480 is the ideal packet size (including the 29 byte header info)

You can't just change to PPPoE. That is something you enable when your ISP requires it and that is somewhat rare nowadays.

1500 MTU is where you want to be, and that is the default anyway. You can change the WAN MTU without changing to PPPOE but you would not want to as it will almost certainly make things worse. You want it to match whatever your ISP is, which with 5G is typically 1500.

Ignore the buffer bloat garbage, that just means you're able to saturate your connection during a speed test.

Your ideal MTU is the largest ping that succeeds when "do not fragment" is set, plus 28 bytes. In your case it should be 1472, which when you add 28 gives 1500.
 
Fortunately, I am pretty close to a tower and get 5GUC pretty much constantly. I'm happy with my speeds and my gaming latency is actually pretty good. My annoyance is barely perceptible (but perceptible) stutters in audio on streaming (NetFlix, etc.) But for the amount of money I'm saving, I can deal with it if I need to
 
Your ideal MTU is the largest ping that succeeds when "do not fragment" is set, plus 28 bytes. In your case it should be 1472, which when you add 28 gives 1500.
I did the ping tests and it worked out to be 1480 after adding the 28 for the header, etc. But, again, I am no network pro. If you guys are saying Don't worry about it, that's good enough for me.
 
I did the ping tests and it worked out to be 1480 after adding the 28 for the header, etc. But, again, I am no network pro. If you guys are saying Don't worry about it, that's good enough for me.

So
ping -f -l 1452 google.com works but ping -f -l 1453 google.com doesn't (saying packet must be fragmented)?

In that case you should change your WAN MTU to 1480 and then reboot the router.

Does your router not have something like this at the bottom of the WAN settings?

1694305415415.png
 
So
ping -f -l 1452 google.com works but ping -f -l 1453 google.com doesn't (saying packet must be fragmented)?

In that case you should change your WAN MTU to 1480 and then reboot the router.

Does your router not have something like this at the bottom of the WAN settings?

View attachment 52962
Precisely correct. 1452 good, 1453 fragmented with the -f -l modifiers. So 1480. Absolutely only place in my AX86U where MTU an be set is under PPPOE tab.
 

Attachments

  • IMG_1233.jpeg
    IMG_1233.jpeg
    69.5 KB · Views: 35
So
ping -f -l 1452 google.com works but ping -f -l 1453 google.com doesn't (saying packet must be fragmented)?

In that case you should change your WAN MTU to 1480 and then reboot the router.

Does your router not have something like this at the bottom of the WAN settings?

View attachment 52962
Newer routers do not have the ability to change MTU. I believe my AC66U_B1 had it but not the AX86U or Pro version.
 
Newer routers do not have the ability to change MTU. I believe my AC66U_B1 had it but not the AX86U or Pro version.

Odd, is it available in Merlin on those? I guess Asus assumes PMTUD is always going to work (when in reality it rarely does). Fragmentation is not the end of the world but certainly good to avoid it if you can.
 
Apparently so

If the firmware no longer allows it, you can change it via a script using ifconfig commands, but in reality it probably isn't going to impact you that much (if at all). Large transfers will have some packet fragmentation (which the router can handle) but in reality most stuff you do on the internet isn't using full sized packets. Path MTU discovery (PMTUD), when it works, will also prevent the fragmentation. When it works being the key phrase, though since the 1480 limit is one hop beyond your router, hopefully your ISP has it implemented correctly and it will work.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top