What's new

Belkin N1 F5D8235-4 appears to 'hang'

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Had an old D-Link router for some time,
then upgraded to Belkin N1 F5D8235-4 V2

running 2.0.7 firmware from UK site (not available in US
site for some reason).

But regardless of what I try, my main computer
(connected via ethernet) and my laptop connected via N1

once in a while appear to 'hang'. But that I mean
that when I say browse search results, I click on few links
and everything is ok, then I click on one of the links and I get "web page not found" -- then I click again and it works...

Now the reason why I am getting even more concerned -- I need to some work from home on a remote computer
(via Remote Desktop) -- and with that kind of problem I basically cannot do the work (because the remote desktop session just 'freezes' for 5-10 seconds every 2 minutes or so)

Are there any settings on Belkin I could try?
( I am sure it is not my computers because both of them behaved the same, and both were working fine before).

My belkin is connected to Motorola cable modem via
mediatrix VoIP box (so it is not directly connected to the
cable modem -- but neither was my previous Dlink 625).

thank you in advance
Try connecting your computers directly to the cable modem (one at a time) and see if you have the problem.

You could run a long ping to Google or some other internet site (ping -n 1000 google.com) to see if the Internet connection is actually dropping.
just to follow up on my post

I connected my PC to internet without the router
(keeping all other devices intact) and it worked ok.

I called Comcast (my isp), had them check my connection
again, removed the Belkin N1 router and things worked,
as soon as put it back I get timeouts
(I can even see with ping -t)

Finally called Belkin, request another router, prepaid
(and paid additional 9 bucks for fast shipping) got the new
router .... the same problem.

Got sick of it -- and ordered Netgear 3700 (which I wanted anyways).

Just set it up today ... and internet connection is fine
(no problem)... but

as soon as I connect my USB hard drive to the thing
-- the whole router stops working (and I cannot login into it). I am posting this as as separate question.

... some how 'somebody from above' does not like me.

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!

Members online