Custom firmware build for R7800 v. 1.0.2.36SF

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Voxel

Very Senior Member

Voxel

Very Senior Member
Samba 3.6.25 does add SMB2.0 support, however I'm not sure if Voxel is able to modify the smb.conf config file to enable that.
I use:
Code:
max protocol = SMB2
in smb.conf. But did not test SMB2.0 especially.

Voxel.
 

RMerlin

Asuswrt-Merlin dev
I use:
Code:
max protocol = SMB2
in smb.conf. But did not test SMB2.0 especially.

Voxel.
To test, first reboot your computer (to ensure it has no legacy session in memory). After the reboot, access a network share.

Then start a Powershell console with elevated privileges, and run the following command (requires Windows 8 or newer I believe):

Code:
Get-SmbConnection
It will tell you the protocol version used by each network session.

Code:
Windows PowerShell
Copyright (C) 2016 Microsoft Corporation. All rights reserved.

PS C:\WINDOWS\system32> Get-SmbConnection

ServerName ShareName UserName       Credential     Dialect NumOpens
---------- --------- --------       ----------     ------- --------
ALEXANDRIA Media     CAMELOT\Merlin CAMELOT\Merlin 3.1.1   1
ALEXANDRIA mep       CAMELOT\Merlin CAMELOT\Merlin 3.1.1   1
ALEXANDRIA Music     CAMELOT\Merlin CAMELOT\Merlin 3.1.1   1
ALEXANDRIA Public    CAMELOT\Merlin CAMELOT\Merlin 3.1.1   2
(this is my NAS, hence the 3.1.1 version).
 

Voxel

Very Senior Member
To test, first reboot your computer (to ensure it has no legacy session in memory). After the reboot, access a network share.

Then start a Powershell console with elevated privileges, and run the following command (requires Windows 8 or newer I believe):

Code:
Get-SmbConnection
It will tell you the protocol version used by each network session.

Code:
Windows PowerShell
Copyright (C) 2016 Microsoft Corporation. All rights reserved.

PS C:\WINDOWS\system32> Get-SmbConnection

ServerName ShareName UserName       Credential     Dialect NumOpens
---------- --------- --------       ----------     ------- --------
ALEXANDRIA Media     CAMELOT\Merlin CAMELOT\Merlin 3.1.1   1
ALEXANDRIA mep       CAMELOT\Merlin CAMELOT\Merlin 3.1.1   1
ALEXANDRIA Music     CAMELOT\Merlin CAMELOT\Merlin 3.1.1   1
ALEXANDRIA Public    CAMELOT\Merlin CAMELOT\Merlin 3.1.1   2
(this is my NAS, hence the 3.1.1 version).
Thanks a lot. I tried from Windows 10. Got version 2.0.2. So it works. For both R7800 and R9000.

Voxel.
 

Voxel

Very Senior Member
Me too. But still, seems normal based on other posts, without SMB1/CIFS installed I don't get shares in Network.
Your initial problem (when you could not see your router's shares enabling HT160) is strange. I failed to reproduce it. I had to use laptop of my wife with Windows 10 for RMerlin's test (I use Windows 7). But I did not touch SMB1 on her laptop (enable/disable) leaving default settings. Just to check that it will use SMB2 by default, And HT160 was enabled. But do you really need HT160? Don't trouble trouble until trouble troubles you :)

Voxel.
 

cybrnook

Senior Member
Will this model receive some of the same package updates as the R9000? Saw the new R9000 release today.
 

Voxel

Very Senior Member
Will this model receive some of the same package updates as the R9000? Saw the new R9000 release today.
Sure. For me it is more easy to do the same for both models at the same time. Plus something specific for R7800 (what is under testing now).

Voxel
 

RogerSC

Part of the Furniture
Posting here because I'm using this version of the venerable Voxel firmware *smile*. I notice that when I enable IPv6 and run the IPv6 Connectivity and Speed test that I get 17/20 when I should be seeing 19/20. This lowered score indicates that ICMPv6 isn't responding when it should. I've tried enabling "Allow external IPv6 hosts ping internal IPv6 hosts" from the debug page, but that doesn't help, either.

Voxel, is this something that you can help with? Like adding a simple ip6tables rule to the IPv6 firewall rules? Or is this something that I'm doing wrong? I have my network set to "Private", which in the past has been enough if the right stuff is in the router IPv6 firewall rules. Also, Netgear has refused to fix this, to make ICMPv6 work according to spec, so I was hoping that maybe you might be able to help with this?

Thanks!
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top