What's new

Custom firmware build for R7800 v. 1.0.2.74.2SF & v. 1.0.2.74.3SF

Voxel

Very Senior Member
Continuation of
. . .
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-73sf.60710/
https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-74-1sf.61190/

New version of my custom firmware build: 1.0.2.74.2SF.

Changes (vs 1.0.2.74.1SF):

1. Changes in firewall to allow accessing LAN devices when using OpenVPN TUN server.
2. HiLink LTE modem support changes: optimization.
3. tune2fs utility is added to allow tuning ext2/3/4 FS features (-O ^metadata_csum,^64bit).
4. hotplug2 package: add support of upcoming WireGuard-Go add-on (config from USB flash).
5. DNSCrypt Proxy v.2 build scheme is changed (compilation by Go, dynamic GCC libs). Should work faster.
6. DNSCrypt Proxy v.2 is upgraded 2.0.36->2.0.39.
7. libubox package is upgraded 2019-12-28->2020-01-20.
8. util-linux package is upgraded 2.34->2.35.1.
9. sqlite package is upgraded 3300100->3310100.
10. uci package is upgraded 2019-12-12->2020-01-27.
11. sysstat package is upgraded 12.0.5->12.2.1.
12. libgpg-error package is upgraded 1.36->1.37.
13. coreutils package (sort) is upgraded 8.30->8.31.
14. libxml2 package: optimization for a size.
15. Host tools (gmp): is upgraded to 6.2.0.
16. Host tools (sed): is upgraded to 4.8.
17. Host tools (bison): is upgraded to 3.5.1.
18. Host tools (quilt): is upgraded to 0.66.
19. Toolchain: Go (used for DNSCrypt Proxy v. 2) is upgraded to 1.13.8.

[Edited]

Quick fix version: 1.0.2.74.3SF.

Changes (vs 1.0.2.74.2SF):

1. Firewall: Quick fix. Changes in firewall for OpenVPN servers in 1.0.2.74.2SF are (temporary) disabled.
2. Firewall: Add support of upcoming WireGuard-Go add-on.

The link is:

https://www.voxel-firmware.com (thanks to vladlenas for his help with hosting).

Voxel.
 
Last edited:

LeKeiser

Regular Contributor
Hello,
Installed yesterday, everything is still working great.
Again, I cannot thank you enough, Mr Voxel, for your great work and constant presence here on this forum. Always available to reply to our questions, remarks,... BIG THANX!! :)
 

Cruncher

New Around Here
I finally registered here to say Thank you. I am using the R7800 for almost 3 years now and just started using your FW.

everything was working fine and I installed 1.0.2.74.2SF yesterday and I have some strange issues now.

I have a few DHCP Reservations and they are working fine.
The strange thing is that I am not able to launch my NAS Webgui anymore in local network. Also my Philips Hue Bridge only communicates via Cloud and not local anymore. Same for my Plex Server and Homebridge Server.

My Raspberry with pi-hole and HP LAN Printer are working without any issues. I am able to ping all the devices in my Network.

Any idea?
 

LeKeiser

Regular Contributor
hello :)

Out of curiosity, what's happening when you try to launch the GUI of your NAS? Can you ping it? How do you log on your NAS?
 

Cruncher

New Around Here
The GUI in local LAN is not loading. No Error Message just endless loading screen.
I can ping it without issues.

I can access it external via dyndns and also via SMB.
 

LeKeiser

Regular Contributor
The GUI in local LAN is not loading. No Error Message just endless loading screen.
I can ping it without issues.

I can access it external via dyndns and also via SMB.
You have a redirection configuration on your 7800?
You try to log on your NAS using its IP or...? Private IP, right?
 

Cruncher

New Around Here
No, I have no redirection on local nas. I try to connect trough local IT and Port.

But it is pingable and reachable from external. Very strange. I haven‘t changed any settings.
 

LeKeiser

Regular Contributor
No, I have no redirection on local nas. I try to connect trough local IT and Port.

But it is pingable and reachable from external. Very strange. I haven‘t changed any settings.
Weird. I have 3 NAS at home (Geek Inside ;) ) and I have no problem logging on with the new firmware...
Have you tried to clear your cookies/history/... ? Another browser?
 

Cruncher

New Around Here
Yes I tried everything. That‘s strange. I am an IT technician but I am not that big of a network specialist. Also my Hue Bridge is not connecting locally.

i will maybe try a downgrade tonight and try this.
 

Wigster

Occasional Visitor
Hi,

I am seeing a similar problem after upgrading to Voxel's 1.74.2:

The router sees all the devices on the network, and each device can browse the outside internet, but internal routing doesn't seem to be working properly. I cannot ssh/http some of the devices on my local network despite the fact that I can ping them (as some of the other services are not visible either). (looks like it's wifi->wired that is the problem?). E.g. I have an rpi that is wired to the router, and I can access it over http/ping but not ssh from my laptop which is on wifi. The iphone is not seeing the TV's youtube app, despite the fact that both can access the internet.
 

e38BimmerFN

Very Senior Member
Try a factory reset on the R7800 and setup from scratch?

Try a different browser? IE11, Firefox or Opera.

Be sure to clear all browser caches.

I finally registered here to say Thank you. I am using the R7800 for almost 3 years now and just started using your FW.

everything was working fine and I installed 1.0.2.74.2SF yesterday and I have some strange issues now.

I have a few DHCP Reservations and they are working fine.
The strange thing is that I am not able to launch my NAS Webgui anymore in local network. Also my Philips Hue Bridge only communicates via Cloud and not local anymore. Same for my Plex Server and Homebridge Server.

My Raspberry with pi-hole and HP LAN Printer are working without any issues. I am able to ping all the devices in my Network.

Any idea?
 

Cruncher

New Around Here
Yes, I also tried different devices. Very strange.

when I connect trough VPN with my phone I can access my Hue and my NAS via local IP Adress. Very strange. I will do some more research when I get home.
 

e38BimmerFN

Very Senior Member
What happens if you load Voxels prior version of FW?
 

darkolo

New Around Here
After upgrading to 1.0.2.74.2SF, browsing is very slow with any browser form Mac, PC, iPhone. Pages take so long to open. I thought it was my Pi-Hole, restarted everything but after downgrading to1.0.2.74.1SF all is back to normal. I didn't notice nothing strange into logs.
 

Cruncher

New Around Here
I also tought it was my Pi-Hole first. Now I am back on V1.0.2.74.1SF and everything works fine again. So I wait for another release.
 

bucwylde23

New Around Here
I was having the same issue with trying to access the web GUI for my Synology NAS from wifi. I connected my laptop directly to my NAS via ethernet, and I was able to connect just fine. Same thing when I connected via ethernet to my router. Then I remembered this item in the changelog:
1. Changes in firewall to allow accessing LAN devices when using OpenVPN TUN server.

I do have OpenVPN enabled so figured let me check that. I disabled OpenVPN server and now everything works perfectly fine, I can connect to the web GUI over wifi. I haven't played with the settings much since then such as switching from Auto to allow all internet and home network traffic but I might do that later.
 

Voxel

Very Senior Member
Then I remembered this item in the changelog:
1. Changes in firewall to allow accessing LAN devices when using OpenVPN TUN server.
Thank you.

Sorry. Errare humanum est. I've not checked this with wireless connection.

Seems this is really the reason of problems.

Temporary remedy (until next fixing version) could be

1. Disable OpenVPN servers if you do not need them.

or

2. Install kamoj add-on

or

3. Comment these lines in /usr/sbin/net-wall script:

Change
Code:
. . .
    # Check if tun0 interface exists: open access to LAN for client of TUN server
    ifconfig | grep -q tun0
    if [ $? -eq 0 ]; then
        iptables -I FORWARD -j ACCEPT
        iptables -I FORWARD -i tun0 -o br0 -j ACCEPT
        iptables -I FORWARD -i br0 -o tun0 -j ACCEPT
        iptables -t nat -A POSTROUTING -o br0 -j MASQUERADE
    fi
. . .
to
Code:
. . .
    # Check if tun0 interface exists: open access to LAN for client of TUN server
#    ifconfig | grep -q tun0
#    if [ $? -eq 0 ]; then
#        iptables -I FORWARD -j ACCEPT
#        iptables -I FORWARD -i tun0 -o br0 -j ACCEPT
#        iptables -I FORWARD -i br0 -o tun0 -j ACCEPT
#        iptables -t nat -A POSTROUTING -o br0 -j MASQUERADE
#    fi
. . .
Voxel.
 

tarassippo

Regular Contributor
Thanks Voxel, so if we don't use OpenVPN we can stick with 1.0.2.74.2SF and no need to install 1.0.2.74.3SF, correct ?
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top