What's new

External Asmedia USB3 hard drive no longer recognized on USB3 port but fine on USB2

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
Ok so I have a external hard drive, Rosewill RX 358 U3C which uses the AsMedia 1051 chipset. It's been working fine in the router, in the USB3 port, for many months but recently I noticed it's no longer showing up. I'm not sure if it coincides with my latest upgrade to 380.59 but either way, the drive refuses to show up.

I plugged a thumb drive into the USB3 port and it shows up immediately. So on a whim I tried the external hard drive in the USB2 port, and it worked. So the Asus won't detect this enclosure in the USB3 port but it will in the USB2 port. I've tried a thumb drive in USB3 and USB2 ports and it works fine in both cases. So what is it about this drive that makes it not be recognized in the USB3 port?

When I plug it into the USB3 port, there's no mention of it in the kernel log/dmesg. But when I plug it into the USB 2.0 port:

usb 1-2: new high speed USB device using ehci_hcd and address 5
scsi2 : usb-storage 1-2:1.0

So anyways, I'm running in degraded mode right now. Not like I was getting a ton of speed out of that USB 3.0 port but still. I thought it could be hardware but that doesn't explain why the thumb drive works in the USB 3 port. The thumb drive was a USB 2.0 device, I also tried a USB 2.0 ethernet adapter in the USB3 port and that worked. I don't have any other USB 3.0 devices to test the USB3 port against at the moment. Could this be a software issue?

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!