What's new

Failed to compile firmware for RT-AC68u

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
I updated and compiled the merlin firmware for RT-AC68u as usually today, but I got these message shown below. Though I cleared and reset, it still failed. Is there any option I miss while compiling? I hope someone could help me out.
Last edited:
I have got exact the same error and want to know how to fix this.
This error is caused after commit no: fad473f (ffmpeg: harmonize build recipes with upstream)

I'm compiling it for the RT-AC86U.
Last edited:
You could fix this yourself by editing ~/asuswrt-merlin.ng/release/src/router/Makefile. The place to fix this is near "ffmpeg/stamp-h1:", in that file.

Here's how to see the valid arguments to the configure program.
cd ~/asuswrt-merlin.ng/release/src/router/ffmpeg
./configure --help

I have posted the output of "configure --help" for ffmpeg, here:
https://cryptobin.co/x5c0x9b0 , password is lol
Here's how to see the valid arguments to the configure program.
I'm not a pro to compile code, I use the post that you placed several months ago to compile
Thanx again Fitz, it worked very well since ffmpeg and I do not know exactly how to apply the fix you just placed.
So I came to the humble conclusion, it's time to stop compiling if i dont know how fix this. It was just copy paste for me and a hobby of testing new builds and nights commits . :)
And also, I compiled the code from the Master (not the mainline) branch to stay under the GPL 32799, I have some problems under 45149 (Bugged clients list Network map, 5 ghz failing, ... etc)
I m gonna stay for a while on alpha 2 , it rock solid.
Last edited:
Alternatively, how to download a fresh copy directly from the source.

Download a fresh 384.9 final
### Download a fresh 384.9 final
mkdir -p asuswrt-merlin.ng-source
cd asuswrt-merlin.ng-source
wget -O 384.9-0-680426d.tar.gz https://github.com/RMerl/asuswrt-merlin.ng/archive/680426d75d65594b3b1239a9639b9e016c57196b.tar.gz
rm -rf asuswrt-merlin.ng-????????????????????????????????????????
tar xzvf 384.9-0-680426d.tar.gz
rm -rf ../asuswrt-merlin.ng-build
mv asuswrt-merlin.ng-???????????????????????????????????????? ../asuswrt-merlin.ng-build
cd ..

Maybe your local repo got corrupt because Microsoft?
I am having the same problem building for RT-AC88U (on ubuntu Bionic). I tried the master branch as per the wiki but it fails with ffmpeg option problems. Thank Fitz for the alternative method above (I've learnt something there) but it fails at the same point. Can anyone post the options that the latest ffmpeg needs please?
In rt-ac86u model I can see that 'ffmpeg/libavformat/libavformat.so.58' file doesn't exist but it is required in install phase. I can see only 'ffmpeg/libavformat/libavformat.so.52' in .gitignore so I guess it has to be corrected/pre-compiled to the new version. So that's the reason why it wont compile the firmware for this model. I didn't check any other models. The same I would expect for libavcodec.so.58 and libavutil.so.56. Is there a chance to push them into the git or do we have to compile them by myself? Thanks.
Last edited:
Do not build from the master branch, build from the mainline branch, as explained in the changelog.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!