Help setting up VPN AC86u merlin

a_shot_on_ehlo

New Around Here
I've been trawling through various posts and other forums, none of the changes seem to work, have been on various chats with Nord who have had me use 10+ configs, have changed the custom config, have changed dns servers, have changed the "accept dns config" entry, eventually they basically said it's your router it's leaking DNS, we can't help. It's like the title says an AC86u w merlin firmware 386.7_2.

I thought it would be simple enough, followed the Nord guide here https://support.nordvpn.com/Connectivity/Router/1047410642/AsusWRT-Merlin-setup-with-NordVPN.htm

I can get it "working" but I'm only doing it to watch Netflix on the TV, by working it provides internet access but fails dnsleaktest, won't load fast.com and Netflix says no connection.

Is this router/firmware just unable to do this consistently? Is it simply a Nord issue? Do I need to buy a new router?
 
Last edited:

sl4fko

Regular Contributor
Does the VPN client on router says that it is connected?

Did you enter NordVPN DNSs in "WAN" section?

In "VPN Client" you have to set up DNSs as "Exclusive"

Does Netflix work on your computer in Firefox/Chrome browser?


Netflix won't work on your smart TV with VPN. I have the same router and the same VPN provider as you do and I can watch Netflix with VPN only on my smartphone and computer (in internet browser). On my smart TV it does not work.

I think the apps and the ecosystem are not the same; Android TV and Android on phones/tablets are not the same nor are the streaming apps for both of them.
 

a_shot_on_ehlo

New Around Here
Does the VPN client on router says that it is connected?

Did you enter NordVPN DNSs in "WAN" section?

In "VPN Client" you have to set up DNSs as "Exclusive"

Does Netflix work on your computer in Firefox/Chrome browser?


Netflix won't work on your smart TV with VPN. I have the same router and the same VPN provider as you do and I can watch Netflix with VPN only on my smartphone and computer (in internet browser). On my smart TV it does not work.

It’s connected.

I have set NordVPN dns servers in Wan, I have also used Cloudflare and Google servers.

I have tried exclusive, strict, disabled.

No it doesn’t work on any devices currently, the easiest check is fast.com as it will say no connection etc, then check Netflix same thing. Then a dns leak check will show it’s leaking.

However it has worked previously, including with the TV. At that time it was set to cloudflare dns in Wan, strict, policy rules, then only certain devices, including the TV selected in “VPN Director”.

It has worked fine for several days, watching Netflix Singapore, based in Australia. Then we had a power outage and that stopped the VPN. I rebooted, cleared the VPN settings, uploaded the same config, same settings, but it was leaking/couldn’t access Netflix/Fast.com.

So it absolutely does work for the TV, but for the last few days I have been unable to get it working, with various udp servers, different config etc.

It works flawlessly when using the Nord app, I can even use my PC as a hotspot while connected to the Nord app, and connect my TV to it, however the connection is weak, resulting in immense buffering etc.

So it would seem to be something with the router, a setting I have is wrong, that is causing the leaking. Yet it has worked as I said, but using the exact same settings and config has failed over and over the last few days. So it’s very confusing, it can work perfectly, yet not work at all more often than not.
 

ColinTaylor

Part of the Furniture
However it has worked previously, including with the TV. At that time it was set to cloudflare dns in Wan, strict, policy rules, then only certain devices, including the TV selected in “VPN Director”.

It has worked fine for several days, watching Netflix Singapore, based in Australia. Then we had a power outage and that stopped the VPN. I rebooted, cleared the VPN settings, uploaded the same config, same settings, but it was leaking/couldn’t access Netflix/Fast.com.

So it absolutely does work for the TV, but for the last few days I have been unable to get it working, with various udp servers, different config etc.
This is a completely different scenario than your original post implied. There you implied that this had never worked before. You even said "Is this router/firmware just unable to do this?".

Now you're saying that it was working fine but after a power outage, with no changes to the router, it stopped working.
 

a_shot_on_ehlo

New Around Here
This is a completely different scenario than your original post implied. There you implied that this had never worked before. You even said "Is this router/firmware just unable to do this?".

Now you're saying that it was working fine but after a power outage, with no changes to the router, it stopped working.

I'm sorry if I confused you. However you replied after I provided more info, not after my first post, so you should have a better idea?

It was working fine for a brief time, but I had used probably 8 different config files and changed certain settings just to get it to work that one time. The router rebooting seemed to stop the VPN client as I'd expect. My questioning the router and firmware capability, is not based on it never working, it's whether it can consistently perform the task, which it certainly has not in my experience.

The only feedback I have from Nord is we have exhausted all options that they know of, and that it works fine when using their app, but does not work when setting it up via the router.

Do you have any advice?
 

ColinTaylor

Part of the Furniture
Do you have any advice?
I've used NordVPN on my RT-AC68U and RT-AX86U and not had a problem. Yes getting DNS to work exactly how you want can be a bit head scratching but I've never had a complete lack of connectivity to the internet (e.g. fast.com) that you're experiencing.

I suggest that you

a) Change your WAN DNS settings back to Auto or your preferred public servers (e.g. 8.8.8.8). Don't use NordVPN's servers here.

b) Default your VPN client settings and then re-import the NordVPN config. Enter your username and password details. Change "Accept DNS Configuration" to Exclusive.

For testing purposes change "Redirect Internet traffic through tunnel" to "Yes (all)". Turn on the VPN client and check that all of your clients are now going through the VPN.
 
Last edited:

a_shot_on_ehlo

New Around Here
I've used NordVPN on my RT-AC68U and RT-AX86U and not had a problem. Yes getting DNS to work exactly how you want can be a bit head scratching but I've never had a complete lack of connectivity to the internet (e.g. fast.com) that you're experiencing.

I suggest that you

a) Change your WAN DNS settings back to Auto or your preferred public servers (e.g. 8.8.8.8). Don't use NordVPN's servers here.

b) Default your VPN client settings and then re-import the NordVPN config. Enter your username and password details. Change "Accept DNS Configuration" to Exclusive.

For testing purposes change "Redirect Internet traffic through tunnel" to "Yes (all)". Turn on the VPN client and check that all of your clients are now going through the VPN.
Did all that, still end up with the same issue. IP sites will show a Singapore IP, I'll have internet access, however go to fast.com(multiple browsers/devices) and get this, have cleared cache/history/everything
fastnetflix error.jpg


Netflix will say not connected to the Internet.
 

chongnt

Very Senior Member
Can you check on VPN Status page, is the status of VPN Client connected? If yes, take note of the public IP address here.
In VPN Client page, as you have "Redirect Internet traffic through tunnel" set to "Yes (all)" for testing purpose, can you verify with any of your LAN client what is the public IP? It should be the same as the one show in the VPN status page.
 

ColinTaylor

Part of the Furniture
Did all that, still end up with the same issue. IP sites will show a Singapore IP, I'll have internet access, however go to fast.com(multiple browsers/devices) and get this, have cleared cache/history/everything

Netflix will say not connected to the Internet.
Sorry, maybe I misunderstood what you were saying. I thought you didn't have any internet access at all. If it's only a problem accessing Netflix in another country (and fast.com which is also Netflix) but other sites work as expected then this is not unusual. It's just Netflix blocking VPNs.
 

a_shot_on_ehlo

New Around Here
Can you check on VPN Status page, is the status of VPN Client connected? If yes, take note of the public IP address here.
In VPN Client page, as you have "Redirect Internet traffic through tunnel" set to "Yes (all)" for testing purpose, can you verify with any of your LAN client what is the public IP? It should be the same as the one show in the VPN status page.
It's connected. I don't have anything connected via LAN it's all WiFi. The public IP listed matches what shows up if I go to whatismyipaddress.com for example.

Sorry, maybe I misunderstood what you were saying. I thought you didn't have any internet access at all. If it's only a problem accessing Netflix in another country (and fast.com which is also Netflix) but other sites work as expected then this is not unusual. It's just Netflix blocking VPNs.
Right, so it's a case of Nord just giving me the wrong info as I kind of expected initially. They put the blame squarely on the router leaking dns as the issue, rather than their own servers or config files.
 

chongnt

Very Senior Member
It's connected. I don't have anything connected via LAN it's all WiFi. The public IP listed matches what shows up if I go to whatismyipaddress.com for example.
Ok, your VPN is working. Are you still having problem with fast.com? If you want to use your vpn provider DNS, you can set Accept DNS Configuration to exclusive under VPN client setting. Otherwise, you can set it to disabled.
 

a_shot_on_ehlo

New Around Here
Are you still having problem with fast.com? If you want to use your vpn provider DNS, you can set Accept DNS Configuration to exclusive under VPN client setting. Otherwise, you can set it to disabled.
Yeah I have tried a few different servers tonight, all get blocked by Netflix/Fast, all work fine for everything else. Unfortunately I've already tried all of relaxed, strict, exclusive and disabled. With a variety of dns servers google, cloudflare, nord and isp default. Hitting default each time to reset the VPN settings etc.

I have noticed certain dns settings under "wan dns setting" unsure if they're of any consequence? Otherwise I may try a different VPN provider, as I can always get cashback within a trial period if it doesn't work either.

wan_dns_settings.jpg
 

chongnt

Very Senior Member
Yeah I have tried a few different servers tonight, all get blocked by Netflix/Fast, all work fine for everything else. Unfortunately I've already tried all of relaxed, strict, exclusive and disabled. With a variety of dns servers google, cloudflare, nord and isp default. Hitting default each time to reset the VPN settings etc.

I have noticed certain dns settings under "wan dns setting" unsure if they're of any consequence? Otherwise I may try a different VPN provider, as I can always get cashback within a trial period if it doesn't work either.

View attachment 45042
Perhaps can try LAN -> DNSFilter. Set Enable DNS-based Filtering to ON. Then Global Filter Mode to Router. Click Apply.
Also, on LAN - DHCP Server, leave DNS Server 1 and 2 blank. Select Yes for Advertise router’s IP in addition to user specified DNS.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top