[HOW-TO] ownCloud on Router

Rookie

Occasional Visitor
I was wondering if anyone implemented the use of a project called Radicale on this platform.

http://radicale.org/
https://github.com/Kozea/Radicale

I have installed and used it on my raspberry pi to sync my calendars and contacts between smartphones. It is a good alternative to built-in could services that come with smartphones in terms of privacy. It was so much less resource hungry compare to Owncloud.

I would loved to see someone point me in the right direction to achieve this on my Asus RT-N66U.
I have currently Tomato shibby and entware installed.

Cheers
 
Last edited:

Rookie

Occasional Visitor
My apologies, I was being sarcastic.
I came across with your older post about you porting tvheadend somewhere on this forum. What I meant to say was porting Radicale may very well be easier for you compare to tvheadend. Considering the size and complexity of each software. I am currently using tvheadend on my raspberry pi and works really well.
Anyways, I hope you get around to porting Radicale soon.
 

stebrick

Regular Contributor
I have a ASUS router of ac68u with asuswrt-merlin firmware on board and a USB drive with Entware installed. My firmware is :378.52_2

My apology first because I am new to linux. I have tried many times (at least 5) by strictly following the tutorial posted in this post but I am unable to get my owncloud working. I have tried both owncloud 5.0.0 and 8.0.2 version but no good.

I absolutely have no idea what happened to my installation because there is no error at all during all the steps I taken and followed. It just wont work when I type: http://192.168.1.1:81/owncloud

I am new to linux but I am willing to learn via every tutorial or research online.

However, I am absolutely hopeless now. I spend lots of time keep trying and trying without any success. Please would someone offer me some advice or to help me via teamviewer. It would be much grateful for any assistance.
 

jtp10181

Regular Contributor
Thanks, I was just thinking the other day this was something I would have to figure out, but someone already has. Now I can come back to this when I am ready to try it. Need to get a USB hard drive first I think.
 

Carlos M.

Regular Contributor
no way to reach the web interface of owncloud at port 81... :(
I did everything as the tutorial explain but... no luck

Found this record in the system log:

Jan 30 22:32:17 adminnameaccount: Could not start Entware
Jan 30 22:32:32 crond[257]: time disparity of 263432 minutes detected
 
Last edited:

arul

Regular Contributor
hi guys, is it possible to install owncloud on my padavan rt-n56u? its running entware right now
 

ryzhov_al

Very Senior Member
Sure. Just ignore /jffs/scripts/firewall-start creation from first post. It's asuswrt-merlin - specific.
 

motoxsgb

New Around Here
Newbie here to all of this, managed to get everything installed, but loaded a newer version of php. Are there newer versions of owncloud that have been tested? This is an old post, so before I remove php figured I would verify.

Thanks for the excellent tutorials!
 

miazza

Regular Contributor
Thank you for the tutorial.
I'm not a linux expert and before to apply I would like to understand if with this I can have my own cloud for free.
Sorry for the stupid question but I tried to understand this from owncloud web site and I did not manage.

If this is the case I will apply the tutorial because this would be very usefull and safe for my sensitive data to remain on my HD instead of other cloud managed by third parties.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top