in a pickle.. need help with accessing telnet on osx high-sierra

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Joshua Price

Occasional Visitor
I'm in North Carolina, I have a client in Ohio that I'm trying to rds into their mac computer (using anydesk) and telnet into the asus AC86 router. which isn't hooked up to the internet yet. The goal is to telnet to implement the TTL 65 in the routing table via script so that it can bypass the tethering throttle from a jetpack. I am no mac person, in fact I actually lothe working with macs, always have.

Does anyone have a walk through on how do a simple telnet into the merlin firmware from macs? I can't seem to find one, only shh options which seems more work.. just need to bring up the script notepad and throw in the code, save, have it run the scripts, reboot.. then plug in the jetpack in the usb port, boot up the router... The client's internet is so slow on their laptop it would take 2 days to download el-capitan and another 2 days to download xcode to even start trying to load putty. Is there another method that someone can think of? Maybe a way to bridge networks like on windows and then bridge my computer to the mac's network via vpn? would I be able to tunnel into the router that way for telnet?


No windows pc in house for me to use either. So short of having her mail the asus out to me, mod it, and send it back, I'm at a loss.
 

RMerlin

Asuswrt-Merlin dev
Asuswrt-Merlin doesn't support telnet. You will need to use SSH, which isn't enabled by default.

Why not just enable it on the WAN page through the webui?
 

underdose

Regular Contributor
  1. Enable SSH on Administration page of the router GUI. You don't need to configure anything else, just enable it.
  2. On the mac, run "Terminal" (Applications > Utilities > Terminal)
  3. Type "ssh [email protected]"
  4. Enter router password

You're in.
 

Joshua Price

Occasional Visitor
Asuswrt-Merlin doesn't support telnet. You will need to use SSH, which isn't enabled by default.

Why not just enable it on the WAN page through the webui?
Because for some reason it wouldn't work... only way I've found to do it is with a startup script... Not sure why spoofing using the gui doesn't.. Just know it doesn't... It works with doing it with the mofi routers that give you the ability to set the ttl value with a drop down menu.
 

Joshua Price

Occasional Visitor
  1. Enable SSH on Administration page of the router GUI. You don't need to configure anything else, just enable it.
  2. On the mac, run "Terminal" (Applications > Utilities > Terminal)
  3. Type "ssh [email protected]"
  4. Enter router password
You're in.
thanks. I'll do that tomorrow.. damn apple [] hurts my windows/linux/android brain
 
Last edited by a moderator:

thelonelycoder

Part of the Furniture
Because for some reason it wouldn't work... only way I've found to do it is with a startup script... Not sure why spoofing using the gui doesn't.. Just know it doesn't... It works with doing it with the mofi routers that give you the ability to set the ttl value with a drop down menu.
If you have not done it for a while, then it's time for a router reset, followed by a manual configuration of the settings. Do not restore from a backup file as that would defeat the purpose.
 

ColinTaylor

Part of the Furniture
Why not just enable it on the WAN page through the webui?
This issue cropped up a couple of times recently. For example here.

The problem appears to be that the GUI option sets the TTL to 64 whereas these devices needed it to be 65. To that end John created this fix which allows the TTL value to be set in the GUI.

Side note: Still don't understand the reason the firmware uses the mangle/FORWARD chain rather than the mangle/POSTROUTING. But both seem to work.
 
Last edited:

RMerlin

Asuswrt-Merlin dev
Still don't understand the reason the firmware uses the mangle/FORWARD chain rather than the mangle/POSTROUTING. But both seem to work.
No idea, it`s Asus's implementation. I only know that initially it didn't even work, so for quite some time I was hiding the option. I re-added it at some point.
 

Joshua Price

Occasional Visitor
This issue cropped up a couple of times recently. For example here.

The problem appears to be that the GUI option sets the TTL to 64 whereas these devices needed it to be 65. To that end John created this fix which allows the TTL value to be set in the GUI.

Side note: Still don't understand the reason the firmware uses the mangle/FORWARD chain rather than the mangle/POSTROUTING. But both seem to work.
Nice fix, I've already done the shell way...
No idea, it`s Asus's implementation. I only know that initially it didn't even work, so for quite some time I was hiding the option. I re-added it at some point.
Maybe in the next revision firmware updates you can implement the fix on the firmware.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top