What's new

Log flood by dnsmasq

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

lawk

Occasional Visitor
Hi,

My log is constantly being flooded with this message, once a second:

dnsmasq[22041]: LOUD WARNING: use --bind-dynamic rather than --bind-interfaces to avoid DNS amplification attacks via these interface(s)
dnsmasq[22041]: LOUD WARNING: listening on 213.XXX.218.XX may accept requests via interfaces other than eth0

I only edited my public ipv4 for privacy. Any idea what could be causing it?
 
Hi,

My log is constantly being flooded with this message, once a second:

dnsmasq[22041]: LOUD WARNING: use --bind-dynamic rather than --bind-interfaces to avoid DNS amplification attacks via these interface(s)
dnsmasq[22041]: LOUD WARNING: listening on 213.XXX.218.XX may accept requests via interfaces other than eth0

I only edited my public ipv4 for privacy. Any idea what could be causing it?
Router model and firmware please.
 
RT-AX88U Pro, 3.0.0.6.102_21514

I think I found the cause:

it happens when "Advertise router's IP in addition to user-specified DNS" is enabled.


It still does it with that option disabled.

I tried something else now, let the WAN default DNS from ISP as enabled.

for now the messages are gone.

So this keeps happening. After all.
 
Last edited:
dnsmasq is warning you that it is listening on an interface with a public IP. Whats the output of this command, run on the router over SSH?
Code:
grep -E "bind|interface" /etc/dnsmasq.conf
I don’t think anyone knows what the new Asus source code looks like yet, but this seems unusual, compared to past releases.

My config from Merlin 388 firmware shows:
Code:
# grep -E "bind|interface" /etc/dnsmasq.conf
bind-dynamic
interface=br0
interface=pptp*
no-dhcp-interface=pptp*
interface=br1
interface=br2
 
That’s pretty wild that it explicitly adds the wan interface. Do you run a IPsec VPN server / Instant Guard?
 
I did run IPSec but turned it off, I run Wireguard.

I will try with wireguard turned off.
 
Last edited:

Similar threads

Latest threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top