my AC3100 wifi settings - any room for improvement?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

consorts

Senior Member
i'm really happy that i migrated from the linksys dd-wrt world over here to the asus merlin'sphere ;)
while i will miss using yamon, at least here i have no new bs/kong instability nightmares any more.

so now that everything just works, i was wondering if i still had room for improvement. here are my
wifi settings based on stuff i googled around, trial and error that keeps my two dozen IP's working.
i have a typical residence lan wifi hosting; streamers, ip cams, android/iphones, laptops etc.
i don't need a,b,g anymore, but i still have a few single channel 2.4 n devices to keep happy.
i have not done anything yet with an iot hub and sensors, but will probably get there next year.
i use some bluetooth 4.x devices, usb2 in the router, and a few 900mhz-2.4ghz not wifi gadgets.

regarding mu-mimo (no idea if it's working or not, but whatever),
I only want the type that supports multiple devices simultaneously,
and NOT the one that binds multiple channels to the same device.
i would like beam forming to work, even if mu-mimo really isn't.

router is centered in a 2,000sqtf 70 year old plaster wall apt near a dozen neighbor routers.
un/fortunately they didn't use metal mesh lath in my building, so wifi penetrates well here,
so my readings on system.log/wireless.log 2.4 noise is -92 dBm and 5.0 noise is -88 dBm.
what would you change and why; please stay relevant to my router and merlin firmware;

 
Last edited:

ColinTaylor

Part of the Furniture
Last edited:

consorts

Senior Member

not to get sidetracked here, but YAMon was already intermittent in dd-wrt,
in asus-merlin it stops after an hour no matter how much you tweek it or
how fast write your usb - i would NOT bother here if you value your sanity,
and Al - the developer himself, does not activity support it on asus merlin.
 

loveleeyoungae

Regular Contributor
i'm really happy that i migrated from the linksys dd-wrt world over here to the asus merlin'sphere ;)
while i will miss using yamon, at least here i have no new bs/kong instability nightmares any more.

so now that everything just works, i was wondering if i still had room for improvement. here are my
wifi settings based on stuff i googled around, trial and error that keeps my two dozen IP's working.
i have a typical residence lan wifi hosting; streamers, ip cams, android/iphones, laptops etc.
i don't need a,b,g anymore, but i still have a few single channel 2.4 n devices to keep happy.
i have not done anything yet with an iot hub and sensors, but will probably get there next year.
i use some bluetooth 4.x devices, usb2 in the router, and a few 900mhz-2.4ghz not wifi gadgets.

regarding mu-mimo (no idea if it's working or not, but whatever),
I only want the type that supports multiple devices simultaneously,
and NOT the one that binds multiple channels to the same device.
i would like beam forming to work, even if mu-mimo really isn't.

router is centered in a 2,000sqtf 70 year old plaster wall apt near a dozen neighbor routers.
un/fortunately they didn't use metal mesh lath in my building, so wifi penetrates well here,
so my readings on system.log/wireless.log 2.4 noise is -92 dBm and 5.0 noise is -88 dBm.
what would you change and why; please stay relevant to my router and merlin firmware;

Unless you specifically know your things, as far as I know, the usual recommendation is to disable Universal Beamforming first or all Beamforming features, never heard that Explicit Beamforming should be disabled first.
 

consorts

Senior Member
as far as I know

my understanding is; you start off with all beam forming disable (as you suggested), but once you see your stuff behaving, try universal beam forming enabled, and if your most roaming clients (typically android and iphones) have no new issues, then leave it enabled. explicit beam forming enabled makes more sense if you have a known beam forming support wireless endpoint or a lot of other recent model high end devices with the latest in dual channel AC support (most of my wifi client stuff is a few model years old).
 

loveleeyoungae

Regular Contributor
my understanding is; you start off with all beam forming disable (as you suggested), but once you see your stuff behaving, try universal beam forming enabled, and if your most roaming clients (typically android and iphones) have no new issues, then leave it enabled. explicit beam forming enabled makes more sense if you have a known beam forming support wireless endpoint or a lot of other recent model high end devices with the latest in dual channel AC support (most of my wifi client stuff is a few model years old).
So in this situation enabling/disabling explicit bf wouldn't make any difference anyway, and the usual recommendation is still correct. Alright, you obviously know your things :)
 

DroidST

Regular Contributor
my understanding is; you start off with all beam forming disable (as you suggested), but once you see your stuff behaving, try universal beam forming enabled, and if your most roaming clients (typically android and iphones) have no new issues, then leave it enabled. explicit beam forming enabled makes more sense if you have a known beam forming support wireless endpoint or a lot of other recent model high end devices with the latest in dual channel AC support (most of my wifi client stuff is a few model years old).

I went with the config from RMerlin's post here:

https://www.smallnetbuilder.com/wireless/wireless-features/32329-does-beamforming-really-work

Personally, I recommend disabling implicit/Universal Beamforming (for compatibility reasons), and keeping Explicit enabled on the 5 GHz band only.

Explicit = 802.11ac. Asus changed that label's name over time.



Enable only 802.11ac beamforming on the 5 GHz band, as it's actually part of the 802.11ac specifications, unlike with 802.11n.


So on my 86U, both disabled on 2.4GHz band and only 802.11ac Beamforming on 5GHz Enabled (Universal Beamforming Disabled)

Also, Airtime Fairness and Multi-User MIMO disable on both bands.

Interesting reading
https://www.smallnetbuilder.com/wireless/wireless-features/33100-why-you-don-t-need-mu-mimo

Regular readers know I call MU-MIMO "the 3DTV of Wi-Fi"


.
 
Last edited:

DroidST

Regular Contributor
I have Modulation Scheme enabled on both bands (Up to MSC 11) but thinking about lowing to the first option (MCS 9) on 5GHz and setting the 2.4GHz band to MCS 9 since I will move the 68U to repeater mode on the 2.4GHz band (that is the plan today, still thinking this over).

The 68U will be able to take advantage of TurboQAM with the 86U if I keep the signal good between the two.
 

consorts

Senior Member
Multi-User MIMO disable on both bands... Interesting reading

i checked my system.log/wireless.log and using my current unchanged settings
see amazon firetv sticks at 866Mbps would that mean that mimo was working?
while our older iphones are at 433Mbps as that client does not support mimo?
also some iphones and imacs on 2.4ghz are at 2*72 and 3*72 which would seem
to imply they were bonding more than one typical 72Mbps channel.

(MCS 9) on 5GHz and setting the 2.4GHz band to MCS 9 since... take advantage of TurboQAM.

interesting. i was dealing with buffering issues on firetv sticks while replaying nas based dvr files, and found lowering mcs helped, maybe because my old single drive nas is relatively 40MB/s slow compared to my router & streaming stick (typically a local HDD would be 120MB/s). i don't have any wifi endpoints or other high transfer rate needing wireless devices (isp is only 100 and i lan qos everything to 80), so i leave t.qam off. once all my ip.cams are done, a big fast new nas/dvr will be my next major home tech project. anyway, i may try as you suggest and go MCS-9 then wait and see which family member starts bitching :rolleyes:
 
Last edited:

DroidST

Regular Contributor
More about the Channel Bandwidth and chipset in client (and router): Murata chipsets are repackaged Broadcom WiFi chips and support TurboQAM (MCS 9 on 5GHz?) it looks like. Perhaps SU-MIMO here to?

Our Samsung Galaxy S7's (Murata) report 866.7Mbps (Tx/Rx) as well on 5GHz using up to 80MHz bandwidth, Multi-User MIMO is disabled on my 86U.

Murata KM5D18098 controller. That's 2x2, which means a max link rate of 866 Mbps.

(For the record: never heard of them before)

I just got my 86U up and running so been focusing on stability but those S7's do report the highest speeds of my clients. I want to know what the 68U will report when connected to the 86U.

I also have a firestick 2nd gen, have not used it since going all Roku, I'll attached and see what it reports.

.
 
Last edited:

consorts

Senior Member
i made changes inline with advice here so far, and will report anything i notice later :p



noise is still 92/88, and i have to wait 24hrs and watch when the family uses their wifi :cool:

UPDATE: instead of bumping the thread with a new post, i'll just edit this with new info;
so after 2 days everything seems to still work, no better no worse. the only difference i
can see is the router itself may be working less while devices are sleeping. this because
my STBC capable channel bonding devices will register one channel or drop from DHCP
altogether during long dormant periods (when most family is at work/school) but once
they are home and active, their devices will display RSSI indicative of channel bonding.
i don't see how this benefits me, but maybe my neighbors will enjoy less -dBm loss :rolleyes:
 
Last edited:

Darcy

Senior Member


5GHz settings for my 86U. Is this correct? I have an ASUS 1900P as a bridge connected as well.

Sent from my iPhone using Tapatalk
 

consorts

Senior Member
when fine tuning your wifi settings, it may take a few weeks for intermittent issues to manifest before you can be certain your settings are the best they can be for your router and environment and your collection of devices. after a week i noticed my 5ghz wifi would become unstable, drop connections, misreport to the router, and it forced me to reboot the router to correct. this happened 2 weeks in a row, and provoked me to revisit the settings i reported using on this thread.

the only correction i decided to try was to change the (Wireless/Professional) Modulation Scheme from MCS 9 to MCS 11 for both 2.4 and 5.0ghz radios. it's now been over a week since i made this change, i made no other router changes nor rebooted it, and am happy to report that after a week the 5ghz and other functions are working well and completely stable.

i don't know exactly why my wifi circumstances (1800 sqft apt in wifi congested apt building) may require MCS 11 for 5ghz channel consistency over time, i just know that it does :p

TDLR: raise both 2.4ghz and 5.0ghz Modulation Schemes from MCS 9 to MCS 11 to help insure 5ghz radio stability.

02/2019 update: LAN/Switch Control/NAT-acceleration = auto (may add longer term radio stability)
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top