Solved Need help on resolving local dns with manually assigned dhcp

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

aSae

New Around Here
Hi,

I am using Merlin's 386.2_3 on an AX58U, and need help on getting the local names resolutions for my manually set DHCP IP's to work. The problem is my DHCP client keep defaulting to my dns-over-tls's address instead of to router's address.

I've searched around the forum and have set the:

1. WAN DNS to blank except using the DNS-over-TLS
1629711427781.png


2. Have set the DHCP DNS to blank, and advertise the router's IP enabled.
1629711508249.png


3. My manual/static DHCP is on different pool, 192.168.50.5 to 192.68.50.99. below is example:
1629711615603.png


4. However my DHCP clients keep using the dns-over-tls address instead of router's address (192.168.50.1).
1629711843421.png

5. NSLOOKUP from client keep defaulting to 1.1.1.1 instead of router's address as well, so local names are not resolved unless I force it to use router address.
1629712010519.png


Scratching my head on this one and really appreciate if anyone can help. My suspect is probably conflicting with dns-over-tls/need to take it off?

Thanks in advance, cheers.
 
Last edited:

dave14305

Part of the Furniture
1. WAN DNS to blank except using the DNS-over-TLS
Don’t do that. Put valid DNS servers in there, or set to Automatic.
However my DHCP clients keep using the dns-over-tls address instead of router's address (192.168.50.1).
It must be coincidence, because there’s nothing in the router firmware that uses the DoT servers when setting up DHCP options. Make sure clients don’t have DNS configured manually. Was LAN DHCP DNS ever set to Cloudflare before you made them blank?
 

aSae

New Around Here
Don’t do that. Put valid DNS servers in there, or set to Automatic.
Thanks for the response. I was following similar post in this old thread here since i have a similar setup, but i don't use dns-filter. I will put back a valid dns there.
It must be coincidence, because there’s nothing in the router firmware that uses the DoT servers when setting up DHCP options. Make sure clients don’t have DNS configured manually. Was LAN DHCP DNS ever set to Cloudflare before you made them blank?
Yep, none of the DHCP clients has manual DNS. LAN DHCP DNS was set to cloud flare long time ago when i first setup (386.19), then changed to router's address after a dirty update to 386.2 up to 386.2_3. Put it as blank since yesterday.
 

aSae

New Around Here
Solved! apparently your answer has triggered me to check with another client thinking there might be a cache somewhere, either in the router or the client itself.
So i used another client that was off/dhcp was for sure due for renewal and it's default dns immediately turns into the router. Looks like something's wrong with the frst client where the DNS didn't change although the DHCP was forced renewed several times.

Thanks @dave14305
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top