NordVPN OpenVPN not working on RT-AC86U with firmware 386.3.0 and 386.3.3

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Dr.B

New Around Here
Hi all, I am having issues with NordVPN not working using the OpenVPN client on my RT-AC86U with firmware 386.3.0 and greater. In 386.3.0 it does not seem to connect, but in 386.3.3 it connects, but does not get an IP address assigned. I downgraded to 386.2.6 and it is working again.
 

Adooni

Senior Member
There was change to OpenVPN

386.3 (23-July-2021)

- NEW: Introducing VPN Director, which replaces the original
policy routing management interface for OpenVPN clients.

you should try to clear nvram and setup your router manually and check if it is OK.
 

Dr.B

New Around Here
Did that, ruined all my settings, but did not solve anything. It's connecting in 386.3.3, but no traffic seems to be happening. See attachment.
 

Attachments

  • Screenshot 2021-08-24 at 15.55.05.png
    Screenshot 2021-08-24 at 15.55.05.png
    116 KB · Views: 48

chongnt

Senior Member
Did that, ruined all my settings, but did not solve anything. It's connecting in 386.3.3, but no traffic seems to be happening. See attachment.
From your screen capture, NordVPN are connected. In VPN client GUI page, have you set “Redirect Internet traffic through tunnel” to VPN Director? Then in VPN Director page, you need to add rule to enable client to use which openvpn interface.
 

L&LD

Part of the Furniture
Welcome to the forums @Dr.B.

There is no RMerlin 386.3_3 firmware that I'm aware of? Did you mean v386.4 Alpha 1?

Did you read the changelogs of the differences from the firmware you were previously using?
 

Mark Lear

New Around Here
I am running 386.3.2 and running nordvpn without any issues. I also did not have any changes that I needed to make when upgrading to that firmware and it is using the VPN director (not that the director should matter for getting connected).
 

Dr.B

New Around Here
Thanks Chongnt, I have done so now, and did redirect all traffic through tunnel etc. It was new to me and now I have a connection. Thanks for your help.
From your screen capture, NordVPN are connected. In VPN client GUI page, have you set “Redirect Internet traffic through tunnel” to VPN Director? Then in VPN Director page, you need to add rule to enable client to use which openvpn interface.
 

Dr.B

New Around Here
I am running 386.3.2 and running nordvpn without any issues. I also did not have any changes that I needed to make when upgrading to that firmware and it is using the VPN director (not that the director should matter for getting connected).
you are right, I meant 386.3.2 it was a typo. I have now indeed changed the tunnelling and activated the connections in VPN director.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top