What's new

Pause/stutter MKV video using NFS on AC86U and NFS Exports server fails to start on AC68U

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Thanks @Buontinh. I'm a bit confused by your output, but I think that may just be cosmetic differences between our firmwares. Is your AC68 in "router mode"?

Can you post the output of this command:
netstat -anp
You are using NFS 'legacy' mode.....is that by choice?
My procedure to set the number of threads should work on both the AC68 and AC86.

Also, your ps output shows you already have 8 nfsd threads running...not sure why that is.

Yes, it's by choice as Oppo does not work with anything newer, but I have also tried disabling it with the same results.
Can't try those commands on the AC86U yet as it's currently using an old Asus firmware for Samba V1 as the newest no longer support it and Oppo only work with legacy samba.
Would enabling and disabling the service 8 times cause it to get stuck and stay running 8 times?
Thanks @Buontinh. I'm a bit confused by your output, but I think that may just be cosmetic differences between our firmwares. Is your AC68 in "router mode"?

Can you post the output of this command:
netstat -anp
Yes, AC68U running in router mode.
Please see attached file for netstat results as code is too long to post.


  • ac68u netstat.txt
    26.4 KB · Views: 90
I reset the router, went through the wizard to configure wifi then went straight to NFS Exports; added a simple share then toggled the button without changing anything else, but same exact thing. This is with beta5 still.
Well I'm out of ideas and don't have a spare router to test with. If you have access to a Linux PC you could use rpcinfo to perform some diagnostics.
Since Samba works really well on the AC86U, I will just use it for now and hopefully this will be corrected some day and I will go back and try NFS again as it's always nice to have the latest firmware just for peace of mind.
I appreciate all the helps you and others have given though.

One more...
It turns out that Merlin was using a later version of NFS support than my fork. So I updated, and guess what....it didn't work.

Turns out this innocuous looking little error is preventing it from starting.

Jan 29 19:06:03 statd[29673]: Failed to open directory sm: No such file or directory

So, try the following on the AC68U via ssh

service stop_nfs
mkdir -p /var/lib/nfs/sm
service start_nfs

I also figured out
Jan 24 20:09:44 kernel: svc: failed to register lockdv1 RPC service (errno 97).

We don't have all the libraries to support NFS IPv6, but the kernel is compiled with IPv6 support. It's really just a cryptic warning telling us about it.
Last edited:
I had high hope for this, but sorry to say it still does not work for me. Maybe it's a bug in the firmware, but it's strange that I also couldn't get NFS to work with 384.19 on the AC68U either, although both the final and beta firmware worked on the AC86U.

I stopped the service then created the folder as suggested although I have no idea what the -p switch does. The error about not finding sm no longer come up after creating the folder and starting NFS from the GUI or shell, but both of my Windows 10 computers could only see the Samba server. The sm folder disappears whenever I reboot the router which is probably normal. I also tried disabling NFS, reboot the router, recreated sm folder, then tried enabling NFS from the GUI as well as shell but same thing.
@Kaver163 Great to hear that it works with Samba 4. I'll have to try it when I get a chance as I'm currently running a very old version of Asus firmware on my AC86U just to get NT1 support for the OPPO 103.

@Kaver163 Could you please provide instructions. I did a bit of Googling and found instructions on installing Debian Wheezy and Squeeze only.

@Kaver163 Thanks. Yeah, I found it, but confused about EXT_DIR... so I don't need to change it if I don't want to use external directory? Also is Entware better than Optware?

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!