[Question] Force DDNS update when IP changes

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

sentinelvdx

Very Senior Member
Hi,

My new Fiber ISP seems to have less than 24hs lease time, which s*cks...
Is there any script which might help updating it when new WAN IP is detected?

Thanks,
 

L&LD

Part of the Furniture
Just set the interval to 1 day in the GUI settings.
 

sentinelvdx

Very Senior Member
Just set the interval to 1 day in the GUI settings.
It's already like that but doesn't work, because sometimes it changes IP 1 or 2 times the same day, causing being unable to join my VPN server.
 

L&LD

Part of the Furniture
So, it's much less than 24 hours then.
 

sentinelvdx

Very Senior Member
Yup, sadly... and it's getting me crazy... I already sent them an e-mail to rent a static IP if I can't solve it
 

ColinTaylor

Part of the Furniture
You could schedule a periodic service restart_ddns. Although if your IP address is changing then I would have thought that the router would be doing this automatically anyway, perhaps not.
 

dosborne

Very Senior Member
I update my ddns info by running a scheduled script from another box (raspberry pi, or NAS,...). Run it as frequently as you want.
 

sentinelvdx

Very Senior Member
You could schedule a periodic service restart_ddns. Although if your IP address is changing then I would have thought that the router would be doing this automatically anyway, perhaps not.
Could be.... I was thinking on extending echo, maybe it's that causing
I update my ddns info by running a scheduled script from another box (raspberry pi, or NAS,...). Run it as frequently as you want.
Thing is router is using ASUS DDNS and OpenVPN server is running on the router, and I use a .cfg file to get client settings
 

dosborne

Very Senior Member
thing is router is using ASUS DDNS and OpenVPN server is running on the router, and I use a .cfg file to get client settings
Well, if the Asus ddns option doesn't give you the flexibility you want, then another free or paid ddns service should (and does). Something to consider.
 

sentinelvdx

Very Senior Member
Well, if the Asus ddns option doesn't give you the flexibility you want, then another free or paid ddns service should (and does). Something to consider.
Maybe I didn't explain myself well.

Problem is not ASUS DDNS, problem is that OpenVPN server is mounted on router, so if I switch DDNS provider I'm on the same situation. I need ddns to update IP as soon as it changes, or a script to force update every hour for example.

Unless I can add my NAS DDNS into openvpn .opvn config file which updates ddns as soon as new WAN IP is detected
 
Last edited:

bluepoint

Very Senior Member
Hi,

My new Fiber ISP seems to have less than 24hs lease time, which s*cks...
Is there any script which might help updating it when new WAN IP is detected?

Thanks,
DDNS will update to a new ip automatically when it changes, just make sure your local wan dns caching server is set to 'no'.
 

sentinelvdx

Very Senior Member
DDNS will update to a new ip automatically when it changes, just make sure your local wan dns caching server is set to 'no'.
Didn't check how I left dns caching... I'll give a try once back and update
 

bluepoint

Very Senior Member
Why would this be necessary?
It's my experience that when dns caching is set to yes the DDNS recovery doesn't work. I know it might not makes sense but it seems it's a timing thing that when Inadyn needs connection to resolve from a DNS it's not available while waiting for dnsmasq to come up instead of being available already once a WAN connection is up and I believe it only tries to correct the IP once only in this instance. Maybe RMerlin can look into this.
Step to reproduce.
a. Disconnect from WAN in not a normal way( disconnect/connect the WAN Ethernet cable making sure you obtain a different IP)
 

ColinTaylor

Part of the Furniture
It's my experience that when dns caching is set to yes the DDNS recovery doesn't work. I know it might not makes sense but it seems it's a timing thing that when Inadyn needs connection to resolve from a DNS it's not available while waiting for dnsmasq to come up instead of being available already once a WAN connection is up and I believe it only tries to correct the IP once only in this instance. Maybe RMerlin can look into this.
Step to reproduce.
a. Disconnect from WAN in not a normal way( disconnect/connect the WAN Ethernet cable making sure you obtain a different IP)
I just tried this (with DNS caching set to yes) and it worked without any problems. But as you say, it might be a timing issue that only effects certain users.
 

bluepoint

Very Senior Member
I just tried this (with DNS caching set to yes) and it worked without any problems. But as you say, it might be a timing issue that only effects certain users.
Yes, something doesn't align right for certain setup. In my case using ASUS server for DDNS and FIOS.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top