Repeater/Bridge to Guest Network broken on 386.3

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.


New Around Here
After upgrading to 386.3 from 386.2_6, I noticed my guest router, which connects to my guest wifi in repeater mode, no longer gets assigned an IP from the main network and instead runs as

Main setup: 3x AC68U in AiMesh with a guest network in 5G band.
Guest setup: 1x AC68U in repeater mode, wirelessly connected to the guest network.

1. With main setup on 386.3, issue reproduces regardless of guest router version and resetting the guest router didn't help.
2. Issue goes away if the repeater connects to the main wifi instead of the guest wifi.
3. Issue reproduces with guest router in both repeater and media bridge modes.
4. Reverting to 386.2_6 makes everything work properly again.

Does anyone have a similar bridge to guest network setup? Appreciate any suggestions! :)


Occasional Visitor
I've tried this with my own setup just now with 2x RT-AC68U routers on 386.3 (I haven't updated to 386.3_2 yet).
Primary router IP is, second router in repeater mode is set to get assigned an IP via DHCP, and gets assigned
The Guest Network on my primary router is in Index 2 (so not on a separate VLAN like Index 1)
Maybe try a factory reset?

Out of curiosity, why do you connect the guest router as a repeater to the guest SSID instead of the primary SSID?
Have you tried connecting to the Guest router yourself?
I think you'll find that it makes no difference whether you connect the guest router to the primary or guest SSID - from my own testing, anything connected to the guest router has full access to the primary network (network shares, chromecasts, etc), regardless of which SSID the guest router connects to the primary router on.
Last edited:


New Around Here
The problem goes away if I connect the repeater router to the main wifi instead of the guest wifi. Thanks for the tip!

My main router is in AiMesh mode. That seems to be the difference in our setups. I tried again today and can still reproduce the original problem.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!