What's new

Solved Router ignoring DNS settings

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

SO333

Occasional Visitor
Hello!
Today, I had some DNS issues (some URLs not beeing resolved).
After checking, it seems, my RT-AX88U (Firmware:3004.388.4) is ignoring the DNS server setting for its own queries (and maybe even for other queries as well, cannot check), and forces Cloudflare's 1.0.0.2 for some reasons, although it is not defined in the GUI.
Disabling DNS Director or DoT produces the same result, it always uses 1.0.0.2:

Used server for nslookup is cloudflare:
1696413328188.png


Settings. Here, Googles server is defined
1696413373850.png

1696413400386.png



Is this a bug, or am I doing something wrong? (Tools---> Other --> Wan: Use local caching DNS server as system resolver (default: No) is also on "no".
 
Have you made any changes in LAN>DNS Director? Global Redirect should be set to "Router".
 
Have you made any changes in LAN>DNS Director? Global Redirect should be set to "Router".
Yes (and no :)), see screenshot. Global Redirect to router.

----Edit ----- now changed again
What is strange, /etc/resolv.conf looks like this:

ASUSWRT-Merlin RT-AX88U 3004.388.4_0 Mon Aug 21 19:35:36 UTC 2023
me@RT-AX88U-EA00:/tmp/home/root# cat /etc/resolv.conf
nameserver 1.0.0.2
nameserver 5.9.164.112
nameserver 127.0.1.1

Here, the 1.0.0.2 is specified. Is this correct? Does your resolv.conf looks the same?
----Edit ----- now changed again

Now, the file is empty...
 
Last edited:
1.0.0.2 would be Asia-Pacific Cloudflare DNS server.
Reboot the router and test again.
 
Mine
Code:
cat /etc/resolv.conf
nameserver 9.9.9.11
nameserver 149.112.112.11
nameserver 127.0.1.1
which is correct for my DNS
 
Last edited:
In DNS Director it looks like you've set up specific DNS for some devices. Only do this if necessary as it bypasses the Global Redirect.
 
It’s either coming from stale nvram settings or ISP DHCP.
Code:
nvram show 2>/dev/null | grep -F "1.0.0.2"
grep -F "1.0.0.2" /tmp/wan*bound.env
 
It’s either coming from stale nvram settings or ISP DHCP.

Thanks! Here we go, directly from nvram:
Code:
me@RT-AX88U-EA00:/tmp/home/root# nvram show 2>/dev/null | grep -F "1.0.0.2"
wan0_dns=1.0.0.2 5.9.164.112
wan0_dns1_x=1.0.0.2

me@RT-AX88U-EA00:/tmp/home/root# grep -F "1.0.0.2" /tmp/wan*bound.env
me@RT-AX88U-EA00:/tmp/home/root#

Maybe something from a previous version? Can I delete this entry (and how?)
 
Maybe something from a previous version? Can I delete this entry (and how?)
Go back to the WAN page and click the Assign button in the DNS section. Change it to something else, save it, then change it back to Google and save again.

Is there any Dual WAN setup to worry about?
 
Go back to the WAN page and click the Assign button in the DNS section. Change it to something else, save it, then change it back to Google and save again.

Is there any Dual WAN setup to worry about?

No Dual-WAN to is active or used.

I rebooted the device, /etc/resolv.conf again contains 1.0.0.2 as well as NVRAM.
Then I changed the settings as described (+ added Quad to DNS over TLS), no change in file or nvram. After reboot, still no change.
nslookup always uses the 1.0.0.2, although this is nowhere used in the settings :-/
I wonder about the secondary DNS (5.9.164.112): this is something I have used quite some time before and entered it in the old settings many versions ago. I still have the feeling, the new DNS settings are overwritten by this old setting.
 
Interestingly enough, the changes in the Webgui are propagated to wan1 and wan, but not to wan0, which seems to be used?!
Code:
me@RT-AX88U-EA00:/tmp/home/root# nvram show | grep -F "9.9.9.9"
size: 86823 bytes (44249 left)
wan1_dns=9.9.9.9 149.112.112.112
wan1_dns1_x=9.9.9.9
wan_dns=9.9.9.9 149.112.112.112
wan_dns1_x=9.9.9.9

Code:
me@RT-AX88U-EA00:/tmp/home/root# nslookup www.google.com
Server:    1.0.0.2
Address 1: 1.0.0.2

Name:      www.google.com
Address 1: 142.250.203.100 zrh04s16-in-f4.1e100.net
Address 2: 2a00:1450:400a:808::2004 zrh04s16-in-x04.1e100.net


me@RT-AX88U-EA00:/tmp/home/root# nvram get wan0_dns
1.0.0.2 5.9.164.112
me@RT-AX88U-EA00:/tmp/home/root#
 
You might have some remnants of old custom scripts or config files messing with DNS. Try disabling custom scripts in the GUI, rebooting and then seeing if you can successfully change the WAN DNS servers.
 
It is off, although I remember that I once used it with my Android phone with USB as the ISP had issues.

1696426109266.png
 
Which wan shows primary = 1?
Code:
nvram show 2>/dev/null | grep -E "wan?_primary"
I can’t understand why the GUI is saving to wan1 dns.
 
Which wan shows primary = 1?
Code:
nvram show 2>/dev/null | grep -E "wan?_primary"
I can’t understand why the GUI is saving to wan1 dns.

Some issue with regex, but it seems wan0 is used.

Code:
me@RT-AX88U-EA00:/tmp/home/root# nvram show 2>/dev/null | grep -E "wan?_primary"
me@RT-AX88U-EA00:/tmp/home/root# nvram show 2>/dev/null | grep -F "primary"
bsd_primary=192.168.1.1
wan0_primary=1
wan1_primary=0
me@RT-AX88U-EA00:/tmp/home/root#
 
Some issue with regex, but it seems wan0 is used.

Code:
me@RT-AX88U-EA00:/tmp/home/root# nvram show 2>/dev/null | grep -E "wan?_primary"
me@RT-AX88U-EA00:/tmp/home/root# nvram show 2>/dev/null | grep -F "primary"
bsd_primary=192.168.1.1
wan0_primary=1
wan1_primary=0
me@RT-AX88U-EA00:/tmp/home/root#
Yes, thanks. My blatant error.
 
Some issue with regex, but it seems wan0 is used.

Code:
me@RT-AX88U-EA00:/tmp/home/root# nvram show 2>/dev/null | grep -E "wan?_primary"
me@RT-AX88U-EA00:/tmp/home/root# nvram show 2>/dev/null | grep -F "primary"
bsd_primary=192.168.1.1
wan0_primary=1
wan1_primary=0
me@RT-AX88U-EA00:/tmp/home/root#
Edit:
Your hint with the 2 WANs was very good! I have enabled dual wan, and suddenly I get:
Code:
me@RT-AX88U-EA00:/tmp/home/root# nvram show 2>/dev/null | grep -F "wan_dns"
none_wan_dns=9.9.9.9 149.112.112.112
none_wan_dns1_x=9.9.9.9
none_wan_dns2_x=149.112.112.112
none_wan_dnsenable_x=0
wan_dns=9.9.9.9 149.112.112.112
wan_dns1_x=9.9.9.9
wan_dns2_x=149.112.112.112
wan_dnsenable_x=0
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top