Router is overwriting my preferred IPv6 DNS address?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

gil80

Occasional Visitor
Router: RT-AX88U
Firmware Version:386.1_2

Enabling IPv6 after getting my ISP to enable it for me.
The router is advertising itself as my DNS despite my settings to use my own Pihole as my DNS.

Is there something I'm missing in how it is configured?

1615272784702.png


1615272923789.png



Code:
[email protected]:~ $ ip -o addr
1: lo    inet 127.0.0.1/8 scope host lo\       valid_lft forever preferred_lft forever
1: lo    inet6 ::1/128 scope host \       valid_lft forever preferred_lft forever
2: eth0    inet 192.168.1.2/24 brd 192.168.1.255 scope global noprefixroute eth0\       valid_lft forever preferred_lft forever
2: eth0    inet6 2403:5800:7300:cb00:6de6:be72:631c:ccdc/64 scope global dynamic mngtmpaddr noprefixroute \       valid_lft 594sec preferred_lft 594sec
2: eth0    inet6 fe80::c5ab:3326:1085:e247/64 scope link \       valid_lft forever preferred_lft forever
4: wg0    inet 10.6.0.1/24 scope global wg0\       valid_lft forever preferred_lft forever

As you can see, this IP 2403:5800:7300:cb00:6de6:be72:631c:ccdc is the IPv6 of Pihole which is set as the DNS in the IPv6 settings in my router, but according to IPCONFIG /ALL my IPv6 DNS is the router 2403:5800:7300:cb00::1

Am I wrong here? Maybe I misunderstand something here?
 

dave14305

Part of the Furniture
The IPv6 DNS settings are like the IPv4 WAN DNS server settings. The router will forward DNS requests to those 3 servers, but give its own IPv6 address to the clients for DNS resolution.
 

gil80

Occasional Visitor
The IPv6 DNS settings are like the IPv4 WAN DNS server settings. The router will forward DNS requests to those 3 servers, but give its own IPv6 address to the clients for DNS resolution.
is there a way to disable the router from doing that?

With IPv4, there's an option for that:
1615289529246.png
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top