RT-AC87U Plex Setup, WAN Issue - Some Help Please

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

RedSector

New Around Here
Hello, I'm having trouble getting Plex to work outside world using the configuration that I currently have. I would like some help to make this work correctly, everything I have tried has failed, thus hoping you can just tell me what I need to do to make this work correctly.

RT-AC87U Firmware Version: 384.13_10
Plex works locally (LAN) and I'm already able to Host TeamSpeak LAN/WAN from the same server without issue.

amtm is installed with:-
1 Diversion
divserion standard
ad-blocking to IP
pixelserv-tls
blocking list standard
DNSmasq.conf.add (only this entry) rebind-domain-ok=/plex.direct/

3 FlexQos
5 scribe
J1 connmon
j3 scMerlin
j5 uiDivStats
J6 uiScribe
ep Entware Packages
sw swap file

DDNS is set up (using internal script) from the menu in the RT-AC87U and using NO-IP.

WAN DNS Setting:-
Connect to DNS Server automatically: Yes
Forward local domain queries to upstream DNS: No
Enable DNS Rebind protection: Yes
Enable DNSSEC support: Yes
Validate unsigned DNSSEC replies: Yes
DNS Privacy Protocol: DNS-over-TLS (DoT)
DNS-over-TLS Profile: Strict

Static IP assigned to Plex Server
I have VPN setup, however the server/plex is not part of it.
Trying not to muddy the water with what I think or failed with. I would like to keep this setup within reason (I want Plex to work as well)
Plex is default setup, If I need to make changes here just list them out and make it happen.

Thank you in advance.

What do I need to do to make Plex available on WAN traffic ?
 
Last edited:

elorimer

Very Senior Member
Not to be reductive, but are you signed in and is remote access enabled in the Plex settings?

I don't have the dnsmasq.conf.add entry.
 

RedSector

New Around Here
Not to be reductive, but are you signed in and is remote access enabled in the Plex settings?

I don't have the dnsmasq.conf.add entry.

Thankyou for your reply.

Yes signed in and yes enabled (remote access), it goes green initially then about 3-10 seconds latter red and displays the correct WAN IP. (sadly no access from WAN side of course)
That entry, it's from when I was running Skynet. Not 100% sure why I added it now.
Can I ask, is your set up an identical one using TLS and DDNS, (my thought was a problem here, then again trying to get new eyes to look at this)

Maybe should try Skynet path again. Its removal was a failed experiment in trying to find the issue.

Maybe I'm asking the wrong question with how do I get Plex to work.

Perhaps I should be asking this question.
How can I go about troubleshooting this issue myself, where should be looking for data or what tools will help me find the problem or the data to allow you to help me with it?
 
Last edited:

elorimer

Very Senior Member
I don't have the DoT setting or the strict policy. I'm using unbound. So those might be avenues to pursue. I don't think DDNS has anything to do with it, because Plex is not invoking that. I'm assuming the plex server is some thing on the network and not on the router.

Don't think skynet is an issue, never had any issue there over, um, a bunch of years.

Me, I would save my config and jffs. Then I would reset the router to default, and then add back the bare mininum of stuff (no addons or scripts or anything). Then I would see if plex works. If it does, then I would start to add back other things. (actually, I would then bring back all the addons--i can't see they are in this picture).

Without being discouraging, I run plex off my NAS, and I have blown it up and reinstalled maybe 50 times. Plex is running in a jail and its config is in a dataset, and the data in another dataset, so those aren't affected and it takes only a minute or so.
 

RedSector

New Around Here
Local service connection is FTTN -> Bridge Router -> Asus RT87U -> 10 port giga bit switch -> NAS
It is on computer (Windows 10 AMD 1800x) which call my NAS 16tb of amm movie goodness / backup etc. LAN hardwired and run a Teamspeak server from it.

Thinking the same, time to blow it away, reset to default and start again. No rush though. The issue is a problem to be solved and this will be last course of action. I could drop DoT and see if this is source problem?

I agree, Skynet was not the issue.
what is unbound, can it encrypt DNS lookup ?
Interesting, In a jail / config data set, how would I go about doing this ?
 
Last edited:

elorimer

Very Senior Member
I've poked at my config and there might be a something to try. I have plex.tv and plex.direct in my Diversion whitelist but I haven't the foggiest idea when or why I added it; if you use diversion you might add those domains (which then get picked up by skynet) or add them in skynet. I can see when I go to plex.tv a lot of traffic is going back and forth to subdomains. But maybe that's why I haven't had a problem.

You might run down the plex remote access troubleshooting list: Plex Remote Access. If Plex is working from within the LAN, then it must be it is reaching the plex servers to log in, etc (I'm on plex pass), so it is unlikely to me that this is DNS related. It is more likely to me that the plex traffic isn't being forwarded properly. The remote access settings page is supposed to warn if this is true, but that troubleshooting checklist might help there.

With 16TB of data I can see why you wouldn't want to rescan your files. My plex server is a jail on a TrueNAS server so anything I know is unlikely to help. But the general idea is that the jail is like a container, with the database and the data outside the jail. Destroy the jail, recreate it, and point again to the database and data. I don't know if you can do that with your server.

Unbound too big a topic to discuss here and a lot depends on how you set it up. I don't do DoT because I use it as a recursive resolver rather than resolving over an encrypted connection to a server that accepts it. Go over to the addons section and go through the thread. (Remembering "nevertheless, she persisted".)
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top