What's new

RT-AC88U WAN speed hitting max DL of around 500Mbps from speedtest?

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

aftershox

New Around Here
Hoping you can help me out with a puzzling situation?

My ISP (Virgin Media UK) Volt 1Gbps (1000Mbps) DOWNLOAD / 100Mbps UPLOAD service.
I have the ISP equipment running in "modem mode" - it is the VM HUB 4.

Connected to that, I have the RT-AC88U as the "AiMesh Master"
- additionally - I have the RT-AC68U as a "Mesh Node"

WAN Port on the AC88U goes directly into the VM HUB 4 (LAN port 1)

If I run the "speed test" via the Admin WEB GUI, via Adaptive QoS (Internet Speed TAB) - the best DL speed I can achieve is around 500Mbps (DOWNLOAD)- with the average UL speed around 95-103Mbps (UPLOAD).

It would appear that the WAN port on the AC88U somehow hits a maximum limit, and cannot go beyond 500Mbps.

If I connect a laptop directly to the HUB 4 in "modem mode", I can achieve 900-1130Mbps (DL) and around 105-130Mbps (UL), so I know it is not the connection nor is it the cables (as I use the same cable switched over to the laptop from the router WAN port).

The AC88U is running asuswrt-merlin 386.12_4
The AC68U is running stock Asus Firmware 3.0.0.4.386_51915-g43629d2

I've also tried running the same tests on the AC88U with latest stock Asus Firmware, and it is exactly the same.

The AC88U is setup in a "light" configuration, QoS off, Traffic Analysis off, AiProtection Off - everything off. I've also tried with the Wireless networks as Smart Connect, and also as seperate 2.4Ghz / 5Ghz WLAN's - and this doesn't affect the speed test - it always seems to cap out at around 500Mbps, often a little less.

I've also been into Administration, Privacy Control and selected "Withdraw" on both entries. For the tests, I've been using the WEB GUI on the AC88U.

The routers have been hard-reset and setup with the minimal features.

I've read most of the posts I could find, but nothing conclusive jumped out.

Any pointers please?
 
Last edited:
The built-in speed test is limited by the router's CPU. It's not a valid test. Test again using a PC connected to the router by ethernet.
I'll connect the laptop via a switch port on the AC88U and re-run the tests from the laptop. I'd already tested the laptop direct to ISP HUB, but not via the switch ports in the router.
 
WAN Port on the AC88U goes directly into the VM HUB 4 (WAN)
Absolutely sure about this? AC88U WAN should go to HUB 4 LAN, surely?
 
This VM Hub 4 appears to be DOCSIS modem/router. It doesn't have a WAN port.


Must be a mistake.
you can configure it in modem mode/bridge mode and then only 1 lan port gives WAN access to a attached devices (e.g router )
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top