RT AX86U: problems with 2.4g devices on smart connection

havrancek

Occasional Visitor
Hey guys,
I need help. I had RT-AC68U and this year I have bought AX86U. I love how snappier and quick it is, but I have a long problem with old devices using only 2.4g bandwidth.
I am using a combined smart connection 2.4g + 5g together as a main Wi-Fi for my family. Also I have a backup net, which I am sharing with my neighbour as a guest network (set to not to have access to our main network, and it is just 2.4g band) Main is xxx.xxx.50.xxx, guest net is xxx.xxx.101.xxx.
Firstly, I wanted to connect my smart Wi-Fi bulbs to the .50 net, nothing. Then some RPies 3 and 4s, nothing, cant. Then Sonos, without success, etc. Everything working in 2.4g band (even when I set a MAC address with a static IP and turn on possibility to use only 2.4g band, it connects, but is not available, not visible, nothing) I tried to pair them with the guest network, and there it works, but I don't want to have my devices on a shared network, so I am trying to figure out what to do to make it work.
It is the only minus I am experiencing from the start.

Can pls someone help me with setting it up to be able to have 2.4g devices working on smart connection? I know I could make 2 networks, but the no is my family. They require just one. Also, with Wifi6 working, because they have devices which uses it.

I love Merlin for his work and this community, as a long time lurker.
 

Attachments

  • _r_router0.png
    _r_router0.png
    372.9 KB · Views: 141
  • _r_router1.png
    _r_router1.png
    310.3 KB · Views: 145
  • _r_router2.png
    _r_router2.png
    335.9 KB · Views: 135
Last edited:

BreakingDad

Very Senior Member
Run raspi-config and go to "Localisation Options" then "Change Wi-fi Country". Set it your country, this should help the pi's contect to 5ghz.

As for the other devices, not sure, you "could" force them off 2.4 ghz using the mac filter.
 

havrancek

Occasional Visitor
Run raspi-config and go to "Localisation Options" then "Change Wi-fi Country". Set it your country, this should help the pi's contect to 5ghz.

As for the other devices, not sure, you "could" force them off 2.4 ghz using the mac filter.
I am not forcing them off 2.4g, I am forcing them to use 2.4g on the smart connection, but with no luck. They connect, but are not accessible or usable.
 

mlord

Regular Contributor
Your settings look similar to mine here, except my country code (and therefore the permitted channels) is different. I'm in Canada, and all of my ESP8266, ESP32, RaspPi, and other 802.11n devices work fine on 2.4GHz.
 

thewan

Occasional Visitor
Did you try using manual connection mode instead of the default auto discovery for your smart stuff? Thats how I got my Wiz bulbs to connect. Sure I had to connect each bulb manually instead of Auto discover and connect all the bulbs together, but they work flawlessly so far after all that hard work. And I still get to keep my dual band smart connect enabled.
 

havrancek

Occasional Visitor
Did you try using manual connection mode instead of the default auto discovery for your smart stuff? Thats how I got my Wiz bulbs to connect. Sure I had to connect each bulb manually instead of Auto discover and connect all the bulbs together, but they work flawlessly so far after all that hard work. And I still get to keep my dual band smart connect enabled.
Of course, I did. I tried everything possible, tried what could I find on net. Without success. There has to be some "glitch" which is doing this. I can't find it, therefore I am writing here, as a last resort.
 

bbunge

Part of the Furniture
Of course, I did. I tried everything possible, tried what could I find on net. Without success. There has to be some "glitch" which is doing this. I can't find it, therefore I am writing here, as a last resort.
With the new AX router you may be tempted to use WPA3/WPA2-Personal. I did and found my older clients did not like it. One solution is to set Guest WIF with just WPA2-Personal which should be used for IoT devices for security reasons anyway. Or use WPA2-Personal for everything. My Pi devices thanked me¡
 

havrancek

Occasional Visitor
With the new AX router you may be tempted to use WPA3/WPA2-Personal. I did and found my older clients did not like it. One solution is to set Guest WIF with just WPA2-Personal which should be used for IoT devices for security reasons anyway. Or use WPA2-Personal for everything. My Pi devices thanked me¡
I am using WPA2-Personal everywhere, because of the thing you are mentioning.
edit: But my RPies are still not cooperating
 

havrancek

Occasional Visitor
Now I was able to connect my Yeelight Strip finally, I opened the port for it in Router Firewall. I am just wondering if it could be the case with all my other devices... I don't have any advanced settings, it is just turned on.
edit: no, it was temporary, it is still of, unavailable
 
Last edited:

intracode

New Around Here
I have a similar setup. I presume you are setting up these smart devices from your mobile. If so then make sure your mobile is connected to 2.4 G and not 5 G. Usually both share the same SSID and PW. An easy way to distinguish between the two is to rename your 5G SSID by selecting 5G band and adding 5G to the end of the SSID.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top