What's new

seeking help with bridge mode

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Fredex

Occasional Visitor
I live in an apartment complex that provides wifi, but not cabled network.

I moved here from my house where I had a wired LAN.

this facility did not have wifi until recently, so we all used Comcast internet, so when I moved here I just plugged the Comcast cable into my router, and everything in my LAN behaved exactly as before.

Now, I am using the wifi via a Raspberry Pi (4B) configured to bridge the wifi to my LAN. It works great, mostly, but there are a couple of issues:
1: I get only 40-60 MBpS from a wlan where I should be able to get several times that. I suspect the Pi's WIFI just doesn't work very fast. I also find I am always assigned only a 20 MHz channel width, never 40 or 80 or 160 or ...., so maybe the Pi just doesn't do extended channel widths.
2: something causes a wifi disconnect every 24 hours. I don't THINK it is on my end, but the tech folks here are singularly unhelpful, so finding another way to bridge my LAN to wifi may be an instructive experiment.

So, I would love to use my (now replaced) RT-AC86U (running latest Merlin release for that platform) as a bridge to replace the Pi (for testing purposes, at minimum, if not permanently) to see if the router can improve either of those two issues.

Trouble is, I am sufficiently ignorant of how such things work, that I have not been able to get the router's bridge mode to do what I want to do. I am hoping/expecting that it can connect via WIFI to the facility WIFI (at a specific SSID or MAC) and bridge that network to my new router (RT-AX86U) via ethernet. I tried configuring that, based on the really scanty hints in the Asus documentation, but the instant I enable the bridge the LAN connection stops working.

I'd be very grateful if any of you can help enlighten me on (1) is it even possible to do this? and (2) how I might make it work.

Thanks in advance for any guidance you may offer!

Fred
 
It should be straight forward. Configure your spare router as a "Media Bridge" connected to your facility Wi-Fi and then plug it into the WAN port of your RT-AX86U.

The only thing to make sure of is that the IP subnet of the facility Wi-Fi must be different than your RT-AX86U's LAN subnet.
 
It should be straight forward. Configure your spare router as a "Media Bridge" connected to your facility Wi-Fi and then plug it into the WAN port of your RT-AX86U.

The only thing to make sure of is that the IP subnet of the facility Wi-Fi must be different than your RT-AX86U's LAN subnet.
that's what I figured should happen. I may have fat-fingered a config somewhere.

when you say "plug it into the WAN port of your RT-AX86U" you mean a cable from a LAN port on the AC86U to the WAN port of the AX86U, correct?

and I assume that so the AX86U can find the AC86U, the AC86U's LAN needs to have a static IP...

Thanks for the reply!

Fred
 
when you say "plug it into the WAN port of your RT-AX86U" you mean a cable from a LAN port on the AC86U to the WAN port of the AX86U, correct?
Correct.

and I assume that so the AX86U can find the AC86U, the AC86U's LAN needs to have a static IP...
IIRC the bridge itself can be configured as a DHCP client of the facility Wi-Fi's. So it would have an address in that subnet range. In effect you would have two DHCP clients connected to the facility Wi-Fi, the media bridge and the AX86U (through the bridge). Try to setup the bridge first using a PC/laptop connected to the AC86U. Once that's working just swap the PC/laptop with the AX86U.
 
Last edited:
You should also select channels for your WiFi that are not in use by the building WiFi. If they use all channels, then choose one with the weakest signal.
 
well, not sure where to go now...
I set it up as best I can, switched to bridge mode,logged in again and the UI shows only a few menu items--which, I guess, is normal. but from the UI I am unable to select any of the clickable items. hovering over any of them gives a hand pointer, but tapping on the touchpad of the laptop I'm using does nothing.
worse, I remove the cat-5E from the Raspberry PI, plug it into one of the LAN ports, I see the lan port light blinking like mad but can access nothing on the internet. the network map shows the WAN as disconnected, should it?
 
You should be seeing this:

b843d99b-3135-4b37-b169-8601266b5ff5.png


 
You should also select channels for your WiFi that are not in use by the building WiFi. If they use all channels, then choose one with the weakest signal.
I don't think that's relevant for Media Bridge mode because it's not a repeater.
 
Morris, I don't understand the "weakest signal" theory. weakest signal means worst thruput, so why would I want to do that?

there are many AP's in the building, but one of them has better signal strength than any of the others (probably closest to me), so why wouldn't I want to use it?
 
there are many AP's in the building, but one of them has better signal strength than any of the others (probably closest to me), so why wouldn't I want to use it?
I think I may have misunderstood the nature of your internet connection. I thought that the "facility WIFI" was your own personal internet connection, like the Comcast one, but delivered over Wi-Fi. It now sounds like this is a shared internet service, much like a hotel might provide. If that's the case then it's quite likely this won't work as it won't allow more than one client to connect over a single Wi-Fi connection (just like a hotel). You perhaps would need to use a "travel router" instead of the RT-AC86U.
 
Not really. the topmost box says "Disconnected". so I must have something set wrong in the wireless configuration. AFAIK, in order to change such settings, I need to reset the router and redo the configuration, is that right?

Oh, also, it seems to come up, after starting the bridge, with a different IP address, and I have had trouble finding it. is there some easy way? (probably overlooking something, again.) I am NOT running windows, so the utility ASUS offers won't do me any good.

Fred
 
I think I may have misunderstood the nature of your internet connection. I thought that the "facility WIFI" was your own personal internet connection, like the Comcast one, but delivered over Wi-Fi. It now sounds like this is a shared internet service, much like a hotel might provide. If that's the case then it's quite likely this won't work as it won't allow more than one client to connect over a single Wi-Fi connection (just like a hotel). You perhaps would need to use a "travel router" instead of the RT-AC86U.
I don't think that is the case. there is no problem with roaming the facility with a portable device and your connection follows you around. we have no control over which AP our devices connect to, and experience shows me that the specific AP changes from time to time even for a stationary device.

the schematic shown on the page where you see that image you sent (https://kmpic.asus.com/images/2020/07/29/4881324e-0fb1-41df-8117-275fc652eaff.png) doesn't show quite what I want to do... which is shown below:

building wifi ==== wifi bridge (RT-AC86U) === cable to LAN router === LAN router (RT-AX86U Pro)
the "cable to LAN router" runs from LAN port on the AC86U, to the WAN port on the AX86U.

the RT-AC86U is in "media bridge" mode. the RT-AX86U Pro is in normal router mode.

This works fine (for some values of fine, as I described in my original post) when using the Raspberry PI, and I want to see if I can use my now-spare RT-AC86U to replace it (hoping for better thruput).

I appreciate your attempts to help, and if you can offer any further assistance now that you understand the configuration, I'd still appreciate it.

Thanks again!

Fred
 
How have you configured the Raspberry Pi? I suspect you need a device that supports a WISP type of connection, which the Asus does not.
 
Last edited:
I live in an apartment complex that provides wifi, but not cabled network.

I moved here from my house where I had a wired LAN.

this facility did not have wifi until recently, so we all used Comcast internet, so when I moved here I just plugged the Comcast cable into my router, and everything in my LAN behaved exactly as before.

Now, I am using the wifi via a Raspberry Pi (4B) configured to bridge the wifi to my LAN. It works great, mostly, but there are a couple of issues:
1: I get only 40-60 MBpS from a wlan where I should be able to get several times that. I suspect the Pi's WIFI just doesn't work very fast. I also find I am always assigned only a 20 MHz channel width, never 40 or 80 or 160 or ...., so maybe the Pi just doesn't do extended channel widths.
2: something causes a wifi disconnect every 24 hours. I don't THINK it is on my end, but the tech folks here are singularly unhelpful, so finding another way to bridge my LAN to wifi may be an instructive experiment.

So, I would love to use my (now replaced) RT-AC86U (running latest Merlin release for that platform) as a bridge to replace the Pi (for testing purposes, at minimum, if not permanently) to see if the router can improve either of those two issues.

Trouble is, I am sufficiently ignorant of how such things work, that I have not been able to get the router's bridge mode to do what I want to do. I am hoping/expecting that it can connect via WIFI to the facility WIFI (at a specific SSID or MAC) and bridge that network to my new router (RT-AX86U) via ethernet. I tried configuring that, based on the really scanty hints in the Asus documentation, but the instant I enable the bridge the LAN connection stops working.

I'd be very grateful if any of you can help enlighten me on (1) is it even possible to do this? and (2) how I might make it work.

Thanks in advance for any guidance you may offer!

Fred
Do you have a physical IP address?
 
There's no such thing as a physical IP address. Maybe you mean a public or reserved/fixed address.
Wrong. That's your way. My way is different. If I say like a public or reserved or fixed address. Some people say "My IP address is 192.168.1.1". I do this it works great.
 
Wrong. If we don't explain about it like that some users say "My IP address is 192.168.1.1". I do this it works great.
This makes no sense. Deliberately using the wrong words to describe something will just create confusion.
[Post has been edited by moderator.]
 
Last edited by a moderator:

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top