Slower download speed through RT-AC87U with 1Gbps internet

goldenegg

Regular Contributor
My home internet connection was recently upgraded to a plan with 1Gbps download speed. With a wired connection directly to the cable modem, I get ~980Mbps download through Speedtest.net. The same test with a wired connection through the AC87U provides ~750Mbps.

I don't have QOS enabled on the router and the cable modem is in bridge mode, so there's no overhead of having multiple firewalls in play.

Any thoughts? I'm running firmware 3.0.0.4.380_3459
 

doczenith1

Very Senior Member
Under LAN>Switch Control is NAT Acceleration set to Disable or Auto? If set to Auto what is the level of acceleration is shown to the right of the selection box? Are FA (Flow Acceleration) and CTF (Cut Through Forwarding) are both enabled? With NAT Acceleration set to auto and both FA and CTF enabled I get around 940 Mbps up and down with negligible cpu usage. With only CTF enabled (due to AiProtection turned on) I still get close to 940 Mbps up/down but cpu core 1 hits 100% utilization during the speed test.

When was the last time you did a factory reset to defaults on the router? And do you typically do a reset after upgrading firmware? Might be worth it to do a reset and minimally configure the router to check speeds.
 

goldenegg

Regular Contributor
Under LAN>Switch Control is NAT Acceleration set to Disable or Auto? If set to Auto what is the level of acceleration is shown to the right of the selection box? Are FA (Flow Acceleration) and CTF (Cut Through Forwarding) are both enabled?
It's auto and shows CTF is enabled. How do I go about enabling FA?

I do a full factory reset before upgrading new firmware and have the router scheduled to auto reboot every 2 days.
 

doczenith1

Very Senior Member
You should be doing the factory reset after upgrading the firmware so that it loads the proper default values for the new firmware version. Another big no-no is loading a saved configuration from a previous firmware version. If you do a very minimal setup then FA should be enabled. Items that can disable FA include QoS, AiProtection and I think the Traffic Analyzer that has shown up in the more recent firmware versions.

What kind of cpu usage are you seeing during the speed test? And are you using the exact same speed test location when comparing speeds? I've found that some of the speedtest.net loactions are not capable of providing gigabit speed tests.
 

goldenegg

Regular Contributor
I meant to say I do a full reset before AND after upgrading to a new firmware.

I don't have QoS or AiProtection enabled. Traffic Analyzer is also off and there's no setting to disable the Traffic Monitor. AiCloud is also disabled.

The only things I configure are the following:

1 - Channels for both wifi frequencies
2 - Port forwarding for one port
3 - DDNS

Other than that, everything else remains standard config.

EDIT:

I should note that I get full gigabit speed on my local network. The drop in speed is only for internet access.
 
Last edited:

doczenith1

Very Senior Member
I use port forwarding also and can get FA to enable. What is the cpu usage during the speed test? If it's under 100% then the issue is probably not do to NAT on the router.
 

goldenegg

Regular Contributor
~55% on both cores.

EDIT:

Accidentally was using wi-fi for that test. On wired, it jumps between mid 50's to mid 80's on core 1 and mid 40's to mid 70's on core 2.
 
Last edited:

follower

Senior Member
I meant to say I do a full reset before AND after upgrading to a new firmware.

I don't have QoS or AiProtection enabled. Traffic Analyzer is also off and there's no setting to disable the Traffic Monitor. AiCloud is also disabled.

The only things I configure are the following:

1 - Channels for both wifi frequencies
2 - Port forwarding for one port
3 - DDNS

Other than that, everything else remains standard config.

EDIT:

I should note that I get full gigabit speed on my local network. The drop in speed is only for internet access.
Do not use 'MAC Clone': empty the space
Disable 'Jumbo Frame'
 

CJazz

New Around Here
I'm actually jumping on a few of these to day the same thing as I've been dealing with an ornery RT-AC87R (RT-AC87U) and after trying every configuration under the son I lost it.

If you haven't, make sure to update any Networking driver you have. It won't fix it 100% of the time and it sounds stupid, but PC and Server drivers are notoriously bug prone and often get updates. It's not uncommon to see a NIC that works great with one device and works poorly with another. It's also not uncommon for a refresh to have a bug in it which is why in DC environments people will frequently upgrade until they find a stable driver and then halt upgrades until they hit another problem or a security flaw forces the issue.

Basically, lots of behaviors disguise themselves as "Network Problems" and you can spend days and weeks trying everything only to find out nothing works - because the part you take for granted as working is not.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top