YazFi [SOLVED v2] YazFi - no internet on secondary wan (eth8)

amplatfus

Senior Member
Hi,

While on secondary WAN, YazFi clients are offline. On primary WAN all are fine.
I am looking to find the root cause.
Could you please help?

Code:
wl01_ENABLED=true
wl01_IPADDR=192.168.2.0
wl01_DHCPSTART=2
wl01_DHCPEND=250
wl01_DNS1=192.168.2.1
wl01_DNS2=192.168.2.1
wl01_FORCEDNS=true
wl01_ALLOWINTERNET=true
wl01_REDIRECTALLTOVPN=false
wl01_VPNCLIENTNUMBER=1
wl01_TWOWAYTOGUEST=false
wl01_ONEWAYTOGUEST=true
wl01_CLIENTISOLATION=true

Thank you,
amplatfus
 
Last edited:

bennor

Senior Member
While on secondary WAN, YazFi clients are offline. On primary WAN all are fine.
Can confirm. No issues with Primary WAN and YazFi. When Primary WAN is offline and Secondary WAN (USB modem device) is enabled YazFi clients do not have internet access; cannot access, ping, etc internet addresses. However if WiFi client is moved to non YazFi main Wifi then they are able to use Secondary WAN to access internet.

@Jack Yaz, any suggestions on scripting in YazFi or a user script to fix when a Secondary WAN is used?

Edit to add: I see the following usb0 entries in the YazFi diagnostic iptables file:
Code:
-A POSTROUTING -o usb0 -j PUPNP
-A POSTROUTING ! -s 192.168.0.125/32 -o usb0 -j MASQUERADE
....
-A FORWARD ! -i br0 -o usb0 -j other2wan
-A FORWARD -i br0 -o br0 -j ACCEPT
....
-A INPUT_PING -i usb0 -p icmp -j DROP
 
Last edited:

amplatfus

Senior Member
Is that typo really there?
Thank you. Only typo in my case. I am fixing it now.
Can confirm. No issues with Primary WAN and YazFi. When Primary WAN is offline and Secondary WAN (USB modem device) is enabled YazFi clients do not have internet access; cannot access, ping, etc internet addresses. However if WiFi client is moved to non YazFi main Wifi then they are able to use Secondary WAN to access internet.

@Jack Yaz, any suggestions on scripting in YazFi or a user script to fix when a Secondary WAN is used?

Edit to add: I see the following usb0 entries in the YazFi diagnostic iptables file:
Code:
-A POSTROUTING -o usb0 -j PUPNP
-A POSTROUTING ! -s 192.168.0.125/32 -o usb0 -j MASQUERADE
....
-A FORWARD ! -i br0 -o usb0 -j other2wan
-A FORWARD -i br0 -o br0 -j ACCEPT
....
-A INPUT_PING -i usb0 -p icmp -j DROP
Thank you for testing and sharing. I didn't find anything yet.


I will update here if I find the magic command :) I would like that you will too :)

Edit1: as an update I discovered that if I do a falover/ and failbak from primary to sedondary (usb modem) the no internet messje persist only while on Secondary WAN during this test.

Kind regards,
amplatfus
 
Last edited:

amplatfus

Senior Member
Solved: It was related to ASUS fail over I guess. After using Dual WAN Failover Script v1.3.7 YazFi is working fine even after fail over to secondary and fail back to primary.
I will mark the thread as solved.

Edit1: is seems that there is still a compatibility issue: now blocked to Obtaining IP address

Thank you!
 
Last edited:

amplatfus

Senior Member
Hi,

In the meantime I discovered what would be the cause. When switched to Secondary WAN below iptable rule would be the same:
Bash:
YazFiREJECT all -- wl0.1 !eth0

Please, from where I have to change it from eth0 to eth8?

Thank you,
amplatfus
 

amplatfus

Senior Member
Hi,

[SOLVED]
The fix for this is to do replacecement of all IFACE_WAN occudences from YazFi script
Original value:
Bash:
IFACE_WAN="$(nvram get wan0_ifname)"

Value in order to make it works on Secondary WAN:
Bash:
IFACE_WAN="$(nvram get wan_ifname)"

Raised also on thread related to Dual WAN Failover Script

Thank you,
amplatfus
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top