YazFi Solved: YazFi on AC3200, unable to config

EmeraldFlame

New Around Here
Router: RT-AC3200
Firmware: AsusWRT-Merlin 384.13_10
YazFi Version: 4.4.2

Issue: Web UI just directs me to a 404 page and I'm unable to configure things. I'm unsure if this is due to an incompatibility or not, as the latest forum post I see and the Github page seems to be in conflict with each-other (Github states 384.13_4 or later, first post in this thread states 384.15). Additionally using option 3 within the CLI sends me to a fully blank config file/text editor, and I'm not seeing any sort of guide on what format this is intended to be in or how to create the configuration.

Any guidance available on this?
 

bennor

Very Senior Member
Router: RT-AC3200
Firmware: AsusWRT-Merlin 384.13_10

Any guidance available on this?
Yes. Your using well out of date Merlin firmware (June 28, 2020), and the RT-AC3200 is no longer being supported by Asus-Merlin. If possible see if the john9527 fork of Merlin supports your router, and if it does; install later fork version and reinstall YazFi and retest if it works. If john9527 fork no longer support the AC3200 then you may be out of luck when it comes to having the current version of YazFi on the AC3200. Not sure if @Jack Yaz keeps old versions on hand, versions that may run properly on the older firmware. It is likely due to the old firmware you are running that YazFi isn't properly running on that non currently supported router.
 
Last edited:

EmeraldFlame

New Around Here
Yes. Your using well out of date Merlin firmware (June 28, 2020), and the RT-AC3200 is no longer being supported by Asus-Merlin. If possible see if the john9527 fork of Merlin supports your router, and if it does; install later fork version and reinstall YazFi and retest if it works. If john9527 fork no longer support the AC3200 then you may be out of luck when it comes to having the current version of YazFi on the AC3200. Not sure if @Jack Yaz keeps old versions on hand, versions that may run properly on the older firmware. It is likely due to the old firmware you are running that YazFi isn't properly running on that non currently supported router.

Unfortunately, 384.13_10 is the newest firmware that's available for the AC3200.

I understand that this is an older firmware, but from what I'm seeing it should still be compatible with at least the core features via the CLI. The YazFi GitHub repo is stating that only 384.5 is needed for the core features and that the WebUI needs either 384.15 or 384.13_4 or newer. So the official documentation on GitHub is incorrect?
 

bennor

Very Senior Member
I understand that this is an older firmware, but from what I'm seeing it should still be compatible with at least the core features via the CLI. The YazFi GitHub repo is stating that only 384.5 is needed for the core features and that the WebUI needs either 384.15 or 384.13_4 or newer. So the official documentation on GitHub is incorrect?
You may want to contact @Jack Yaz directly to enquire about the YazFi core running on your older firmware and if the system requirements information on YazFi GitHub and in the YazFi 4.x thread is out of date. You may want to see if he'll spare some time to review a YazFi CLI generated diagnostics file that you can send to him.

Couple of basic suggestions if you haven't tried them already. Uninstall YazFi. Reformat the JFFS partition using the reformat JFFS upon router reboot option (assuming no other scripts are installed/running). Then install YazFi directly, don't use AMTM to install YazFi. (Remember to set erase JFFS at reboot back to off.)
Code:
/usr/sbin/curl -fsL --retry 3 "https://jackyaz.io/YazFi/master/install/YazFi.sh" -o /jffs/scripts/YazFi && chmod 0755 /jffs/scripts/YazFi && /jffs/scripts/YazFi install
Then access the YazFi CLI via SSH and configure it (option 3) when finished configuring, select option 1 in the CLI to apply the changes.
 

EmeraldFlame

New Around Here
Couple of basic suggestions if you haven't tried them already. Uninstall YazFi. Reformat the JFFS partition using the reformat JFFS upon router reboot option (assuming no other scripts are installed/running). Then install YazFi directly, don't use AMTM to install YazFi. (Remember to set erase JFFS at reboot back to off.)
Code:
/usr/sbin/curl -fsL --retry 3 "https://jackyaz.io/YazFi/master/install/YazFi.sh" -o /jffs/scripts/YazFi && chmod 0755 /jffs/scripts/YazFi && /jffs/scripts/YazFi install
Then access the YazFi CLI via SSH and configure it (option 3) when finished configuring, select option 1 in the CLI to apply the changes.

Yeah, I've unfortunately tried this multiple times already which lead to my original post.
When I run the install, and then use option 3 to configure, I get a couple errors stating the file doesn't exist and then when I choose a text editor from the next option selection, it just takes me into a brand new, blank file. I have no options in it to configure.

Errors when running option #3
1660417931689.png


Opening Config with Nano:
1660417977463.png


@Jack Yaz any advice in my scenario? Anything I can do here?
 

bennor

Very Senior Member
When I run the install, and then use option 3 to configure, I get a couple errors stating the file doesn't exist and then when I choose a text editor from the next option selection, it just takes me into a brand new, blank file. I have no options in it to configure.
If you haven't done so already, navigate to the /jffs/addons/YazFi.d folder and see what files are listed there (via the ls command). There should be several files including the config file listed in that folder. Example of files listed for me:
LICENSE
YazFi_www.asp
config.bak
userscripts.d
README.md
config
configHgHgAv

One can see the example config file at the YazFi GitHub: https://github.com/jackyaz/YazFi/blob/master/YazFi.config.example
One could copy that text (all of it) and paste it into the option 3 (nano), edit the file to match your needs, then save it and apply the changes (option 1).
 

EmeraldFlame

New Around Here
If you haven't done so already, navigate to the /jffs/addons/YazFi.d folder and see what files are listed there (via the ls command). There should be several files including the config file listed in that folder.
Hey this did it, and I'm actually up and running now. I didn't even think to check this because the /jffs/scripts/YazFi install command didn't seem to hit any terminating errors. But that folder was indeed empty.
I opened up the install script and added -v onto a couple of curl commands and it looks like I was hitting an SSL error on the downloads, so nothing downloaded but terminating errors were not thrown so I still got sent to the configuration menu and things seemed normal.

Upon discovering that, I downloaded things manually, moved them into the needed location and ran the install script again.

Worked perfectly. WebGUI is working as expected, and I've been able to configure the DNS on my guest networks. I've tested it and those DNS and client isolation rules are working as expected.

Thanks for putting me onto the right path here, I really do appreciate it.
 

TheLyppardMan

Very Senior Member
I've never used YazFi before, but I understand that it could be used to achieve better security when using IoT devices. I don't plan to have a lot of those, but at the moment I have a Honeywell evohome controller that manages my programmable radiator TRV's and which connects to the internet for remote control, primarily from the dedicated mobile app. The controller doesn't need access to any devices on my LAN, so I have moved it onto Guest Network 1 (2.4Ghz band) with isolation from other devices on my LAN. The other devices are two security cameras, which store their video clips on a share on my Synology DiskStation. They do not have access to any other shares on the NAS. What I would ideally like to do is prevent the security cameras from having access to any other devices on my LAN. If this scenario is possible using YazFi, could someone tell me precisely how to set it up? My NAS has a static IP address on the LAN (xxx.xxx.xxx.200), as do a few other devices. The router is xxx.xxx.xxx.254 and the DHCP range is xxx.xxx.xxx.100 to xxx.xxx.xxx.199.
 

bennor

Very Senior Member
I've never used YazFi before, but I understand that it could be used to achieve better security when using IoT devices. I don't plan to have a lot of those, but at the moment I have a Honeywell evohome controller that manages my programmable radiator TRV's and which connects to the internet for remote control, primarily from the dedicated mobile app. The controller doesn't need access to any devices on my LAN, so I have moved it onto Guest Network 1 (2.4Ghz band) with isolation from other devices on my LAN. The other devices are two security cameras, which store their video clips on a share on my Synology DiskStation. They do not have access to any other shares on the NAS. What I would ideally like to do is prevent the security cameras from having access to any other devices on my LAN. If this scenario is possible using YazFi, could someone tell me precisely how to set it up? My NAS has a static IP address on the LAN (xxx.xxx.xxx.200), as do a few other devices. The router is xxx.xxx.xxx.254 and the DHCP range is xxx.xxx.xxx.100 to xxx.xxx.xxx.199.
You may want to start a new post/thread since this one involved a completely different issue with YazFi and has been marked as solved.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top