Some VPN Director options do not appear (using YazFi for guest VLAN networks)

voipbob

New Around Here
I am trying to use the VPN Client on my RT-AC86U. When I select the “VPN Director” option for the “Redirect internet traffic through tunnel”, the following are missing on the panel for the VPN Director rules:
  • The “add new rule +” option above the VPN Director rules table.
  • The column titled “Edit” to the right of the “Iface” column.
I have included two snapshots of the panel showing the VPN Director settings on the VPN client page – the first when the “Redirect all to VPN” option is disabled on the YazFi tab under the Guest network settings; the second snapshot when this option is enabled for all 3 guest networks. In both cases, the “add new rule +” option above the Director rules table is missing. In the second case, the “Edit” column to the rigfht of the "Iface" column is also missing.

This issue occurred when running on RT-AC86U with firmware 386.3_2 as well as after upgrading to 386.4_beta2 after performing an upgrade-in-place from 386.3_2 with no reset. (Hence, I am not posting it in the 386.4 beta forum entry.)

I don’t know if using the YazFi addon has any effect on this behavior. I mention this only for completeness.
 

Attachments

  • VPN Client Setup Page - Example 1.png
    VPN Client Setup Page - Example 1.png
    303.3 KB · Views: 51
  • VPN Client Setup Page - Example 2.png
    VPN Client Setup Page - Example 2.png
    336 KB · Views: 54

Jack Yaz

Part of the Furniture
VPN Director rules are set on the vpn director tab, and not each individual client
 

voipbob

New Around Here
Maybe I am missing something, but on the VPN Client page after selecting “Redirect Internet traffic through tunnel → VPN Director (policy rules)” and doing an “Apply”, I do not see the expected “add new rule +” option above the Director rules table (see the first attachment) which is how I believe I can add Director rules.

However, after doing this if I go to the Guests → YazFi tab, if I select the “Redirect all to VPN” for the guest VLAN networks, and I do an Apply, and I then go back to the VPN Client page, I see the expected entries in the Director rules table (see the second attachment), but I do not see the “Add new rule” option above the Director rules table nor do I see the “Edit” column to the right of the “Iface” column as I expected. Incidentally, after doing this the traffic from my guest VLAN networks is being properly routed through the VPN.

My issue is that I do not see the “add new rule +” option or the “Edit” column by the Director rules table as I expected and used to see. I want to be able to manually add Director rules using the “add new rule +” option.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top