Speed drops when QoS or Bandwidth Limiter enabled on RT-AC68U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

swbrains

Occasional Visitor
I have an RT-AC68U running Merlin firmware version 386.1_2. I recently upgraded to an ISP plan with 400 mbps. I got the full speed when my PC was wired to the modem but not through the router. I tried changing various settings, but eventually resorted to resetting the router to factory defaults, which resolved the issue and gave me > 400 mbps through the router.

I then added back my various router configuration settings that I had before and when I enabled QoS for the bandwidth limiter feature so I could limit some specific devices (but not my PC), I noticed that the speed on my desktop dropped back down to 200+ mbps (I was limiting several devices to 10 mbps, not 200). Disabling QoS again did not bring back the full speed, even though I tested my speed before enabling each feature and enabling QoS caused this drop. I then restored back to factory settings and left QoS off but re-enabled my other configuration settings and retained full speed > 400 mbps. I made a backup of this configuration.

I ran this way for a couple of weeks.

I recently changed my guest networks (2.4 and 5 GHz) so that they would have have the bandwidth limiter feature turned on. Again, my PC is hardwired -- not using the guest networks. I noticed today that my PC speedtest came back around 200 mbps again. Disabling this feature in the guest network configuration did not bring back full speed to my PC. I restored the router to the firmware backup I made and again full speed was restored on my PC.

Is there some reason why enabling QoS bandwidth limiter (but not including my PC in the list of limited devices) *or* enabling the bandwidth limiter for the wireless guest networks would affect the internet throughput to my hardwired PC? And why disabling it doesn't resolve the issue, and a full restore or reset is required to truly undo that setting?

Thanks!
 

dave14305

Part of the Furniture
Bandwidth limiter disables hardware acceleration. The AC68U CPU will struggle over 200 Mbps without HW Acceleration.

Disabling QoS and re-enabling full NAT acceleration on the LAN / Switch Control ? Page should bring it back to full speed after a reboot. It’s been a while so the location of the option may be incorrect.
 

swbrains

Occasional Visitor
It turns out enabling the bandwidth limiter did not disable NAT acceleration. But when I disable the QoS setting, it warns me it will also disable the bandwidth limiter for the guest networks. So it seems it's not possible to have full throughput speed and the bandwidth limiter on the guest network at the same time.
 

Diamond67

Senior Member
I have Traffic Analyzer - Statistic enabled (ON).

Tools - Sysinfo - Network of my router shows
HW acceleration Disabled - incompatible with: IPTraffic

So, enabling Traffic Analyzer disables HW acceleration as well. But limiting the download speeds to 200 mpbs or so doesn't cause me trouble because I have 100 mbps cable modem connection at the moment.

And my NAT Acceleration is set to Auto:

LAN Switch Control - Copy.png
 
Last edited:

RMerlin

Asuswrt-Merlin dev
So, enabling Traffic Analyzer disables HW acceleration as well.

IPTraffic and Traffic Analyzer are not the same thing. IPTraffic is enabled on the Tools -> Other Settings page.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top