What's new

Strangest Network Switch Problem Ever

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Regular Contributor
I need advice concerning one of the most unusual switch problems I’ve experienced in all my years of home networking. The antagonists in this story are a D-Link DGS-108 gigabit switch, A TRENDnet TEG-S80g gigabit switch, a TRENDnet TEW-638APB wireless access point, and a Netgear GS108 gigabit switch.

In my baseline configuration, the D-Link switch is connected to an Ethernet wall jack which leads down to the basement and a SMC switch which is connected to a TRENDnet TEW-633GR wireless router. The D-Link switch supports my PC, a laptop docking station, two network printers (one color laser, one multi-function inkjet), the TRENDnet wireless access point, and a spare connection for when I work on other people’s computers. In a desire to gain some advertised power savings and use equipment from the same vendor in my network, I purchased the TRENDnet gigabit switch and swapped out the D-Link unit for the new device.

The TRENDnet switch worked for only a few days, after which I got a “limited availability” warning on my network connection. I went through all the usual troubleshooting steps and traced the problem to the switch because once I put my old D-Link back in the network path, everything worked again. I sent the TRENDnet back to the vendor as defective and requested a new one.

The replacement switch arrived and I plugged it in, only to have my network connectivity lost instantly. I was never able to get it to work with the TRENDnet switch in the path. I swapped my D-Link back in again and sent the TRENDnet back for a refund.

I ordered a Netgear GS108 switch and plugged it into the network path, immediately bringing down my connection once more. This made me suspect that something other than the switch was at fault. I unplugged all network cables and started to add them back in one at a time, first the wall jack connection, then my PC and so on. It wasn’t until I plugged the TRENDnet TEW-638APB wireless access point into the switch that everything dropped out. I unplugged the access point to determine if it was the device or the cabling; the network connection was immediately restored.

I left it running for some time without powering up the access point, and the network seemed fine. When I powered up the access point, the network stayed connected briefly but soon went down again. I took the Netgear out of the network path and put the D-Link back into the mix.

What is it about the access point that would screw up a switch? I have always been able to plug things into a switch and power it up without thinking, and it always worked. If you have any insight into this, I’d appreciate it. Also, if anyone wants a barely used Netgear switch…
So, no matter what switch you plug it into, the TRENDnet TEW-638APB brings down the entire switch?

When you plug in the AP, what are the switch link/activity ports doing?
Lights are active as if everything's OK, but...

...the network is down. The only switch that operates unfazed by the TRENDnet access point is the D-Link I was trying to replace with a "green" gigabit switch. I don't know if this helps, but it seems that the network loses the ability to communicate with the router; it can't obtain a new network address.
I was trying to see if all the lights were flashing constantly, indicating a network storm. Sounds like it wasn't.

Just a wild guess, but might be a grounding / power problem. Is there anything odd about the Trendnet AP's power supply connection? Are the switch and AP plugged into the same outlet or power strip?
No Power Issues of Which I'm Aware

The switch and AP are plugged into separate APC UPS devices. The power adapter looks pretty conventional to me. And I'm still not clear why two different switches from two different manufacturers would have the same problem but the older switch isn't even fazed by the AP. Every time I swapped the D-Link back into the network path, it simply worked. I don't know what is inherent in the design of the other two switches where they wouldn't just work.


Think I'll stick with what I have

0oooo. Just for yucks, plug everything into the same UPS.

If I had time to disconnect the working switch, put in the one that's having the problem, and reroute the plugs so they're sharing the same UPS, I would. I think I'll be content with the current setup and leave the mystery of why the other two switches freaked out when the AP was connected to it.

Thanks for the assistance; I was hoping you'd seen something like this before. I've been using unmanaged switches in my home networks for over 11 years and they were always just plug and play. Very strange.
Did you ever figure out what this is? I know this post is old as hell so it's a shot in the dark - have a TrendNet TEW-638PAP with a connection to a dell powerconnect 6224 - network dropped the other day, traced it to a switch the wireless was plugged into - was able to powercycle the switch, direct connect and view a TON of discarded packets coming from port 9 - ended up being the wireless access point. On the latest firmware right now - thinking about throwing it in the trash, have a lot of other 638PAPs across the network.


Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!