What's new

Update last RT-N16 firmware file with new headers

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
So I foolishly updated my RT-N16 to latest version of firmware from Asus Support page ( and now I'm getting a lot of connection drops - sometimes I have to restart the router manually to get back online.
Then I wanted to downgrade or switch to different firmware, but I was unable to, because I got the message:
Invalid Firmware Upload
To comply with regulatory amendments, we have modified our certification rule to ensure better firmware quality. This version is not compatible with all previously released ASUS firmware and uncertified third party firmware. Please check our official websites for the certified firmware.

From what I've read on this forum it seems that there is a new verification method for the firmware files and RMerlin implemented it in his latest versions. But obviously, the last firmware files that supported RT-N16 (from 2015) don't have it.

RMerlin: could you please repackage the last firmware that supported RT-N16 (filename RT-N16_3.0.0.4_378.50_0.trx) with these new headers, so I can downgrade? It would help me and other people with these issues a lot.

Use the Firmware Recovery tool to bypass the validation system.

I also advise against running such an old firmware, due to the numerous security issues that were discovered since then. You should switch to @john9527 's fork.
Thanks RMerlin and Jack Yaz for pointing me to the correct firmware.
I needed to to this:
1. Factory reset the router with Asus firmware.
2. Disconnect all ports from the router except Port #1 where I connected my PC.
3. Configured static IP Mask Gateway on my PC.
4. Put router in Rescue mode (had to be patient as it worked only after 2nd or 3rd try).
5. Flash AsusWRT Merlin firmware using Asus Firmware Recovery Tool.
6. Factory reset the router again.
Voila, it worked.

Thanks again, hopefully the firmware and these steps will also help other people.
did you factory reset after upgrading ? as this can help

Pre-380_3xxx releases can no longer be flashed on top of newer firmwares due to the firmware validation process Asus implemented last year because of the new FCC requirements becoming active.
so I've tested the firmware you mentioned (374.43 LTS (V27E5)), but the router still restarted at least once per hour.
I've also tried different firmware (Advanced Tomato) with same result.
I've tried lowering the connections limit to 5000 and also decreasing CPU frequency to 300 (from 450MHz), without luck.
Is it time to buy new router?
Thanks pete y testing, that was genius!
Seems it helped, so it wasn't FW problem after all.
Anyway, I've learned a lot here, thank you all!
RT-N16 also has a bad capacitor problem - search for threads about repairing the hardware.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!