USB not mounting on reboot

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

YGator

New Around Here
I have a RT-AC86U and when I reboot for an update or just to reboot my USB drive does not get mounted and hence skynet does not start up. I believe this used to work way back (unsure how long ago, but it has been a least a year or two). So if I am on the premises I have to pull the USB drive out and put it back in. Then I manually start skynet. I have a lot of devices that I block from the Internet and this gives them a chance to get out before I do all this. I believe I tried different combinations of USB2 and USB3, but honestly I cannot remember any more. In my upgrade today to 386.3_2 the drive was plugged into the USB 3 port and was set to USB 2 mode. The USB 2 mode is because I thought I read long ago about an issue with USB 3. The USB drive is a Samsung USB 3.1 Bar 32GB.

How can I get the USB drive to automount on reboots? Is there still issues with USB 3 on this firmware/router?

If this is corrected would there still be a time period in which skynet blocked devices could get to the Internet?

Thanks
 

Jeffrey Young

Senior Member
Have you tried another usb key? Yours may be on life support.
 

eibgrad

Very Senior Member
Unfortunately, not all USB drives work well w/ the router. They can be quite finicky. Esp. w/ more modern USB drives. It's why I keep a bunch of ancient Kingston DataTraveler USB drives around, despite their meager capacity (e.g., 1-4GB).
 

YGator

New Around Here
Thanks for pointing me in the right direction.

I believe it works now (only rebooted once). It was not the drive, but how it was formatted. Everything (Linux and Windows) read the drive fine, but looking closer the entire drive (/dev/sda) was the volume with no standard DOS 4 entry partition table. So I recreated the drive with the partition table and made partition 1 (/dev/sda1) the rest of the drive and it mounted when I plugged the drive in and also mounted when I did a reboot.
 

Jeffrey Young

Senior Member
Perfect. Glad it all turned out
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top