VLAN for IPTV

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

johnnyboy

Occasional Visitor
Johnnyboy or RMerlin: Any changes for compiling one fixed FW also for N66U?

I am struggling with the exact same issues.
I'll compile fw for N66U for your temporary use this afternoon (about 2 hours later).
 

zorb

New Around Here
How long does it usually take after GPL code release until the official firmware is available?
 

johnnyboy

Occasional Visitor
Last edited:

zorb

New Around Here
Didn't break my router and internet works at the same time with IPTV. Thank you johnnyboy! There is just one more issue left.

Now the IPTV box has access only to traffic with VLAN tag 252. It also needs normal internet connection for full functionality. Does anyone know if tagged and untagged VLAN to the same port is possible?
 
Last edited:

zorb

New Around Here
Johnnyboy,

Perhaps your IPTV fix is only for port 3 and not 4?

Zorb, does it work on port 3?
Tried both ports already. With both builds compiled by johnyboy.

The fix solved the problem of broken internet in all other ports when VLAN tagged traffic is going to port 4.
 
Last edited:

zorb

New Around Here
Could it be possible to assign also untagged traffic to port 4 with
"nvram set vlan?ports="
or
"nvram set port?vlans="
-command? Or would I need to use both?
 
Last edited:

Kozlor

New Around Here
I have same problem with ASUS AC68U

All router ports 1-4 are working correctly when i don't use IPTV.
When i turn IPTV on (http://192.168.1.1/Advanced_IPTV_Content.asp) sheet and connect IPTV box to port 4
Settings are:
Select ISP profile: Manual
Internet: VID empty Prio 0
LAN port 4: VID 4 Prio 0
LAN port 3: VID empty Prio0

then i lose internet connection in Port 3, but IPTV is working in port 4.

If i try to change settings as follows and connect IPTV box to port 3
Select ISP profile: Manual
Internet: VID empty Prio 0
LAN port 4: VID empty Prio 0
LAN port 3: VID 4 Prio0

then i lose internet connection in Port 4, but IPTV is working in port 3.

In ports 1 and 2 ineternet is working fine all the time.

It would be not a problem, if i need only 1. and 2. port for internet.
But i need 3 ports. I dont want to lose 1 port because IPTV.

I did try this setting in Merlins firmware and in official. Result was same.


Is there any solution for that. Seems it is related to VLANs.

Thanks!

Ivo.
 

wiz

Regular Contributor
If I look at the schematic, it seems internet is going through vlan1 and is natted.

What would happen if you select vid 1 for internet, and vid 6 to port 3 or port 4?
 

Algimantas

Occasional Visitor
I have the same ISP as Andrius does (Teo)

My router is RT-AC56U running 374.32_2 (Merlin build)

I got IPTV working by setting ISP profile (LAN->IPTV) to manual and setting VID 6 to LAN port 4 and leavint PRIO with 0 (I have only 1 tv so I don't need port 3) Internet and LAN port 3 form is left blank. This way both internet and IPTV works normally, however this setup causes traffic monitor to stop working.

There is another way to solve this problem and with this solution traffic monitor works fine. We do a factory reset and change vlans directly in the nvram.
So with my vlans which are:
VLAN1 (untagged) Internet
VLAN6 (tagged) IPTV
Code:
nvram set vlan6ports='3 4t 5'
nvram set vlan6hwname='et0'
nvram set vlan1ports='0 1 2 5*'
nvram commit
reboot
The only things that I can't get to work are IGMP and udpxy.
I want to watch IPTV on my laptop aswell.
Any ideas ?
 

Phk

Occasional Visitor
Greeting everyone,

I'm running latest Merlin build on AC66u (3.0.0.4.376.45_0).

IPTv settings for Voice+Net+IPTV are a no-go, but i've manage to fix it using the nat-start script with:

robocfg vlan 101 ports "0t 4u"

I've used GUI and set:
Internet vlan 100
Port 4 vlan 101 (for voice)
Port 3 vlan 105 (for IPTV)

Only one VLAN gets untagged, and that is the one that is set in the NVram variable: switch_stb_x. In my case, port 3 was always good (i had TV) but port 4 was always a mess.

So using ssh i tried "robocfg show" and I saw that vlan 101 didn't even exist.
A simple ' robocfg vlan 101 ports "0t 4u" ' did fix everything. So i put it in nat-start script..

@RMerlin, can you please confirm this is actually a bug? Is seems that only the switch_stb_x port gets untagged and correctly created! Weird!

Thank you,
Artur Phk
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top