What's new

VPN: if "Tunnel activated" ->internet on mobile phone is laggy, all the rest clients work fine

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

StefMug

New Around Here
greetings from austria
(excuse my english)

if I activate the VPN-tunnel, the connection to NordVPN is online and stable.
so thats ok.
Problem with activated VPN-tunnel: my smartphone gets laggy internet connection, but every other device works without delay.

For example:
- i start speedtest-app on phone (android), it needs 10 seconds to get internet-connection.
- or: if i click any internet-shortcut (amazon.com), chrome-app opens immediately but then stops loading the page for 10 seconds, and after this 10sec.-full-stop the page fades-in in one twinkle.
by setting VPN-Tunnel off, my phone gets internet without delay and everything works fine.

My knowledge level: "every client which is not specified in VPN_director, will pass through WAN"
As I want only one client (set-top-box) passing through VPN, I enabled VPN-director rule only for this device, and all other devices are forced through WAN by default.

How can i get rid of this Lag in loading time when VPN activated?
Maybe there is a problem with the ip adress from the phone and the router needs seconds to decide which tunnel to use VPN vs. WAN?
(phone's ip adress is set to automatic DHCP)

attached file: vpn_client_settings
 
file
 

Attachments

  • vpn_client.jpg
    vpn_client.jpg
    52.4 KB · Views: 24
Your screenshot is virtually unreadable but it looks like you have "Accept DNS Configuration" set to Strict. Try setting that setting to Disabled as a test.
 
sorry, upload from phone.

yes it's "strict"
in WAN my DNS is: 1.1.1.1
seems there are Problems with NordVPNs DNS at "strict"

thanks for the hint, seems its a DNS-Problem.
Found some more infos here:


quote:
"It's always been my recommendation (even beyond this specific problem) that users define custom DNS servers on the WAN (e.g., 8.8.8.8 and 8.8.4.4), configure the VPN w/ "Accept DNS configuration" set to Disabled, and bind those same DNS servers using policy based routing (as destination IPs) to the VPN. So when the VPN is NOT active, 8.8.8.8 and 8.8.4.4 are accessed over the WAN. When the VPN is active, you're using the same servers, but they're now accessed over the VPN. It avoids all this nonsense w/ push'd DNS servers NOT being within the scope of the tunnel, the router refusing to bind them to the tunnel, this handling of DNS for VPN and non-VPN clients differently, etc. It just makes things simpler and more predictable."
 

Latest threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top