What's new

Windows Home Server Help - cannot locate server

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Wombat

Occasional Visitor
I recently converted an old desktop workstation (P4) into a NAS running Windows Home Server w/Power Pack 1. The install on the server went smoothly, but when I attempt to install the WHS Connector Software on my new desktop machine, I keep getting an error message telling me that the software cannot find the server.

The only thing I can think of that may be causing the problem is that I have a non-standard (but not unusual) networking setup. I have Verizon FiOS, which uses a router (Actiontek MI424-WR) with very little memory, so I set it up as a bridge to allow me to use a D-Link DI-624 as my router. The DI-624 is, in turn, connected to a Gigabit switch. My desktop machine is also connected to the Gigabit switch, but the Actiontek router is not (it is connected only to the DI-624). When I have tried to install the connection software, I connect the server directly to the switch that the desktop machine is connected to.

More details about how I set up the MI424-WR and DI-624 are at http://www.dslreports.com/forum/r17679150-Howto-make-ActionTec-MI424WR-a-network-bridge in case that is relevant to my problem.

Is there some inherent flaw in my setup or anything I should check? I appreciate your help. And to think, in part I chose WHS for its supposed ease of use and stability versus FreeNAS, etc.! Thanks.

Steve
 
The Actiontec shouldn't have anything to do with your problem since it is on the WAN side of your router.

What are the IP addresses of the WHS NAS and the new machine that you are having the problem with? Can you ping the WHS NAS from the new machine.
 
Thank you for your assistance. The machine that won't connect has an IP address of 192.168.0.100. Here is the strange part. The WHS NAS does not seem to have an IP address. When I run "ipconfig" from the command line, I get "Windows IP Configuration" and a new prompt. Also, the WHS NAS cannot connect to the internet no matter what I do--I just had to activate my copy of WHS by telephone because it could not establish a connection. Any thoughts? Thank you again.

Steve
 
Last edited:
Sounds like you have something wrong with either the physical connection to the WHS NAS (try another cable or switch port), or a bad NIC.
 
I had tried other switch ports but not another cable (silly, I know). I have now tried three with the same result, so just about all I am left with is the NIC. I will try replacing that this evening and will report my results. The card was working a few months ago when the machine was my primary workstation, but you never know. Thanks again.

Steve
 
I installed a new NIC in the WHS machine, but WHS did not support it (using drivers on the CD did not work, either). But I ruled out a problem with the NIC another way: I had a Linux distro on a CD laying around (Mepis) and ran it on the server. I was able to get an IP address and go online with both the new NIC and the old, original NIC. It seems that is not the problem.

With all hardware problems seemingly eliminated, it appears there must be a problem with my install of WHS. Maybe it is simply incompatible with both NICs (the one built into my ASUS motherboard and the Netgear card I bought today). I will first try reinstalling WHS and starting from scratch, though, in case there was some problem at install. If that does not work, I will try to find a compatible/WHS certified NIC (if such a list exists).

Do you have any ideas other than those I have suggested? Thank you.

Steve
 
Are there any NIC errors reported by Device Manager? Does repairing the connection do anything?

The WHS installer should tell you if it couldn't install your NIC. If you run a reinstall, keep an eye out for those messages.

WHS is based on Windows Server 2003, so be sure you have NIC drivers for that OS.

Before you install an add-in NIC, disable the onboard NIC via the BIOS.
 
I will check on those things and report back soon. This one is really confounding me. Thanks again for your assistance.

Steve
 
I may have another clue to what my problem is (which I discovered based on your questions). In the device manager, under Network Adapters, it lists only "1394 Net Adapter." Under "Other devices," which is denoted with a question mark, among the many items listed is "Ethernet Controller." I am thinking that WHS does not recognize (or have drivers for) the ethernet controller built into my Asus motherboard. Under "Network Connections" in the Control Panel, all I have is "1394 Connection." I think that explains why I essentially get nothing when I run ipconfig.

I think my next step is to order a Windows Server 2003 compatible gigabit NIC (there are not many, but there are a few on Newegg) and see what happens when I install it. I will take your suggestion and disable the onboard NIC when I do. Thank you for the further good suggestions!

Steve
 
What is the model of the motherboard? You should be able to download a NIC driver that will work. The Asus website might have one specifically for WHS or one from Win XP might work. If you find out the manufacturer of on board NIC they might also offer drivers.

00Roush
 
Thanks, 00Roush. It is an Asus P5LD2 Deluxe, and the Asus site indeed has an updated driver that is supposed to work for Windows 2003 (which I understand WHS to be based upon) and XP. I will give it a try and report back. Thanks again.

Steve
 
Thanks, 00Roush. It is an Asus P5LD2 Deluxe, and the Asus site indeed has an updated driver that is supposed to work for Windows 2003 (which I understand WHS to be based upon) and XP. I will give it a try and report back. Thanks again.

Steve

Your welcome.

From what I found the network card is a Marvell 88E8053 so you can also download the drivers directly from their website. This is the same PCIe based card I am running on my server and I use the Marvell drivers as they are the most up to date.

00Roush
 
Brilliant! That did the trick. In retrospect, I feel a little foolish for not trying to download updated drivers, but I guess I have gotten used to things just working.

Thanks for the info about the exact model of the card, too. I may go to Marvell for the most up-to-date drivers, too. Because it is a PCIe-based gigE card, it should be able to saturate the pipe, right? (PCI-based cards do not have adequate bandwidth to use all of the gigabit ethernet standard's capacity, correct?)

I appreciate all of the help. I will share my further adventures using WHS, which so far appears promising.

Steve
 
Similar threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top