YazFi YazFi 4.4.2 Dns Leak After Update AX-88U (surfshark Vpn)

Asusrouterlover

Regular Contributor
Hi

I Just Update to version 4.4.2 YazFi and I have Dns Leak After This Update

every thing Was Work Fine With Defulet Yazfi setting 4.4.1 Dns 8.8.8.8 And 8.8.4.4

i use surfshark vpn for my guest network with smart dns enable

can some one help
 

ZebMcKayhan

Very Senior Member
Not too familiar about how openVPN works, so I dont know how much help I will be.

1) How is your setup intended to work?
2) what's your vpn dns setup?
3) how are you testing for leaks?
4) any other type of dns you have setup? Stubby, Unbound et.c?
5) have you tried: Reboot? Restart vpn connection?

Perhaps the output of:
Code:
iptables -nvL PREROUTING -t nat
iptables -nvL YazFiDNSFILTER -t nat
Will provide some info about what is happening.

Normally YazFi provides "Exclusive" dns setup were firewall rules are redirecting clients to the dns you enter in gui which superseeds the router dns-filter.

//Zeb
 

Asusrouterlover

Regular Contributor
1) How is your setup intended to work?
Vpn Access Without Dns Leak

2) what's your vpn dns setup?
i use YazFi Setup i dont change any thing

3) how are you testing for leaks?
ipeak.net

4) any other type of dns you have setup? Stubby, Unbound et.c?
nextdns for home use

5) have you tried: Reboot? Restart vpn connection?
yes
 

SomeWhereOverTheRainBow

Part of the Furniture
Hi

I Just Update to version 4.4.2 YazFi and I have Dns Leak After This Update

every thing Was Work Fine With Defulet Yazfi setting 4.4.1 Dns 8.8.8.8 And 8.8.4.4

i use surfshark vpn for my guest network with smart dns enable

can some one help
Make sure your VPN server is set like this

1645495535149.png


report back if this fixes your issue.

Also make sure any custom DNS used in Surfshark VPN are not overriding your options specified by YazFi

Both of these not set correctly could be resulting in your DNS leak.

(This is assuming you are intending to use 8.8.8.8 and 8.8.4.4, which is what your post sounds like. )


*** Browser Cache just caught up, Just realized this has been dealt with, disregard and carry on***
 
Last edited:

Asusrouterlover

Regular Contributor
Make sure your VPN server is set like this

View attachment 39704

report back if this fixes your issue.

Also make sure any custom DNS used in Surfshark VPN are not overriding your options specified by YazFi

Both of these not set correctly could be resulting in your DNS leak.

(This is assuming you are intending to use 8.8.8.8 and 8.8.4.4, which is what your post sounds like. )


*** Browser Cache just caught up, Just realized this has been dealt with, disregard and carry on***
just restart the router every thing work fine again
thanks for tip
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top