What's new

YazFi YazFi Guest Network unable to access Pi-Hole DNS server

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

I remembered that I had manually assigned IP address to the devices, so I undid that. On Pi-hole, I changed it to the DNS settings to "Respond Only to WLAN0" and also "Permit all Origins' but no luck with either of them. I have tried using Unbound (installed on Pi-Hole) vs. using Cloudflare, but it has made no difference.

For some reason, when I use my Chromebook on the YazFi network, it gives me the "Sign in to Network" but I don't have a Captive Portal installed as far as I know.
I can get rid of the "Sign in to Network" by disabling the "Force DNS"
 
You appear to be having issues that others, using YazFi, haven't experienced or reported (AFAIK). As prior posts indicate YazFi clients can access internet without having to enable or disable Two Way to Guest and or disable Allow Internet Access in YazFi. Further the Pi Zero W does work wirelessly with YazFi as previously shown. Maybe its time for a hard factory reset and reconfiguration (without importing a saved router.cfg file) if you continue to have these strange issues.
Pi-hole has log entries for my Chromebook when it is connected to my main WIFI AP.
Is your router configured for Wireless Router mode or Access Point (AP) mode? YazFi generally only works when the router is configured for wireless router mode. YazFi does not work with AP or AiMesh nodes or clients connected through those nodes or AP's.
You may want to list your settings outside of YazFi (i.e. post screen shots) as you may have some other setting outside of YazFi causing one or more of your problems.
What firmware version are you running on your router?
How do you have Pi-Hole configured on the router? Did you put the Pi-Hole IP address in the LAN DHCP DNS fields or the WAN DNS fields?
Are you using LAN > DNS Director and or LAN > Route? If so, how is it configured?
How is your Guest Network page configured? Did you inadvertently disable Access Intranet on the Guest Network page? DO NOT change the Guest Network Access Intranet option from Enable. YazFi needs that option set to Enable.
How is your router connected to broadband? Are you using it behind another router?

Guest Network.jpg
 
Last edited:
You appear to be having issues that others, using YazFi, haven't experienced or reported (AFAIK).
Sorry for the late reply. I had a busy last couple days. I got so frustrated, I factory reset my router and manually entered every setting ... and ... I got the exact same error. I eventually figured out the issue. I had set up a firewall on the pi-hole a while back that only allowed the main LAN. The solution was to add the subnets to the pi-hole's firewall.

@bennor Thanks for your patience and willingness to help. Hopefully, someone else can benefit from my mistake.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top