YouTube cast to Samsung TV

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

jc_hwz

Occasional Visitor
Hi,
I just upgrade my router to RT 5300 with two AC 1900P in Aimesh network. I see the problem that once the Samsung tv connect to 5G_1, and I cannot cast youtube to Samsung tv youtube app by mobile device, but shield tv(andriod tv box) is working find. The situation is that, I don't see the samsung tv selection in my youtue cast to device list. However, once the tv connect to 5G_2 or plug into the Ethernet port, the tv come up to my Mobile device youtube cast to device list and can cast to the tv without any problem. before, I upgrade to RT 5300, it is running well in my two AC 1900p aimesh system. The only different is the AC1900P is running in upper channel(149 - 161), and in RT 5300 5G_1 is running lower channel(36). Is any one has the idea, what cause the problem.
 

OzarkEdge

Part of the Furniture
Hi,
I just upgrade my router to RT 5300 with two AC 1900P in Aimesh network. I see the problem that once the Samsung tv connect to 5G_1, and I cannot cast youtube to Samsung tv youtube app by mobile device, but shield tv(andriod tv box) is working find. The situation is that, I don't see the samsung tv selection in my youtue cast to device list. However, once the tv connect to 5G_2 or plug into the Ethernet port, the tv come up to my Mobile device youtube cast to device list and can cast to the tv without any problem. before, I upgrade to RT 5300, it is running well in my two AC 1900p aimesh system. The only different is the AC1900P is running in upper channel(149 - 161), and in RT 5300 5G_1 is running lower channel(36). Is any one has the idea, what cause the problem.

I thought an AiMesh node uses the same channel per band as the AiMesh router (?).

Also, I believe AiMesh disables one 5.0 GHz band, so all clients should use the other 5.0 GHz band. If you had tri-band nodes, then AiMesh would use the 2nd 5.0 GHz band for their wireless backhaul (whether they're wired or not). Regardless, the 2nd 5.0 GHz band on the 5300 remains unavailable to clients.

Are you using identical SSIDs?

OE
 

jc_hwz

Occasional Visitor
I thought an AiMesh node uses the same channel per band as the AiMesh router (?).

Also, I believe AiMesh disables one 5.0 GHz band, so all clients should use the other 5.0 GHz band. If you had tri-band nodes, then AiMesh would use the 2nd 5.0 GHz band for their wireless backhaul (whether they're wired or not). Regardless, the 2nd 5.0 GHz band on the 5300 remains unavailable to clients.

Are you using identical SSIDs?

OE
Yes I am using identical ssids. Also I checked it all the nodes will use the same chanel as 5g_2 even though I use Ethernet backhaul. So nodes use upper channel and the main router use lower Chanel, but the all three of them use 5g_1 ssids in mesh
 

OzarkEdge

Part of the Furniture
Yes I am using identical ssids. Also I checked it all the nodes will use the same chanel as 5g_2 even though I use Ethernet backhaul. So nodes use upper channel and the main router use lower Chanel, but the all three of them use 5g_1 ssids in mesh

Separate SSIDs are advised when Smart Connect node band steering is not supported. The 1900s do not support Smart Connect.

If you have not reset the current firmware (all routers) before configuration, I would do that first and then configure from scratch, using separate SSIDs (and fixed channels).

Then troubleshoot the casting issue, if it persists.

OE
 

jc_hwz

Occasional Visitor
Separate SSIDs are advised when Smart Connect node band steering is not supported. The 1900s do not support Smart Connect.

If you have not reset the current firmware before configuration, I would do that first and then configure from scratch, using separate SSIDs (and fixed channels).

Then troubleshoot the casting issue, if it persists.

OE
I am not using smart connect since first day I used 5300
 

OzarkEdge

Part of the Furniture

L&LD

Part of the Furniture
The TV won't even use the 100Mbps potential, let alone the simple connection speed of 866Mbps. ;)
 

OzarkEdge

Part of the Furniture
It seems fix the problem by connecting tv by Ethernet port, but the downside is that samsung Tv Ethernet port only 100mbs, and connecting to 5g wifi is much faster which up to 866mbs

If wired is an option, I would consider it the best option and assume the Samsung WiFi has an issue... and move on.

BTW, do you have router WiFi/Professional/Airtime Fairness and Universal Beamforming disabled for the troubled bands/clients? Some older WiFi adapters can have trouble with these settings enabled.

OE
 

OzarkEdge

Part of the Furniture
It is possible to switch the channel like that, 5g_1 use upper channel, and 5g_2 use lower channel, but I don't see this option in the settings

Given that AiMesh commandeers the 2nd 5.0 GHz band for AiMesh use only, be sure to only connect your clients (TV and casting devices) to the same other 5.0 GHz band.

OE
 

jc_hwz

Occasional Visitor
If wired is an option, I would consider it the best option and assume the Samsung WiFi has an issue... and move on.

BTW, do you have router WiFi/Professional/Airtime Fairness and Universal Beamforming disabled for the troubled bands/clients? Some older WiFi adapters can have trouble with these settings enabled.

OE
Thanks so much. I find what caused it. Once I disabled universal Beamforming, everything is working fine for me.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top