OpenVPN incredibly slow compared to PPTP

Discussion in 'Asuswrt-Merlin' started by davewolfs, Jan 7, 2013.

  1. davewolfs

    davewolfs Occasional Visitor

    Joined:
    Jan 4, 2013
    Messages:
    36
    I have an issue with OpenVPN on slow connections. It is significantly slower than the routers built in PPTP. To the point that it is simply not usable for certain things eg VNC/RDP.

    I don't know if this is the nature of the protocol or how I have set things up.

    I do see the following warnings from my client logs:

    NOTE: Options consistency check may be skewed by version differences
    WARNING: 'version' is used inconsistently, local='version V4', remote='version V0 UNDEF'
    WARNING: 'dev-type' is present in local config but missing in remote config, local='dev-type tun'
    WARNING: 'link-mtu' is present in local config but missing in remote config, local='link-mtu 1560'
    WARNING: 'tun-mtu' is present in local config but missing in remote config, local='tun-mtu 1500'
    WARNING: 'proto' is present in local config but missing in remote config, local='proto TCPv4_SERVER'
    WARNING: 'comp-lzo' is present in local config but missing in remote config, local='comp-lzo'

    Is it possible that compression is not being used?
     
  2. Log in / Register to remove this ad

  3. davewolfs

    davewolfs Occasional Visitor

    Joined:
    Jan 4, 2013
    Messages:
    36
  4. rlcronin

    rlcronin Regular Contributor

    Joined:
    Sep 14, 2010
    Messages:
    104
    So I tried switching to UDP as a test, and when connecting from my Android phone from outside my local LAN (turned off WIFI and just used 4G) it seemed to work OK. But then I tried some test clients on my LAN and it would not connect. The log showed packets being rejected with a message suggesting I needed to remove a "remote" option. I researched that and found advice to change the "client" in my config file to "float". I did that but that failed as well. Any ideas?
    --
    bc
     
  5. rlcronin

    rlcronin Regular Contributor

    Joined:
    Sep 14, 2010
    Messages:
    104
    I discovered that to make it work from inside my LAN I had to replace the server IP with its local IP (e.g. it is normally set to nnnnnnnn.asuscomm.com, to get a client to connect from inside the LAN when the protocol is UDP, I have to set it to 192.168.1.1). It'd be nice if there were some way to configure the client so that it would just work whether I am inside or outside the LAN (e.g. some config parameter in the server to tell it that 192.168.1.1 is equivalent to whatever nnnnnnnn.asuscomm.com resolves to).
    --
    bc
     
  6. RMerlin

    RMerlin Part of the Furniture

    Joined:
    Apr 14, 2012
    Messages:
    14,625
    Location:
    Canada
    Try creating a custom hosts file with an entry containing your IP and your hostname. See the Wiki for info on how to use custom config files. It should hopefully override any DNS entry.
     
  7. RMerlin

    RMerlin Part of the Furniture

    Joined:
    Apr 14, 2012
    Messages:
    14,625
    Location:
    Canada
    Performance-wise, OpenVPN will always be slower than PPTP because it uses much stronger encryption. There are ways you can limit the performance impact tho (for my own use, the RDesktop performance is pretty close to what it used to be when I was using PPTP).

    - Limit your keys to 1024 bits (anything higher is overkill and will degrade performance)
    - Stick with one of the AES encryption codecs as these are optimized in the OpenSSL implementation of Asuswrt-Merlin
     

Share This Page