5GHz wifi does not turn off completely - smart connect - smart home devices

styrbiorn

Occasional Visitor
So I have an AIMesh running Merlin 386.4 on all devices. After setting this up last week (hard reset all the devices and flashed new firmware and re-added all the nodes after the main router didn't want to recognise one node via cable) I had issues with getting my Sonoff ZBBridge to connect to the network.

I tried resetting the ZBBridge, re-adding etc, no luck
Only way i could make it connect to the Wifi was to completely disable 5GHz in settings under Wireless/Professional.
I had previously turned off Smart Connect as it caused my MacBook to be unable to connect properly to the Wi-Fi.

So now to my new issue. the ZBBridge has been working fine since above changes until tonight when it was again offline.
When I went into my routers settings it still looks like 5Ghz is turned off with the half green icon at the top.
1645134356718.png

BUT
when i start and look using Netspot for example the main router has no 5GHz but the AIMesh nodes seem to broadcast the SSID hemma_5G
1645134501147.png

I don't know it this changed on its own or if it was on at node level since I disabled it a few days ago but the signal strength was just to weak to disturb the ZBBridge..

But I was under the impression that it should be disable everywhere (cant see how it should be otherwise.
At first I thought it might be the 5G band being used.

So I like what Smart Connect should do, it looks and feels neat but apparently might cause issues.
I like the bandwidth of 5GHz but i need 2.4Ghz as all the smart home devices only supports 2,4GHz...

And the ZBBridge has a bug in my opinion, it should not care if there is a 5GHz SSID, but on the other hand so does then a few other devices. I also have some RBG spotlights from another brand (don't remember) that also could not pair properly when SmartConnect was on.


Any suggestions are welcome! workarounds, help troubleshooting, mistakes I have made..
 

bbunge

Part of the Furniture
You might want to flash Merlin 386.5 alpha 1 on your router then flash the Asus factory firmware on the nodes. There is no advantage in an AiMesh system to have Merlin on the nodes.
Leave the 5 GHz turned on and use Dual Band Smart Connect (my Mac and iOS devices have no issues with SmartConnect). In fact set the 2.4 GHz to 20 MHz auto channel and 5 GHz to 80 MHz auto channel (or if AX use 20, 40, 80, 160 MHz) but do not enable DFS check box.
Set up a 2.4 GHz guest WIFI for the IOT devices with just WPA2-Personal. Disable Intranet recommended.

Auto channel sounds counter productive. But trust your router and clients to connect to the channel and band they want to connect to.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top