AC-RT68U - Guest wifi - how to get devices to see each other

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

robmash

New Around Here
Hi all,

I currently have set up a Guest wifi SSID for all my IOT devices - all the things in my home that need internet access but I don't completely trust. I have created this using the guest network feature and I have set 'Access Intranet' to 'disable'. As a result, the devices on this network have access to the internet but cannot see anything else on the network.

I would like to configure the guest network so the devices can see all other devices on the network, but nothing on my main network. I have found another thread trying to do the same thing (https://www.snbforums.com/threads/allow-computers-on-the-guest-network-to-see-eachother.26869/), which suggested adding an entry into iptables to allow this:
-A FORWARD -i wl0.2 -o wl0.2 -j ACCEPT (From what I can tell, wl0.2 is the guest network interface)

After adding this line, I still cannot get devices on the guest network to see each other. Can anyone explain what is going on, and what I can do to make this work?

Thanks in advance.
 

ganas

New Around Here
Hi all,

I currently have set up a Guest wifi SSID for all my IOT devices - all the things in my home that need internet access but I don't completely trust. I have created this using the guest network feature and I have set 'Access Intranet' to 'disable'. As a result, the devices on this network have access to the internet but cannot see anything else on the network.

I would like to configure the guest network so the devices can see all other devices on the network, but nothing on my main network. I have found another thread trying to do the same thing (https://www.snbforums.com/threads/allow-computers-on-the-guest-network-to-see-eachother.26869/), which suggested adding an entry into iptables to allow this:
-A FORWARD -i wl0.2 -o wl0.2 -j ACCEPT (From what I can tell, wl0.2 is the guest network interface)

After adding this line, I still cannot get devices on the guest network to see each other. Can anyone explain what is going on, and what I can do to make this work?

Thanks in advance.
I was in the same boat as you, and YazFi was the answer for me.

Both of the links below will show you how to install it, and the setting you are looking for is at the very bottom of the screenshots - "Client isolation" (Should Guest Network radio prevent clients from talking to each other? (true/false)).

The "One way to guest" feature of YazFi was also key for me, so clients on the main network could still access my IoT devices, but not vice-versa. I'm a huge Home Assistant user, so this option was key for HA to access items on my IoT network.

I do utilize pretty much all of the other features as well... separate ip ranges for that network are nice, as is having a Guest Network that is always on a vpn, but these aren't necessary for what you're trying to achieve.

I hope that helps!

All credit, and all my thanks, goes to @Jack-yaz

SNB link
Github link
 

robmash

New Around Here
Thankyou so much for the suggestion! I hadn't actually flashed to Asus-merlin but this gave me the reason to do so, and I discovered it was far simpler than I had expected (Last time I did this was getting DD-WRT onto a WRT54G which was a much more complex process! This time I even retained my config). Installing YasFi was simple as well, and now everything is running exactly how I want it.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top