AC66_B1 firmware upgrade unsuccessful - can't upgrade or downgrade....

NX3

Occasional Visitor
I have a AC66_B1 running firmare "RT-AC68U_384.17_0" that refuses to upgrade or download firmware. I've hard reset / factory reset it several times, I've tried Asus recovery tool as well but all say firmware upgrade unsuccessful.

It has been running 386.1 when this started. I read the release thread and a oouple of others had the same issue. I tried all the solutions from the thread including downgrade which worked, dropping to 384.17 as I had it saved locally. Its now on 384.17 but stubbonly stuck no matter what I try and I'm stuck for ideas....

Its been hard reset on 384,17, it won't upgrade or downgrade. Asus recovery tool gets to about 48% then says failed. I can access the router and everything works but I'd like to upgrade to a newer version and resolve this really.
 

NX3

Occasional Visitor
I've flashed the latest release from Asus so back to being to change firmware now.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top