ntpMerlin Addons page blank 386.2_beta3

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Jack Yaz

Part of the Furniture
Does this include updates for addons in general on AX11000 (and presumably other HND routers) where the /opt partition isn't mounted R/W at boot time?

In particular, I want my swapfile and Entware and other addons on a USB drive, which requires re-mounting /opt to /tmp/opt at just the right time during the boot process. I have tried to address this with a script called asus_usbmount.sh that I saw posted somewhere in other thread by Arul Selvan and tinkered with it, but can't quite get it work. I can reinstall all my addons after every boot to get them working again, (they all retain history), but hoping for a more permanent/supported solution from the Addon script authors. I hope you know about the issue I'm referring to, and many thanks for the add-ons!
not an issue im familiar with, it sounds like you're running stock firmware and not merlin?
 

archiel

Senior Member
I am having the same issue with the GUI addon tabs having gone awry after upgrading to 386.2. All of the userx.asp pages are there (diversion, skynet, scMerlin, spdMerlin, ntpMerlin and unbound) and can be accessed manually, but were not showing in the correct places. After various uninstalls and re-installs everything is in its place except the unbound stats page.

It does appear the issue is with the install process for the unbound stats page @juched being out of sync with those by @Jack Yaz, as if I add this before the other scripts then they do not load in Addons correctly. For now I removed each script, rebooted and the reinstalled, but did not install the unbound stats until last. It is not showing in the scMerlin WebUI listing but can be accessed directly.

I added the unbound GUI at 10:47 this morning from unbound_manager advanced, Option 3, sgui
Code:
A:Option ==> sgui

unbound-control set_option 'extended-statistics yes' ok
Option Auto Reply 'y'
        Installing GUI TAB to Graphically display unbound stats.....
        unbound_stats.sh downloaded successfully
        unboundstats_www.asp downloaded successfully
        unbound_log.sh downloaded successfully

##
# ____ ___     ___.                            .___   _________ __          __
#|    |   \____\_ |__   ____  __ __  ____    __| _/  /   _____//  |______ _/  |_  ______
#|    |   /    \| __ \ /  _ \|  |  \/    \  / __ |   \_____  \   __\__  \   __\/  ___/
#|    |  /   |  \ \_\ (  <_> )  |  /   |  \/ /_/ |   /        \|  |  / __ \|  |  \___ \
#|______/|___|  /___  /\____/|____/|___|  /\____ |  /_______  /|__| (____  /__| /____  >
#             \/    \/                  \/      \/          \/           \/          \/
## by @juched - Generate Stats for GUI tab - v1.4.0
## with credit to @JackYaz for his shared scripts

Mounting Unbound_Stats.sh WebUI page as user6.asp
Saving MD5 of installed file /jffs/addons/unbound/unboundstats_www.asp to /jffs/addons/unbound/www-installed.md5

##
# ____ ___     ___.                            .___ .____
#|    |   \____\_ |__   ____  __ __  ____    __| _/ |    |    ____   ____
#|    |   /    \| __ \ /  _ \|  |  \/    \  / __ |  |    |   /  _ \ / ___\
#|    |  /   |  \ \_\ (  <_> )  |  /   |  \/ /_/ |  |    |__(  <_> ) /_/  >
#|______/|___|  /___  /\____/|____/|___|  /\____ |  |_______ \____/\___  /
#             \/    \/                  \/      \/          \/    /_____/
## by @juched - Process logs into SQLite3 for stats generation - v1.5

unbound_log.sh
Logfile used is /opt/var/log/unbound.log
Date used is 2021-04-04 (7 days ago is 2021-03-28)
Date used is 2021-04-04 (30 days ago is 2021-03-05)
Creating nx_domain table if needed...
Deleting old nx_domain records older than 7 days...
Creating reply_domain table if needed...
Deleting old reply_domain records older than 7 days...
Creating rpz_events table if needed...
Deleting old rpz_events records older than 30 days...
(unbound_log.sh): 32119 Processed 11480 reply_domains...
Removing reply lines from log file...
Running SQLite to import new reply records...
(unbound_log.sh): 32119 Processed 0 nx_domains...
Removing always_nxdomain lines from log file...
Removing static/transparent lines from log file (for performance)...
Running SQLite to import new nx records...
(unbound_log.sh): 32119 Processed 0 RPZ events...
Removing RPZ event lines from log file...
Running SQLite to import new rpz event records...
All done!
Calculated Cache Hit Percentage: 89.44
Adding new value to DB...
Calculating Daily data...
Calculating Weekly and Monthly data...
Outputting histogram performance data...
Outputting answers data...
Outputting top blocked domains...
Outputting top replies ...
Outputting daily replies ...
Calculating DNS Firewall data...
Outputting DNS Firewall Hits ...
and all that is showing in messages at that time is
Code:
Apr  4 10:49:44 RT-AX88U-5050 rc_service: httpd 1306:notify_rc start_scmerlingetaddonpages
Apr  4 10:49:44 RT-AX88U-5050 custom_script: Running /jffs/scripts/service-event (args: start scmerlingetaddonpages)
Apr  4 10:49:44 RT-AX88U-5050 custom_script: Running /jffs/scripts/service-event-end (args: start scmerlingetaddonpages)
Apr  4 10:49:54 RT-AX88U-5050 rc_service: httpd 1306:notify_rc start_scmerlingetaddonpages
Apr  4 10:49:54 RT-AX88U-5050 custom_script: Running /jffs/scripts/service-event (args: start scmerlingetaddonpages)
Apr  4 10:49:54 RT-AX88U-5050 custom_script: Running /jffs/scripts/service-event-end (args: start scmerlingetaddonpages)
Apr  4 10:50:42 RT-AX88U-5050 rc_service: httpd 1306:notify_rc start_scmerlingetaddonpages
Apr  4 10:50:42 RT-AX88U-5050 custom_script: Running /jffs/scripts/service-event (args: start scmerlingetaddonpages)
Apr  4 10:50:42 RT-AX88U-5050 custom_script: Running /jffs/scripts/service-event-end (args: start scmerlingetaddonpages)
Apr  4 10:52:13 RT-AX88U-5050 rc_service: httpd 1306:notify_rc start_scmerlingetaddonpages
Apr  4 10:52:13 RT-AX88U-5050 custom_script: Running /jffs/scripts/service-event (args: start scmerlingetaddonpages)
Apr  4 10:52:13 RT-AX88U-5050 custom_script: Running /jffs/scripts/service-event-end (args: start scmerlingetaddonpages)
 

Jack Yaz

Part of the Furniture
Those with missing tabs, try uninstalling the unbound gui until it is fixed. I'm unable to reproduce sny mounting failures with unbound gui disabled
 

MvW

Senior Member
FWIW: I don't have unbound or it's GUI installed, and I have had zero issues so far.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top