AiMesh Daisy-Chain Topology

bitberserker

New Around Here
RT-AC5300 x3, 3.0.0.4.384_45717-gadd52a8

Daisy-chain Topology for AiMesh

The last node in the chain reverts to a star topology using the master router 5ghz dedicated backbone radio despite having terrible signal quality (-87dbm), and great quality to the middle node (-60dbm), after changing any of the wireless settings. This never corrects itself without hard rebooting the last node in the chain (is there a way to reboot a single node in AiMesh yet?).

I have roaming assistant turned on on the dwb radio, but the AiMesh nodes don't respect it.

I intend to eventually run a wired backbone, but am stuck with this for now.

I want to be able to configure topology, or for the nodes to occasionally reassess the ideal topology; is there something I can do to enforce the daisy-chain?
 

OzarkEdge

Part of the Furniture
RT-AC5300 x3, 3.0.0.4.384_45717-gadd52a8

Daisy-chain Topology for AiMesh

The last node in the chain reverts to a star topology using the master router 5ghz dedicated backbone radio despite having terrible signal quality (-87dbm), and great quality to the middle node (-60dbm), after changing any of the wireless settings. This never corrects itself without hard rebooting the last node in the chain (is there a way to reboot a single node in AiMesh yet?).

I have roaming assistant turned on on the dwb radio, but the AiMesh nodes don't respect it.

I intend to eventually run a wired backbone, but am stuck with this for now.

I want to be able to configure topology, or for the nodes to occasionally reassess the ideal topology; is there something I can do to enforce the daisy-chain?

Ad-hoc thought... how far apart are your routers... three AC5300 in too small an area might be confusing, signal-wise.

OE
 

bitberserker

New Around Here
Ad-hoc thought... how far apart are your routers... three AC5300 in too small an area might be confusing, signal-wise.

OE
I'm in a large 3000sq ft older home with lots of plaster and brick. The problem is that both the master router and the end node are near windows on a common side of the house, so the end node does get a very faint unobstructed 5ghz signal. According to the wireless log, the signal never gets any stronger than -87dbm.

When the daisy-chain is working, everything is stable, and I get a strong 5ghz signal everywhere, and am seeing solid throughout on the end node. The topology only seems to change when the radios are reset on the master (which makes sense as the middle node isn't available yet), but it never seems to reevaluate.
 

bitberserker

New Around Here
You can do that either via Asus router app or over the SSH.
How do I target just the end node? I can't manage it via IP, I just get redirected to the master. If I hit the reboot button, it only restarts the master, and leaves me in the same scenario with a broken topology. I haven't tried SSH, if I can connect to the known IP of the end node, that will probably be the best solution for me.
 

bitberserker

New Around Here
How do I target just the end node? I can't manage it via IP, I just get redirected to the master. If I hit the reboot button, it only restarts the master, and leaves me in the same scenario with a broken topology. I haven't tried SSH, if I can connect to the known IP of the end node, that will probably be the best solution for me.
SSH worked for me, that's tremendously useful. Thanks!
 

Asad Ali

Very Senior Member
I couldn't find the option for an individual router in the app (first time using the app).
Open the app and go to devices tab from the bottom bar, select your AiMesh node from the devices list. On next page click on 3 vertical dots on the top right corner of the page and select 'reboot device'
 

bitberserker

New Around Here
RT-AC5300 x3, 3.0.0.4.384_45717-gadd52a8

Daisy-chain Topology for AiMesh

The last node in the chain reverts to a star topology using the master router 5ghz dedicated backbone radio despite having terrible signal quality (-87dbm), and great quality to the middle node (-60dbm), after changing any of the wireless settings. This never corrects itself without hard rebooting the last node in the chain (is there a way to reboot a single node in AiMesh yet?).

I have roaming assistant turned on on the dwb radio, but the AiMesh nodes don't respect it.

I intend to eventually run a wired backbone, but am stuck with this for now.

I want to be able to configure topology, or for the nodes to occasionally reassess the ideal topology; is there something I can do to enforce the daisy-chain?
I'm able to force the topology reestablish with either of the following commands over SSH to the end node without a full reboot:

Drop the connection on the dwb radio
Code:
wl -i eth3 deauthenticate
OR

Restart the dwb radio
Code:
wl -i eth3 down && sleep 10 && wl -i eth3 up
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top